Package Details: superlu 5.2.1-2

Git Clone URL: https://aur.archlinux.org/superlu.git (read-only)
Package Base: superlu
Description: Set of subroutines to solve a sparse linear system
Upstream URL: http://crd-legacy.lbl.gov/~xiaoye/SuperLU/
Licenses: custom
Submitter: gborzi
Maintainer: valandil
Last Packager: valandil
Votes: 38
Popularity: 1.962198
First Submitted: 2009-05-13 18:28
Last Updated: 2017-10-09 12:38

Latest Comments

valandil commented on 2017-01-01 14:33

Sorry for the delay, I was on Christmas vacation.

I think it might be best for these packages to have their own PKGBUILD. I am not particularly interested in maintaining them, however, as I do not use SuperLU often. If you are interested, then I suggest you go ahead and create the AUR packages ^_^

lahwaacz commented on 2016-12-23 17:04

Would you mind adding also the SuperLU_MT and SuperLU_DIST (sub)libraries to the package? It seems at least petsc, which optionally depends on this package, could make use of it: http://www.mcs.anl.gov/petsc/petsc-current/docs/manualpages/Mat/MATSOLVERSUPERLU_DIST.html

valandil commented on 2016-08-31 12:51

@Thorjelly I can't replicate this on my computer. Are you sure that you have a version of blas installed? If so, which one? Thanks,

valandil commented on 2016-08-26 16:22

I will check this next week, when I come back from vacation.

Thorjelly commented on 2016-08-25 21:48

/tmp/yaourt-tmp-dunder/aur-superlu/src/SuperLU_5.2.0/lib/libsuperlu.a
/usr/bin/ld: cannot find -lblas
collect2: error: ld returned 1 exit status
==> ERROR: A failure occurred in build().

valandil commented on 2016-06-24 15:27

I'll check whether this is really needed and update after the long weekened here in Quebec. Thanks for the info!

janisozaur commented on 2016-06-23 14:23

I think static library needs CFLAGS="-fPIC" FFLAGS="-fPIC" NOOPTS="-fPIC" as well.

valandil commented on 2016-05-20 13:14

yaourt -S --nodeps superlu
yaourt -S armadillo

JohnRobson commented on 2016-05-20 00:05

looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: armadillo: installing superlu (5.2.0-1) breaks dependency 'superlu=4.3'
==> WARNING: Your packages are saved in /tmp/yaourt-tmp-us
==> ERROR: unable to update

valandil commented on 2016-05-16 17:40

I have updated SuperLU to 5.2.0, but I haven't checked the PKGBUILD to make sure everything is correct. If you encounter any issue, please comment here, or contact me via email.

I have done this mostly in preparation for armadillo-7.100.0, so if anyone is willing to take over maintenance of this package, I will gladly delegate this responsability :)

timmyl17 commented on 2016-04-28 17:05

This package has been out of date for almost a year.

xDShot commented on 2015-02-21 05:35

md5sum of superlu_ug.pdf is still not updated.

Manjarohans commented on 2015-02-18 08:58

MAKEPKG was unable to build superlu 4.3 "validating source files with MD5sums .... superlu_ug.pdf ... failed".

How do I solve?

davidovitch commented on 2014-09-21 07:49

The user guide pdf seemed to be have changed since the checksum doesn't match any more. I got this one: 0097d559fa73f8fc182ac05635537454 (md5sum).

gborzi commented on 2012-01-02 13:29

Fixed.

bo0ts commented on 2012-01-02 11:28

The md5sums have changed and need to be updated in the PKGBUILD.

bo0ts commented on 2012-01-02 11:21

Superlu_ug.pdf has changed and the check-sum needs to be updated.