Package Details: superswitcher 0.6-4

Git Clone URL: https://aur.archlinux.org/superswitcher.git (read-only)
Package Base: superswitcher
Description: Powerful window and workspace switching using the Super key
Upstream URL: http://code.google.com/p/superswitcher/
Licenses: GPL
Submitter: Dragonlord
Maintainer: Dragonlord
Last Packager: Dragonlord
Votes: 1
Popularity: 0.003853
First Submitted: 2011-12-18 19:47
Last Updated: 2015-06-28 16:35

Required by (0)

Sources (2)

Latest Comments

mokkurkalve commented on 2013-10-08 01:24

Well as nothing is happening here I made a quick-and-dirty package superswitcher-fixed
https://aur.archlinux.org/packages/superswitcher-fixed/
I'll delete it as soon as something happens here....

Alister.Hood commented on 2013-08-03 10:52

Please update or orphan.

mokkurkalve commented on 2013-07-04 12:43

So this is a complete unified diff of all below to make it compile on Arch.
The usual dance: makepkg -o , patch -p0 , makepkg -e

http://pastebin.com/4Q8jgZPn

(Please fix this....)

mokkurkalve commented on 2013-05-25 13:39

So this is a complete unified diff off all below to make it compile om Arch:

http://pastebin.com/4Q8jgZPn

mokkurkalve commented on 2013-05-25 12:49

Deleting the line
AM_PROG_CC_STDC
from configure.in seems to fix the problem.

mokkurkalve commented on 2013-05-06 00:40

Also after applying Alister.Hoods suggestions it now fails with:

Running intltoolize...
Running aclocal-1.13...
aclocal-1.13: warning: autoconf input should be named 'configure.ac', not 'configure.in'
configure.in:20: error: 'AM_PROG_CC_STDC': this macro is obsolete.
You should simply use the 'AC_PROG_CC' macro instead.
Also, your code should no longer depend upon 'am_cv_prog_cc_stdc',
but upon 'ac_cv_prog_cc_stdc'.
/usr/share/aclocal-1.13/obsolete-err.m4:17: AM_PROG_CC_STDC is expanded from...
configure.in:20: the top level
autom4te: /usr/bin/m4 failed with exit status: 1
aclocal-1.13: error: echo failed with exit status: 1

Alister.Hood commented on 2013-02-10 01:47

It builds if I apply the Gentoo patches:
http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/x11-misc/superswitcher/files/
And run this:
sed -i 's/gdk_display/GDK_DISPLAY_XDISPLAY(&_get_default())/g' src/{superswitcher,thumbnailer}.c

Alister.Hood commented on 2012-07-06 12:26

And here we have yet another case of this:

error: #error "Only <glib.h> can be included directly."
make[1]: *** [dbus-object.o] Error 1

superswitcher-svn has the same issue, too.