Package Details: svg2png 0.1.3-7

Git Clone URL: https://aur.archlinux.org/svg2png.git (read-only)
Package Base: svg2png
Description: Conversion of SVGs to PNGs via cairo
Upstream URL: http://cairographics.org/
Licenses: custom
Submitter: haawda
Maintainer: haawda
Last Packager: haawda
Votes: 37
Popularity: 0.140178
First Submitted: 2008-01-18 19:51
Last Updated: 2015-06-08 22:51

Latest Comments

tobias_de commented on 2012-05-15 20:23

Yea, this is really strange here. It builds sucessfully (with a clean src directory), but links against this old non-existant library.

tobias_de commented on 2012-05-15 20:23

Yea, this is really strange here. It rebuilds sucessfully (without a clean src directory), but links against this old non-existant library.

haawda commented on 2012-05-09 19:38

ldd /usr/bin/svg2png
linux-vdso.so.1 => (0x00007fffa85ff000)
libsvg-cairo.so.1 => /usr/lib/libsvg-cairo.so.1 (0x00007fcd078f4000)
libsvg.so.1 => /usr/lib/libsvg.so.1 (0x00007fcd076e0000)
libpng15.so.15 => /usr/lib/libpng15.so.15 (0x00007fcd074b3000)

try rebuilding

tobias_de commented on 2012-05-09 18:00

The issue is not about building it, but about running it:

ldd svg2png
libpng14.so.14 => not found

It's funny that it successfully builds and links against a nonexistant libpng14 library

haawda commented on 2012-04-28 16:48

No, it does not, builds fine here without libpng14 installed.

yoelion commented on 2012-04-28 15:24

this needs libpng14

Maxr commented on 2011-12-27 22:39

Allright now. Thanks!

Maxr commented on 2011-12-27 22:39

Allright now. Thanks!

haawda commented on 2011-12-27 21:23

As it still builds her with that LDFLAGS unset, I think it is harmless to add it, so I did.

kfgz commented on 2011-12-27 21:19

it has to be added right after "cd $srcdir/$pkgname-$pkgver" or just before configure ;)

kfgz commented on 2011-12-27 21:15

"unset LDFLAGS" in PKGBUILD helps.

kfgz commented on 2011-12-27 21:15

unset LDFALGS in PKGBUILD helps.

haawda commented on 2011-12-26 22:09

namcap does not tell me that something is missing. But I have neither [testing] nor [multilib] activated.

Maxr commented on 2011-12-26 21:57

same here. Maybe something missing?

misc commented on 2011-12-26 21:25

After rebuilding those two I still get the same errors.

haawda commented on 2011-12-26 19:59

Sorry, cannot reproduce. Try to rebuild libsvg-cairo and libsvg.

Maxr commented on 2011-12-26 19:33

Same here. Output: http://pastebin.com/d2a2SAch (libpng 1.4.8-1 extra/multilib)

hcartiaux commented on 2010-09-22 08:02

Yes, I'm using libpng 1.4.3-1 from extra.

haawda commented on 2010-09-21 19:36

Do you have a recent libpng installed?

hcartiaux commented on 2010-09-21 15:38

I can't compile it on archlinux testing x86_64.
Here is the output of yaourt :
http://pastebin.archlinux.fr/425081

haawda commented on 2010-08-22 15:46

Fixed.

kfgz commented on 2010-08-22 13:57

Patch for PKGBUILD to compile

./configure --prefix=/usr || return 1
+ sed -i "s/-Wl,--as-needed//g" src/Makefile
make || return 1

bernarcher commented on 2010-03-27 19:16

It compiles now when I remove the "-Wl,--as-needed" from the failing gcc command line. However, I did not install the resulting package yet because I have no time for the moment to test the result.

haawda commented on 2010-03-27 18:15

also builds for me with gcc-4-4.3-2 8x86_64).

haawda commented on 2010-03-27 18:14

also builds for me with gcc-4-4.3-2 8x86_64).

haawda commented on 2010-03-27 18:14

also builds for me with gcc-4-4.3-2 8x86_64).

haawda commented on 2010-03-27 18:00

Hm i have gcc 4.4.3-1 here. will update and test again.

bernarcher commented on 2010-03-27 17:26

Forgot to mention. surely did so: libsvg-cairo 0.1.6-9

It is weird, the so-files are there in /usr/lib and they list the missing symbols. It appears like gcc does not find them although it should look them up according to the -l flags. I tried running /sbin/ldconfig again, just to be sure, to no avail.

BTW, this is x86_64 and gcc 4.4.3-2.

haawda commented on 2010-03-27 16:55

You need also to rebuild libsvg-cairo.

bernarcher commented on 2010-03-27 16:43

I did rebuild libsvg 0.1.4-4 before svg2png 0.1.3-3. The problem persists.

haawda commented on 2010-03-27 16:17

it is not just rebuilding. At least for libsvg you need the patch that comes with the new PKGBUILD I uploaded yesterday.

bernarcher commented on 2010-03-27 16:02

I cannot build, too. Same messages about "undefined reference to `svg_cairo_xxx'"
Rebuilding libsvg, and libsvg-cairo as advised does not help either.

haawda commented on 2010-03-26 19:24

It is a bug in libsvg, which does not fit to libpng 1.4. I added a patch, so please rebuild libsvg using the new PKGBUILD, libsvg-cairo and then svg2png.

muunleit commented on 2010-03-24 07:26

I can't build it.

http://aur.pastebin.com/WKgZbPGt