Package Details: svp 4.2.0.137-1

Git Clone URL: https://aur.archlinux.org/svp.git (read-only)
Package Base: svp
Description: SmoothVideo Project 4 (SVP4)
Upstream URL: https://www.svp-team.com/wiki/SVP:Linux
Licenses: custom
Submitter: phiresky
Maintainer: phiresky
Last Packager: phiresky
Votes: 21
Popularity: 0.779881
First Submitted: 2016-07-03 15:19
Last Updated: 2018-05-18 10:36

Latest Comments

Muflone commented on 2018-02-03 22:51

thank you for your precious hack to decompress the .run file, I've implemented it also in foxitreader

phiresky commented on 2018-01-20 16:57

@sgar No, that doesn't change anything, just checked. It's fixed because I changed the extraction method from a bad hack to a awesome hack.

sgar commented on 2018-01-20 16:54

The problem to install SVP was solved with the upgrade of qt5-base-5.10 to release 3..

Redi commented on 2018-01-16 17:25

And it works. Awesome. Thanks phiresky. :)

phiresky commented on 2018-01-15 19:26

@Muflone thanks. But fuck that, I'm not going to justify this installer bullshit. I'd rather search that binary for 7zip magic bytes and then just try extracting everything I find.

In fact, that's what I just changed it to. Seems to work for me, and no qt-installer-framework makedep anymore :)

Muflone commented on 2018-01-14 03:13

@phiresky I had a bad time to fix the foxitreader package which had the same error:

[0] Warning: QFile::at: Cannot set file position 29490877
Cannot register in-binary resource

At last I dropped the qt-installer-framework dependency using a custom script for the installer. You could use something similar to workaround.

dominicm commented on 2017-12-31 15:27

With all dependencies installed svp package still fails with this error:

==> Starting prepare()... [0] Warning: QFile::at: Cannot set file position 29490877 Cannot register in-binary resource. ==> ERROR: A failure occurred in prepare(). Aborting...

therob commented on 2017-12-30 16:22

I can confirm that I too still get the same error even after re-installing/recompiling the qt-installer-framework package.

I didnt try downgrading Qt tho, my qt version is 5.10.0.

sgar commented on 2017-12-30 16:06

@phiresky I had the same error.. I have succesfully compiled the package with qt5 v9.3... that means that the issue lies with qt5 v5.10 somehow..

Nightbane112 commented on 2017-12-27 12:47

@phiresky Even after reinstalling qt-installer-framework, I still have the exact same error as @therob.

But if I manually run the .run file, it extracts and install the files. Do you think that qt-installer-framework package is giving problems?

All comments