Package Details: svp 4.3.0.157-1

Git Clone URL: https://aur.archlinux.org/svp.git (read-only)
Package Base: svp
Description: SmoothVideo Project 4 (SVP4)
Upstream URL: https://www.svp-team.com/wiki/SVP:Linux
Licenses: custom
Submitter: phiresky
Maintainer: phiresky
Last Packager: phiresky
Votes: 28
Popularity: 0.905746
First Submitted: 2016-07-03 15:19
Last Updated: 2018-12-18 19:18

Latest Comments

1 2 3 4 5 Next › Last »

clap22 commented on 2019-01-24 23:01

in case someone tries to use svptube, I had to workaround a missing dependency for it to work. First install pythonqt if you don't have it then:

/opt/svp/extensions >>> ldd libsvptube.so
linux-vdso.so.1 (0x00007ffefcfb3000) libdl.so.2 => /usr/lib/libdl.so.2 (0x00007fbf4c17f000) libPythonQt.so.1 => not found /opt/svp/extensions >>> sudo ln -s /usr/lib/libPythonQt-Qt5-Python3.so /usr/lib/libPythonQt.so.1 /opt/svp/extensions >>> ldd libsvptube.so
linux-vdso.so.1 (0x00007ffe821f9000) libdl.so.2 => /usr/lib/libdl.so.2 (0x00007f8e0bf7c000) libPythonQt.so.1 => /usr/lib/libPythonQt.so.1 (0x00007f8e0bcd2000)

Probably shouldn't be done to /usr/lib like that but adapt it as you wish with better path or LDD preloads. If it's enabled, to use it you just copy a youtube-dl supported link into clipboard and a popup shows up on bottom with quality options, really neat!

RubenKelevra commented on 2018-11-22 17:07

The svp is crashing with QT-Network errors on bad internet connections, like thru a proxy server. Using a good internet connection, the app works flawlessly with code plugin enabled.

Please re-enable the plugin. :)

RubenKelevra commented on 2018-11-20 16:07

I found that SVP is installing the wrong Deinterlacing plugin into vlc... it's choosing the 22 file not the 30 file.

So /opt/svp/plugins/libvapoursynth_plugin.so.22 is choosen instead of /opt/svp/plugins/libvapoursynth_plugin.so.30 for the VLC in version 3.0.4-6.

Replacing it manually with the right version perfectly works (in opposite to the message displayed while installing by SVP - which states, that it was successfully installed, but VLC has removed the deinterlace support).

Maybe you can submit this as feedback/a bug to the developers?

themagicalyang commented on 2018-10-27 08:45

This is still crashing some time after starting.

❯ SVPManager
14:06:56.408 [I]: Main: starting up SVP 4 Linux [4.2.0.140]... 
14:06:56.408 [I]: Main: args: none
14:06:56.408 [I]: Main: working dir is /opt/svp/
14:06:56.409 [I]: Main: data dir set to /home/username/.local/share/SVP4/
14:06:56.409 [I]: Settings: loading reg.cfg OK
14:06:56.409 [I]: Settings: loading main.cfg OK
14:06:56.409 [I]: Settings: loading ui.cfg OK
14:06:56.409 [I]: Settings: loading frc.cfg OK
14:06:56.410 [I]: Settings: loading profiles.cfg OK
14:06:56.410 [I]: Settings: loading custom.cfg OK
14:06:56.410 [I]: Settings: loading lights.cfg OK
14:06:56.410 [I]: Main: using Qt 5.11.2 (x86_64-little_endian-lp64 shared (dynamic) release build; by GCC 8.2.1 20180831)
14:06:56.410 [I]: Main: device scale is 1, user defined scale is 0
14:06:56.410 [I]: Main: system locale is [en-gb]
14:06:56.412 [I]: Main: setting language file to en.qm...
14:06:56.414 [I]: Main: module 'plugins/libsvpflow1_vs64.so': 4.2.0.138
14:06:56.414 [I]: Main: module 'plugins/libsvpflow2_vs64.so': 4.2.0.146
14:06:56.416 [I]: Main: VLC filter (64 bit): 0.9.0.114
14:06:56.416 [I]: Main: running OpenCL info...
14:06:56.418 [I]: Main: collecting system information...
14:06:56.420 [I]: OS: Linux 4.18.16-arch1-1-ARCH #1 SMP PREEMPT Sat Oct 20 22:06:45 UTC 2018 x86_64
14:06:56.432 [I]: Desktop environment:  / 
14:06:56.448 [I]: CPU: Intel Core i7-6700K [base frequency 4200 MHz, 8 threads]
14:06:56.448 [I]: Video: reading OpenCL info...
14:06:56.456 [I]: Video: 1 GPU OpenCL device(s) on NVIDIA CUDA [OpenCL 1.2 CUDA 10.0.175] (NVIDIA Corporation)
14:06:56.456 [I]: Video 1: device name 'GeForce GTX 980 Ti' (NVIDIA Corporation, ver.410.66) [gpuID=11]: OK
14:06:56.457 [I]: Memory:  15969  MB total,  13265 MB free
14:06:56.457 [I]: System: finding network settings...
14:06:56.462 [I]: Power: AC is ON [1]
14:06:56.468 [I]: Screens: updating information, 3 screen(s) found
14:06:56.468 [I]: Screens: screen 0 (DP-3) - 1920x1080 @60.000 Hz, x1.0 [95 DPI]
14:06:56.468 [I]: Screens: screen 1 (DP-1) - 1920x1080 @60.000 Hz, x1.0 [95 DPI]
14:06:56.468 [I]: Screens: screen 2 (DP-5) - 1920x1080 @60.000 Hz, x1.0 [95 DPI]
14:06:56.468 [I]: Screens: primary screen is 0
14:06:56.486 [I]: Main: preparing video profiles...
14:06:56.518 [I]: Main: preparing performance graphs...
14:06:56.546 [I]: Main: preparing mpv...
14:06:56.559 [I]: Main: preparing remote control...
14:06:56.559 [I]: RemoteControl: started
14:06:56.559 [I]: Main: preparing main menu...
14:06:56.572 [I]: Main: loading extensions...
14:06:56.575 [I]: Extensions: found svpcast 0.9.5.140 ...
14:06:56.576 [I]: Settings: loading cast.cfg OK
14:06:56.580 [I]: Streaming: Web UI started at http://192.168.0.101:9900
14:06:56.581 [I]: Streaming: Avahi service is not available, AppleTVs are probably not discoverable
14:06:56.586 [I]: Extensions: found svplight 2.0.0.138 ...
14:06:56.586 [I]: Settings: loading leds.cfg OK
14:06:56.616 [I]: Main: initialization completed in 198 ms
14:06:56.858 [I]: Updates: checking now...
14:06:59.431 [I]: Performance: quick estimation = 814 (previous value was 809)
[1]    1075 segmentation fault (core dumped)  SVPManager

It takes a few seconds to crash but it does crash everytime. I am not even starting mpv, it crashes as is. Any clue what can cause this?

phiresky commented on 2018-10-24 12:31

Not sure, I haven't tried if it still crashes without removing libsvpcode.so

RubenKelevra commented on 2018-10-24 12:13

Sad so see the svpcode extension go away, any timeframe when it's working again? :)

vito26 commented on 2018-07-19 17:36

Missing libQt5Qml.so.5 available in package qt5-declarative

id942701 commented on 2018-07-19 17:18

Remove /opt/svp/extensions/libsvpcode.so in order to prevent segmentation fault

EggheadDash commented on 2018-07-08 17:46

I am getting segmentation faults whenever I start it, could this be a problem with qt 5.10? I have that downgraded due to a known issue with plex-media-player failing to start with 5.11. This is somewhat annoying as I primarily use these two programs in conjunction with each other.

nemethdani commented on 2018-07-04 17:47

please add qt5-declarative as dependency. It is needed for SVPManager