Package Details: svt-vp9-git 0.3.0.r3.g10910b7-1

Git Clone URL: https://aur.archlinux.org/svt-vp9-git.git (read-only, click to copy)
Package Base: svt-vp9-git
Description: Scalable Video Technology VP9 encoder (git version)
Upstream URL: https://github.com/OpenVisualCloud/SVT-VP9/
Licenses: BSD
Conflicts: svt-vp9
Provides: svt-vp9
Submitter: BlackLotus89
Maintainer: dbermond
Last Packager: dbermond
Votes: 5
Popularity: 0.000000
First Submitted: 2019-03-08 21:58 (UTC)
Last Updated: 2021-02-13 15:29 (UTC)

Dependencies (4)

Required by (6)

Sources (1)

Latest Comments

dbermond commented on 2022-07-12 17:54 (UTC)

@costor An AVX2 capable CPU is a requirement for using svt-vp9, as it requires 5th gen Intel CPU at minimum. So, we are not supposed to modify this here. We are already using git master on this package, which is the latest upstream source code. The link that you posted is from a non-merged pull request.

costor commented on 2022-07-11 18:57 (UTC) (edited on 2022-07-11 18:59 (UTC) by costor)

If your CPU doesn't support AVX2, SvtVp9EncApp won't run and you'll get a SIGILL error.

As a workaround, adding this to the PKGBUILD (before build()) works for me:

prepare() {
    cd SVT-VP9/
    curl -OL 'https://github.com/OpenVisualCloud/SVT-VP9/commit/eb2f70b80d25d51bb6b41282da9ecfe3747a7b81.patch'
    git apply eb2f70b80d25d51bb6b41282da9ecfe3747a7b81.patch
    sed 's/ASM_TYPES\ \&\ PREAVX2_MASK/ASM_TYPES\ \&\ AVX2_MASK/g' -i Source/Lib/Codec/Eb*.c
}

dbermond commented on 2019-10-11 12:04 (UTC)

@BlackLotus89 Please add 'svt-vp9' to conflicts, otherwise the files will conflict with svt-vp9.

Also, the PKGBUILD can be improved. Please see the svt-vp9 package for reference.