Package Details: swagger-editor-git 20181227-1

Git Clone URL: https://aur.archlinux.org/swagger-editor-git.git (read-only)
Package Base: swagger-editor-git
Description: Swagger Editor
Upstream URL: https://github.com/swagger-api/swagger-editor
Licenses: Apache
Conflicts: swagger-editor
Provides: swagger-editor
Submitter: atweiden
Maintainer: VOID001
Last Packager: VOID001
Votes: 0
Popularity: 0.000000
First Submitted: 2015-09-05 14:35
Last Updated: 2018-12-26 15:23

Latest Comments

lastmikoi commented on 2018-02-13 14:12

To whom it may concern, to get this package working you need to update the build() to stop using grunt and bower and use the new npm-based build system. It would also seems that the index.html has been moved away from /dist, so the systemd unit must be updated as well:

diff --git a/PKGBUILD b/PKGBUILD
index 3f8adc2..26818d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
 # Maintainer: Andy Weidenbaum <archbaum@gmail.com>

 pkgname=swagger-editor-git
-pkgver=20151009
+pkgver=20180209
 pkgrel=1
 pkgdesc="Swagger Editor"
 arch=('i686' 'x86_64')
 depends=('darkhttpd' 'nodejs')
-makedepends=('bower' 'git' 'nodejs-grunt-cli' 'npm')
+makedepends=('git' 'npm')
 url="https://github.com/swagger-api/swagger-editor"
 license=('Apache')
 source=(git+https://github.com/swagger-api/swagger-editor
         swagger-editor.service)
 sha256sums=('SKIP'
-            '8988d97fe76124e0563c80842e0b7841b8fe3c24ca0c66c55af22b12746c5a34')
+            'ca2474524032867d5ea1662535250d9339d9e8f80be1d4d23e429b73e0a5eed4')
 provides=('swagger-editor')
 conflicts=('swagger-editor')
 options=('!strip')
@@ -29,11 +29,8 @@ build() {
   msg2 'Fetching NPM dependencies...'
   npm install --python=python2

-  msg2 'Fetching Web assets...'
-  bower install --allow-root --config.interactive=false
-
-  msg2 'Compiling Web assets...'
-  grunt build
+  msg2 'Building...'
+  npm run build
 }

 package() {
diff --git a/swagger-editor.service b/swagger-editor.service
index 7dc390f..35c31d7 100644
--- a/swagger-editor.service
+++ b/swagger-editor.service
@@ -5,7 +5,7 @@ Description=Swagger Editor
 User=swaggereditor
 Group=swaggereditor
 WorkingDirectory=/usr/share/swagger-editor
-ExecStart=/usr/bin/darkhttpd /usr/share/swagger-editor/dist --port 9898
+ExecStart=/usr/bin/darkhttpd /usr/share/swagger-editor --port 9898
 StandardOutput=journal
 StandardError=journal

madwifi commented on 2016-08-21 03:42

bower is no longer a part of the build tool chain

txomon commented on 2016-07-06 10:06

This doesn't work, bower not found.

WhyNotHugo commented on 2015-10-09 07:18

makedepends should list "bower" (which is in now in [community]).