Package Details: sway-borders-git r6976.8fba9c04-1

Git Clone URL: https://aur.archlinux.org/sway-borders-git.git (read-only, click to copy)
Package Base: sway-borders-git
Description: Fork of Sway with some additional (mostly graphical) features
Upstream URL: https://github.com/fluix-dev/sway-borders
Licenses: MIT
Conflicts: sway
Provides: sway
Submitter: fluix
Maintainer: fluix
Last Packager: fluix
Votes: 3
Popularity: 0.000050
First Submitted: 2020-11-05 23:36 (UTC)
Last Updated: 2022-04-03 19:33 (UTC)

Dependencies (24)

Required by (36)

Sources (2)

Latest Comments

1 2 Next › Last »

fluix commented on 2022-10-18 00:51 (UTC)

Fixed.

NicolaiVdS commented on 2022-10-16 11:21 (UTC)

Fails to compile!!

WLR_OUTPUT_ADAPTIVE_SYNC_UNKNOWN has been removed in wlroots

there is a open MR on the project but the maintainer seems to be AFK

fluix commented on 2022-04-03 19:35 (UTC)

@ForgotUmbrella updated and added contrib scripts. I'll ask around and see if adding that file as a source without a checksum is an okay idea since it may be poor convention.

ForgotUmbrella commented on 2022-01-05 09:12 (UTC) (edited on 2022-01-19 10:34 (UTC) by ForgotUmbrella)

I assume that this package should serve as a drop-in replacement for sway, but I have found a few issues.

The 50-systemd-user.conf file is outdated; the version in the sway package also exports XDG_CURRENT_DESKTOP (see https://github.com/archlinux/svntogit-community/blob/packages/sway/trunk/50-systemd-user.conf). Perhaps it would be a good idea to programmatically fetch this file instead of trying to maintain a duplicate file.

In addition to this, unlike the sway package, this version does not install the contrib scripts (e.g. inactive-window-transparency.py).

fluix commented on 2021-10-16 04:23 (UTC)

Thanks! I'm not quite sure what you mean by "the git one" (do you mean sway-git? if so, it's the same type of package, yes) but when flagging you should have gotten the following notice:

This seems to be a VCS package. Please do not flag it out-of-date if the package version in the AUR does not match the most recent commit. Flagging this package should only be done if the sources moved or changes in the PKGBUILD are required because of recent upstream changes.

You can also read more about source code packages here.

To be honest, I've had trouble with various caches as well so not quite sure what may be wrong. I don't believe it is this package though, more so the fact that it dynamically depends on wlroots-git and myself having multiple versions of packages/development cloned locally.

Helpis-Me commented on 2021-10-15 23:40 (UTC)

Hello. Ok, so I unflagged the package, and does that mean the git one and this one aren't the same thing? Well... I don't know how this works, I just read the date as 6 months old, so I thought it was old. I was going to say, I don't know what caches need to be clear, or even how to do that, but I reinstalled the system from scratch, didn't touch anything, and tried it again, and now it works. I don't know why it worked now when it didn't before, I tried to update everything to the software this one needed, but it only works after I fresh install.

fluix commented on 2021-10-11 21:57 (UTC)

@Helpis-Me this package is not out of date. -git packages do not have their pkgver updated every commit. The current commit in the source repository is only 4 days old: https://github.com/fluix-dev/sway-borders/commit/58a32d8130c3b8642566e591947e585ed3ebcc41

Your issue is with an outdated wlroots, please update it and clear any caches.

Helpis-Me commented on 2021-10-08 22:47 (UTC) (edited on 2021-10-08 23:39 (UTC) by Helpis-Me)

Hey, this package doesn't install, and I get this message when trying to install it (I took a screencap): https://ibb.co/cbV4kmt

I just did everything the installer asked, hitting y on everything. Is there something I did wrong?

Total noobie here btw

I also tried the same thing with the download directly from Github, and followed the build instructions, and the same thing shows up.

electricprism commented on 2021-06-21 19:47 (UTC) (edited on 2021-06-21 19:47 (UTC) by electricprism)

@fluix -- r6764.e555655f-1 seems to be working just fine now, thank you :) Great package btw.

fluix commented on 2021-06-03 01:45 (UTC)

Could you test the sway-git package and see if it reproduces (you'll have to remove the border_images in the config)? If it does, please search the issues here or open a new one in the same place. If it doesn't, please follow these steps, pasting links to the log and config files in a comment here.