Package Details: swift-lldb-preview 3.0.2.PREVIEW.1-1

Git Clone URL: https://aur.archlinux.org/swift-preview.git (read-only)
Package Base: swift-preview
Description: The Swift programming language debugger (LLDB) and REPL - preview release
Upstream URL: http://swift.org/
Licenses: Apache
Conflicts: lldb, swift-lldb
Provides: lldb, swift-lldb
Submitter: Zrax
Maintainer: Zrax
Last Packager: Zrax
Votes: 1
Popularity: 0.000027
First Submitted: 2016-07-07 22:38
Last Updated: 2016-11-16 22:11

Required by (20)

Sources (14)

Latest Comments

Zrax commented on 2016-08-09 16:51

@hiking90 Thanks, I've added the missing swiftpm tools for the 3.0-PREVIEW-4 update.

hiking90 commented on 2016-08-09 02:04

This package does not include swift-package and swift-test.

Could you apply below patch?

diff --git a/PKGBUILD b/PKGBUILD
index 461e67c..e71f6b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -122,6 +122,8 @@ package_swift-preview() {
(
cd swiftpm-linux-$CARCH
install -m755 debug/swift-build "$pkgdir/usr/bin"
+ install -m755 debug/swift-package "$pkgdir/usr/bin"
+ install -m755 debug/swift-test "$pkgdir/usr/bin"

install -dm755 "$pkgdir/usr/lib/swift/pm"
install -m755 lib/swift/pm/libPackageDescription.so "$pkgdir/usr/lib/swift/pm"

Zrax commented on 2016-07-29 15:46

The only tagged releases for libdispatch so far have 'darwin' in the name, which makes me believe it's not yet ready for Linux. If they start tagging builds with versions that match the other corelibs, I'll probably add it in at that point.

boterock commented on 2016-07-28 19:40

had to rebuild again, but this time because it doesn't conflict with swift-development-bin, so the installation failed and I have to rebuild again now. (pacaur should somehow cache the build)

All of this made me give a closer look to PKGBUILD and I was wondering why didn't you include libdispatch in the build?

boterock commented on 2016-07-28 16:08

I had a problem at nearly the end of the installation:

CMake Error at cmake/modules/SwiftManpage.cmake:23 (message):
Need pod2man installed to generate man page
Call Stack (most recent call first):
docs/tools/CMakeLists.txt:3 (manpage)


-- Configuring incomplete, errors occurred!
See also "/home/boterock/.cache/pacaur/swift-preview/src/build/Ninja-ReleaseAssert/swift-linux-x86_64/CMakeFiles/CMakeOutput.log".
utils/build-script: fatal error: command terminated with a non-zero exit status 1, aborting
==> ERROR: A failure occurred in build().
Aborting...
:: failed to build swift-preview package(s)

seems like pod2man is not in $PATH by default, adding /usr/bin/core_perl adds it to the path, I am testing now.