Package Details: sxiv-git 2016.08.08-1

Git Clone URL: https://aur.archlinux.org/sxiv-git.git (read-only, click to copy)
Package Base: sxiv-git
Description: Simple (or small or suckless) X Image Viewer
Upstream URL: https://github.com/muennich/sxiv
Licenses: GPL2
Conflicts: sxiv
Provides: sxiv
Submitter: None
Maintainer: jasonwryan
Last Packager: jasonwryan
Votes: 35
Popularity: 0.077355
First Submitted: 2011-01-23 13:55
Last Updated: 2016-08-10 07:16

Required by (7)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

Anonymous comment on 2012-12-30 11:14

I follow upstream's describtion how to change the install directory. Please look it up at the project's github page.

baskerville commented on 2012-12-30 10:42

Instead of:
make PREFIX="$pkgdir/usr" install
I would prefer:
make PREFIX=/usr DESTDIR="$pkgdir" install

Anonymous comment on 2012-12-29 18:17

Concerning GPLv2 vs GPL2, please take a look at the licenses package. That's why it has to be "GPL2".

I took the example PKGBUILD for git packages from the abs package and did a remake of the package. This should solve everything. From my point of view this package is perfect. If there are passages in it you would do differently, I need you to respect that everybody has his own style.

baskerville commented on 2012-12-29 17:50

Thanks, you're right about the license.

Could you take all the other changes too?

There's still a lot of typos ('X' is not 'x', 'GPLv2' is not 'GPL2', etc.), indentation problems, unnecessary messages, double quotes, etc.

Anonymous comment on 2012-12-24 01:13

I like your modifications, so I added most of them. Thanks!

giflib isn't needed as a dependency, since imlib2 already depends on giflib.
The license file isn't required in the package, since the gpl2 license is already provided by the licenses package. We only have to provide licenses which aren't in the licenses file.

baskerville commented on 2012-12-23 20:41

I've made a few improvements to the PKGBUILD:
- Added 'giflib' to the dependencies (cf. ef0ed3226428c00507e76bdda77c522729ed6809).
- Added 'git' to the make dependencies.
- Copied `LICENCE` and `sxiv.desktop` to the appropriate places.
Please grab it here:
https://github.com/baskerville/PKGBUILDs/raw/master/sxiv-git/PKGBUILD

baskerville commented on 2012-12-23 20:38

I've made a few improvements to the PKGBUILD:
- Added 'giflib' to the dependencies (cf. ef0ed3226428c00507e76bdda77c522729ed6809).
- Added 'git' to the make dependencies.
- Copied `LICENCE` and `sxiv.desktop` to the appropriate places.
Please grab it here:
https://github.com/baskerville/PKGBUILDs/raw/master/sxiv-git/PKGBUILD

Anonymous comment on 2012-03-04 21:29

Updated again, because the optdepends were out of date

Anonymous comment on 2011-09-15 15:30

If the maintainer decides to disable exif by default, I respect that decision. It's the arch way to provide the packages as vanilla as possible and so do I here. The default config.h has exif disabled, so this package here provides this as default. It's the user's choice, that's why I put libexif and giflib in the optdepends so the user can see this when viewing the PKGBUILD or after the installation. After that he can change the settings accordingly. I provide all possibliities in the PKGBUILD to build sxiv the way you want (custom config.h).

I enabled both exif and gif animations, because I want it that way. But as said before, I want the PKGBULID to install sxiv as intended by upstream.

quite commented on 2011-09-15 14:11

I know perfectly well how enable exif, that wasn't the question.

My question concerned the reason for exif not being enabled automatically by the PKGBUILD (by rewriting config.h). Do you for example think that people generally don't want exif? Or why?