Package Details: synaptics-led 4.6-2

Git Clone URL: https://aur.archlinux.org/synaptics-led.git (read-only)
Package Base: synaptics-led
Description: Synaptics LED enabled psmouse kernel module
Upstream URL: https://github.com/mmonaco/PKGBUILDs
Licenses: GPL2
Submitter: dgbaley27
Maintainer: dgbaley27 (vantu5z)
Last Packager: vantu5z
Votes: 9
Popularity: 0.000000
First Submitted: 2011-05-23 16:24
Last Updated: 2016-07-15 19:08

Latest Comments

SubZ3r0 commented on 2016-06-10 21:14

Hi there vantu5z, still errors:

patching file Kconfig
patching file synaptics.c
Hunk #2 succeeded at 660 (offset 10 lines).
Hunk #3 succeeded at 1438 (offset 9 lines).
Hunk #4 succeeded at 1496 (offset 9 lines).
Hunk #5 succeeded at 1629 with fuzz 2 (offset -3 lines).
patching file synaptics.h
Hunk #2 succeeded at 199 (offset 1 line).
-> Building psmouse.ko
make: Entering directory '/usr/lib/modules/4.4.12-1-MANJARO/build'
make: *** No rule to make target 'psmouse.ko'. Stop.
make: Leaving directory '/usr/lib/modules/4.4.12-1-MANJARO/build'
==> ERRO: Uma falha ocorreu em build().
A cancelar...
==> ERRO: Makepkg não conseguiu compilar synaptics-led.
==> Reiniciar a compilação de synaptics-led ? [s/N]


Manjaro 16.06 kernel 4.4.12-1-MANJARO

Best Regards,

SubZ3r0

vantu5z commented on 2016-03-20 02:30

SubZ3r0, package updated, try it.

SubZ3r0 commented on 2016-03-15 16:26

Hi guys, i tried to install this package in kernel 4.4.5-1 in Manjaro and i get errors:

-> Building psmouse.ko
make: Entering directory '/usr/lib/modules/4.4.5-1-MANJARO/build'
make: *** No rule to make target 'psmouse.ko'. Stop.
make: Leaving directory '/usr/lib/modules/4.4.5-1-MANJARO/build'
==> ERRO: Uma falha ocorreu em build().
A cancelar...
==> ERROR: Makepkg was unable to build synaptics-led.
==> Restart building synaptics-led ? [y/N]


Can you help ?

vantu5z commented on 2015-06-04 09:40

Get this error when try to install with kernel 4.0:

/tmp/yaourt-tmp-vantu5z/aur-synaptics-led/src/drivers/input/mouse/cypress_ps2.c: В функции «cypress_process_packet»:
/tmp/yaourt-tmp-vantu5z/aur-synaptics-led/src/drivers/input/mouse/cypress_ps2.c:552:2: ошибка: слишком мало аргументов в вызове функции «input_mt_assign_slots»
input_mt_assign_slots(input, slots, pos, n);

nbsp commented on 2015-04-02 23:09

Looks like that error is due to:
http://allanmcrae.com/2014/12/pacman-4-2-released/

I fixed this by changing:

make -C "/lib/modules/$_cur_kernel/build" M="$PWD" psmouse.ko
to
make -C "/usr/lib/modules/$_cur_kernel/build" M="$PWD" psmouse.ko

and

"$pkgdir/lib/modules/$_cur_kernel/extramodules/psmouse.ko.gz"
to
"$pkgdir/usr/lib/modules/extramodules-3.19-ARCH/psmouse.ko.gz"

I'm not sure about how extramodules line /should/ be done, but that works for me..

nbsp commented on 2015-03-31 01:59

Builds fine but getting this when installing:
ZeeBook% pacman -U synaptics-led-3.11-7-x86_64.pkg.tar.xz
...
error: failed to commit transaction (conflicting files)
synaptics-led: /lib exists in filesystem
synaptics-led: /lib/modules/3.19.2-1-ARCH/extramodules exists in filesystem
Errors occurred, no packages were upgraded.

Just for sanity's sake I ran -Qo on both symlinks too:
ZeeBook% pacman -Qo /lib
/lib is owned by filesystem 2015.02-1
ZeeBook% pacman -Qo /lib/modules/3.19.2-1-ARCH/extramodules
/usr/lib/modules/3.19.2-1-ARCH/extramodules is owned by linux 3.19.2-1

Zzaponka commented on 2014-07-08 15:44

I'm a best damn fool!
I didn't.

Now it installed ok, thanks.

dgbaley27 commented on 2014-07-08 15:30

... and then you did pacman -U ?

Zzaponka commented on 2014-07-08 15:20

Here's the full log of makepkg -f command in synaptics-led directory:

[shydlovskyi@shydlovskyi synaptics-led]$ makepkg -f
==> Making package: synaptics-led 3.11-7 (Tue Jul 8 21:15:17 EEST 2014)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
-> Found SHA256SUMS
-> Found synaptics-led.install
-> Found 0001-input-Add-LED-support-to-Synaptics-device.patch
-> Found 0002-synaptics-add-debugging-to-synaptics_has_led.patch
==> Validating source files with sha256sums...
SHA256SUMS ... Passed
synaptics-led.install ... Passed
0001-input-Add-LED-support-to-Synaptics-device.patch ... Passed
0002-synaptics-add-debugging-to-synaptics_has_led.patch ... Passed
==> Extracting sources...
==> Removing existing pkg/ directory...
==> Starting build()...
-> Getting source from git://repo.or.cz/linux.git
-> Performing Integrity Check
-> Patching source
patching file Kconfig
patching file synaptics.c
patching file synaptics.h
patching file Kconfig
patching file synaptics.c
-> Building psmouse.ko
make: Entering directory '/usr/lib/modules/3.15.3-1-ARCH/build'
CC [M] /home/shydlovskyi/aur_builds/synaptics-led/src/drivers/input/mouse/psmouse-base.o
CC [M] /home/shydlovskyi/aur_builds/synaptics-led/src/drivers/input/mouse/synaptics.o
LD [M] /home/shydlovskyi/aur_builds/synaptics-led/src/drivers/input/mouse/psmouse.o
MODPOST 1 modules
LD [M] /home/shydlovskyi/aur_builds/synaptics-led/src/drivers/input/mouse/psmouse.ko
make: Leaving directory '/usr/lib/modules/3.15.3-1-ARCH/build'
-> Compressing psmouse.ko.gz
gzip: psmouse.ko.gz already exists; do you wish to overwrite (y or n)? y
==> Entering fakeroot environment...
==> Starting package()...
==> Tidying install...
-> Purging unwanted files...
-> Removing libtool files...
-> Removing static library files...
-> Compressing man and info pages...
-> Stripping unneeded symbols from binaries and libraries...
==> Creating package "synaptics-led"...
-> Generating .PKGINFO file...
-> Adding install file...
-> Generating .MTREE file...
-> Compressing package...
==> Leaving fakeroot environment.
==> Finished making: synaptics-led 3.11-7 (Tue Jul 8 21:15:44 EEST 2014)

It seems that nothing wrong here. Or in case of successful installation there's have to be some other output lines?

Sorry for messy comment.

dgbaley27 commented on 2014-07-08 15:01

Zzaponka, if you installed 'synaptics-led' but don't see it in $(pacman -Qm), then check the output of your install command because it didn't actually install. That said, the package likely needs to be updated for linux-3.15.

Zzaponka commented on 2014-07-08 14:26

Additionally, I can't see synaptics-led as installed by typing

pacman -Qm

Is it ok?

Zzaponka commented on 2014-07-08 14:13

The problem with xf86-input-synaptics-led is still here.
It complains that synaptics-led is unresolved dependency, but I just installed this package. Is is possible to fix somehow this issue?

Thanks in advance.

Anonymous comment on 2012-11-23 09:51

New PKGBUILD is ok, but it's not working with xf86-input-synaptics-led-1.6.2-3.

dgbaley27 commented on 2012-11-18 09:23

I finally came across some more information about the LED patch. It is being hosted in OpenSUSE's kernel git tree [1].

Also, it seems like they decided to drop supported due to instability [2][3][4].

There are some newer versions of the patch in git (before being deleted), and attached to the bug reports. I'll be posting an update soon.

[1] http://kernel.opensuse.org/cgit/kernel-source/
[2] http://kernel.opensuse.org/cgit/kernel-source/commit/patches.drivers?id=940e57e2c66093f6fee481ab4224dd4294e3793f
[3] https://bugzilla.novell.com/768506
[4] https://bugzilla.novell.com/765524

I think there might also be updates to the xf86-input-synaptics led patches too, so I'll do what I can to update those as well.

dgbaley27 commented on 2012-11-17 19:22

This is due to a bug in kmod v11, kmod 11-2 in testing fixes this (or kmod 12...)

sailerboy commented on 2012-11-15 07:11

Hi. When I install this package, it compiles just fine into the package, but on install, it gives me this error:

depmod: tools/depmod.c:980: mod_free: Assertion `mod->kmod == ((void *)0)' failed.
/tmp/alpm_z5eKAW/.INSTALL: line 1: 9275 Aborted depmod
error: command failed to execute correctly

mikecr commented on 2012-08-14 04:42

anrxc: Your solution did enable the double-tap disable feature, but I don't believe we share the same problem. psmouse does not appear to detect my device as having the LED, it does not create anything in /sys/class/leds and there's no messages in dmesg relating to the LED. I'm not exactly sure how the double-tap disable works, but assuming it's just "IF double-tap in top left corner THEN toggle touchpad state", your solution should in theory enable this feature on any touchpad, regardless of whether it's HP or has an LED or anything. I think you can only be confident that the others in that thread share the same problem as you if they also have something in /sys/class/leds and their dmesg has something relating to the LED, as yours does. For the record, my laptop is an HP Pavilion DM1-4108au.

anrxc commented on 2012-07-20 02:57

Hello, as I predicted a few HP users needed my has_led override. Surprisingly though even identical
ProBook's to mine fail to detect the actual LED so they can't light it up (on/off toggle it self works fine).

I don't know how to help them further with the LED light:
https://bbs.archlinux.org/viewtopic.php?pid=1116410#p1116410

dgbaley27 commented on 2012-07-01 14:44

Fixed, my apologies

Anonymous comment on 2012-07-01 06:51

Install file should be updated with the new kernel version 3.3 --> 3.4, too. And thanks for your work.

Anonymous comment on 2012-01-30 19:22

I have created my PKGBUILD with version for 3.1 and works.
Thank you!

dgbaley27 commented on 2012-01-29 18:04

Use the github link above to get the version for 3.1: https://github.com/mmonaco/synaptics-led/tree/5ed0785551d9a71be9bf2df117a8685f9f0c55c2

Anonymous comment on 2012-01-29 16:28

I am trying to install this package in Parabola (is Archlinux with kernel libre). The only difference is that I have installed the kernel "3.1.5-1-LIBRE" so I have modified the PKGBUILD file, with:

"_kver=3.2" to > "_kver=3.1"
"depends=("linux>=3.1" "linux<3.3")" to-> "depends=("linux>=3.1" "linux<3.3")"
and comments this line:
"#md5sum --quiet -c $srcdir/MD5SUMS"

but when I try to install, yaourt shows me this:

Starting build()...
-> Getting source from git://repo.or.cz/linux-2.6.git
-> Performing Integrity Check
-> Patching source
patching file Kconfig
patching file synaptics.c
Hunk #2 succeeded at 406 (offset -14 lines).
Hunk #3 succeeded at 877 (offset -434 lines).
Hunk #4 succeeded at 930 (offset -434 lines).
Hunk #5 succeeded at 1041 with fuzz 2 (offset -437 lines).
patching file synaptics.h
Hunk #1 succeeded at 129 with fuzz 1 (offset -15 lines).
Hunk #2 FAILED at 172.
1 out of 2 hunks FAILED -- saving rejects to file synaptics.h.rej
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build synaptics-led.
==> Restart building synaptics-led ? [y/N]


And, if I only change "depends=("linux>=3.1" "linux<3.3")" without change "_kver=3.2" yaourt shows me:

Starting build()...
-> Getting source from git://repo.or.cz/linux-2.6.git
-> Performing Integrity Check
-> Patching source
patching file Kconfig
patching file synaptics.c
Hunk #1 succeeded at 29 (offset 1 line).
Hunk #2 succeeded at 421 (offset 1 line).
Hunk #3 succeeded at 1312 (offset 1 line).
Hunk #4 succeeded at 1375 (offset 11 lines).
Hunk #5 succeeded at 1489 (offset 11 lines).
patching file synaptics.h
-> Building psmouse.ko
make: Entering directory `/usr/src/linux-3.1.5-1-LIBRE'
CC [M] /tmp/yaourt-tmp-vicente/aur-synaptics-led/src/drivers/input/mouse/psmouse-base.o
CC [M] /tmp/yaourt-tmp-vicente/aur-synaptics-led/src/drivers/input/mouse/synaptics.o
/tmp/yaourt-tmp-vicente/aur-synaptics-led/src/drivers/input/mouse/synaptics.c: In function 'set_input_params':
/tmp/yaourt-tmp-vicente/aur-synaptics-led/src/drivers/input/mouse/synaptics.c:1266:13: error: 'BTN_TOOL_QUINTTAP' undeclared (first use in this function)
/tmp/yaourt-tmp-vicente/aur-synaptics-led/src/drivers/input/mouse/synaptics.c:1266:13: note: each undeclared identifier is reported only once for each function it appears in
make[1]: *** [/tmp/yaourt-tmp-vicente/aur-synaptics-led/src/drivers/input/mouse/synaptics.o] Error 1
make: *** [psmouse.ko] Error 2
make: Leaving directory `/usr/src/linux-3.1.5-1-LIBRE'
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build synaptics-led.
==> Restart building synaptics-led ? [y/N]

What is BTN_TOOL_QUINTTAP? Why is it undeclared? How can I install synaptics-led in 3.1.5-1-LIBRE?

Anonymous comment on 2012-01-19 05:18

I installed it, perfect! but first I had to reboot because I had the kernel 3.1 and when I tried to install synaptics-led, appears a error because of a kernel 3.1. When I rebooted the new kernel 3.2 I could install synaptics-led.

dgbaley27 commented on 2012-01-18 18:45

I actually run off of [testing] myself. I typically have updates available in github before the new kernel hits [core]. That said, I don't always notices when the new kernel hits [core] so I sometimes need a reminder =)

Anonymous comment on 2012-01-18 18:27

When will it be available for kernel 3.2?
Is there any way that it works in this kernel?

dgbaley27 commented on 2011-12-04 18:14

Are you guys still having problems? Do you have an /etc/depmod.conf or /etc/depmod.d/depmod.conf?

dgbaley27 commented on 2011-11-19 05:06

So I finally tested this on the laptop I have access to with an led touchpad. It worked just fine (correct path in modinfo AND an led device when loaded). Also, this laptop is _not_ run off of testing (whereas my other computers are). From this I really don't have any further insights for you guys. As far as I can tell everything is good.

dgbaley27 commented on 2011-11-18 20:12

Still not sure what to tell you. Can anyone else confirm that this is working for them?

The module needs to be a gzip. So psmouse.ko.gz should be in extramodules. You can try running "sudo depmod $(uname -r)" but this should be the default.

toxygen commented on 2011-11-18 19:37

#3 - and i just noticed that /lib/modules/3.1.1-arch has an "extramodules" folder there, is this where it should go instead? the extramodules folder is a soft link to /lib/modules/extramodules-3.1-arch/
so i have my other module (lenovo_acpi.ko) and psmouse.ko.gz. i tried unzipping the psmouse, same result, system module in use. my other module loads fine either way..

toxygen commented on 2011-11-18 19:32

meant to say modinfo | grep extra, depmod -v also shows nothing regarding extramodules (including the other module i have there)

toxygen commented on 2011-11-18 19:31

ok, i rebuilt this package:

changing _kver in PKGBUILD = error, cant find sources
changing final install output manually to 3.1.1 - module not found, uses psmouse.ko (system)
no changes = system psmouse in use (per modinfo)\
depmod -a = no module shown with path "extramodules"

I have another module residing in the extramodules folder which does load when modprobe'd, but the psmouse,ko seems to take precedence if its in the main modules folder. the path in modinfo supports this.

dgbaley27 commented on 2011-11-18 08:12

kver is meant to be the base version -- just 3.x -- not 3.x.y.

nekolyanich commented on 2011-11-18 08:10

i'd find what $kver in PKGBUILD is incorrect, i change it to right, but insmod give me same error. my linux headers and current kernel version have same numbers

nekolyanich commented on 2011-11-18 08:02

i try to insmod new module:
sudo insmod /home/nekolyanich/abs/synaptics-led/pkg/lib/modules/extramodules-3.1-ARCH/psmouse.ko.gz
insmod: error inserting '/home/nekolyanich/abs/synaptics-led/pkg/lib/modules/extramodules-3.1-ARCH/psmouse.ko.gz': -1 Invalid module format

dgbaley27 commented on 2011-11-18 08:00

Do you have the linux-headers which match your linux installed? I still can't recreate this.

nekolyanich commented on 2011-11-18 07:57

i try to insmod new module:
sudo insmod /home/nekolyanich/abs/synaptics-led/pkg/lib/modules/extramodules-3.1-ARCH/psmouse.ko.gz
insmod: error inserting '/home/nekolyanich/abs/synaptics-led/pkg/lib/modules/extramodules-3.1-ARCH/psmouse.ko.gz': -1 Invalid module format

nekolyanich commented on 2011-11-18 07:55

@dgbaley27

No it's not in xf86-input-synaptics-clickpad, becose i'd never seen new led in /sys/class/leds
my path to psmouse is: /lib/modules/3.1.1-1-ARCH/kernel/drivers/input/mouse/psmouse.ko.gz

dgbaley27 commented on 2011-11-18 07:54

Is there any error output when building or installing? If the file is actually in the extrmodules dir, then maybe depmod isn't running correctly.

nekolyanich commented on 2011-11-18 07:48

@dgbaley27

No it's not in xf86-input-synaptics-clickpad, becose i'd never seen new led in /sys/class/leds
my path to psmouse is: /lib/modules/3.1.1-1-ARCH/kernel/drivers/input/mouse/psmouse.ko.gz

dgbaley27 commented on 2011-11-18 07:43

Ok, but I need to know if "modinfo psmouse" gives the correct path. If it does, then chances are the problem is in the xf86-input-synaptics-clickpad package.

nekolyanich commented on 2011-11-18 07:38

@dgbaley27
I now rebuild package via aurbuild, restart psmouse, but nothing changes. led dosn't working.

dgbaley27 commented on 2011-11-18 07:29

@toxygen:

I just built this directly from the AUR using yaourt. After that I ran "modprobe psmouse" and saw its path in extramodules. Does this not work for you? Is it not working for anyone else?

Are you building it on the kernel you're using it on?

toxygen commented on 2011-11-18 07:13

module builds fine and works, but I've had to move it to the main /lib/modules/3.1.1-arch, the extramodules folder doesn't seem to be accessed by modprobe, should it be changed to extramodules-3.1.1 ?

dgbaley27 commented on 2011-11-11 02:10

Ok, I've finally found a git mirror that allows archive so you don't have to download the entire kernel every time. I've never heard of the repo so I am validating the files I get from it. I also figured out how to get rid of that messy rsync'ing of the headers over the source. Enjoy.

dgbaley27 commented on 2011-11-10 20:24

FYI: I've set up a git repo for this pkg.

https://github.com/mmonaco/synaptics-led

dgbaley27 commented on 2011-11-10 10:53

Updated for 3.1. I don't have the hardware to test anymore. The patch succeeds without any FUZ. I wish I know how to download just the mouse directory - does any know of a git mirror for the kernel that allows git archive? It would also be nice to know how to have a CONFIG_ option on the commandline or specify the path to the config file to get rid of the rsync command.

Anonymous comment on 2011-09-10 00:39

I am still experience frequent crashes, however I am unable to actually locate any of the logged information..

dgbaley27 commented on 2011-08-08 12:50

Ok, I've updated it. I used the minor version, 3.0.1, but my original intention had been to keep with the major version only. Next update I may switch back to versioning this package with the major version but using the underlying minor version when actually building. This is because I think the synaptics code changing on a minor release will be rare.

dgbaley27 commented on 2011-08-08 12:23

Hey guys, I'll update this today. Maybe the mysterious crashes will stop =)

gothmog commented on 2011-08-08 09:40

zephiros: kernel version is 3.0.1, not 3.0

I tested with version 3.0.1 and work: http://pastebin.com/vxT4Ker4

gothmog commented on 2011-08-08 08:48

zephiros: kernel version is 3.0.1, not 3.0

I tested with version 3.0.1, but the LED doesn't work.

gothmog commented on 2011-08-08 08:47

zephyros: kernesl version is 3.0.1, not 3.0

I tested with version 3.0.1, but the LED doesn't work.

gothmog commented on 2011-08-08 08:45

zephiros: kernel version is 3.0.1, not 3.0. I tested with version 3.0.1, but the LED doesn't work.

Anonymous comment on 2011-08-08 08:17

Change in PKGBUILD

_kver=2.6.39 to _kver=3.0


ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-$_kver.tar.bz2 to ftp://ftp.kernel.org/pub/linux/kernel/v3.0/linux-$_kver.tar.bz2

and

md5sums=(
1aab7a741abe08d42e8eccf20de61e05
6d565328f36c6ca20b439f29bffc43bb
)

to

md5sums=(
398e95866794def22b12dfbc15ce89c0
6d565328f36c6ca20b439f29bffc43bb
)

Huulivoide commented on 2011-08-04 11:40

:( I can't get this to work with the new 3.0 kernel

dgbaley27 commented on 2011-07-13 01:24

I'm sorry about this. It's been happing on my HP Envy as well. I'm leaning towards it actually being a problem with the xf86-input-synaptics' use of it because the 'upstream' patch is still the same on the opensuse website for 2.6.39 however they are still on the 1.3 version of the xorg driver. Unfortunately I don't actually have physical access to the laptop, so it's been really hard to debug. Please let me know if you are able to come up with anything.

Anonymous comment on 2011-07-11 21:24

After installing this package and updating the latest xf86-synaptics-clickpad sometimes all of a sudden (at random) the screen goes black with lots of log text related to synaptics-led. I can only hard shut down. Upon restarting there no display even at BIOS POST screen. It is only when I hard shut down 2nd time and restart does the display gets restores.

dgbaley27 commented on 2011-06-14 23:18

Updated.

If anyone has any experience with the kernel's make, I have some questions:

1) I thought you could set a kconfig option on the commandline but it doesn't seem to work. I was trying make MOUSE_PS2_SYNAPTICS_LED=y ... and also make CONFIG_MOUSE_PS2_SYNAPTICS_LED=y, but neither seemed to work.

2) Is there a better way to do this than rsync the /usr/src/$KERNEL/ directory over the kernel source? I tried various combinations of -C M=, and even SUBDIRS, but I couldn't figure it out. Either the module wouldn't build because there were missing components in the src, or there would be permissioning issues.

Huulivoide commented on 2011-06-14 13:33

PKGBUILD for 2,6,39
http://paste.pocoo.org/show/407470/

dgbaley27 commented on 2011-05-28 14:05

It works!!!1one

I'm open to discussion about how to handle the kernel version. I think the 2.6.* (or 3.*) releases are sufficient and we won't need to worry about point releases, unless someone confirms that the mouse modules are touched in a point release. In fact they don't even change much between major releases, but I think I'll try to always bump for a major release.

I can also change the PKGBUILD to rebuild the module for each kernel installed on the system that has headers in /usr/src/ but that will complicate the kernel download and possibly the patch file.

As kernel versions increase, if the patch file needs changing, I'll try to leave the old versions in the source pkg so people can use it.

Enjoy!

dgbaley27 commented on 2011-05-23 16:26

This not ready to be used, I just wanted to get it uploaded. I haven't tested it or added the config files. The config files will be copied directly from the kernel26 package. I think I'll need to add an install file with runs depmod also.

In the future it might be nice to set up this package so that it will build the module for all installed kernels (or all installed kernels which have headers installed).