Package Details: syncthing-git v1.6.0.rc.5.r26.gcf7532906-1

Git Clone URL: https://aur.archlinux.org/syncthing-git.git (read-only, click to copy)
Package Base: syncthing-git
Description: Open Source Continuous Replication / Cluster Synchronization Thing
Upstream URL: https://syncthing.net/
Licenses: MPLv2
Conflicts: syncthing
Provides: syncthing
Submitter: sauyon
Maintainer: FabioLolix
Last Packager: savagezen
Votes: 14
Popularity: 0.005832
First Submitted: 2014-05-21 07:39
Last Updated: 2020-05-21 16:38

Dependencies (3)

Required by (9)

Sources (1)

Latest Comments

1 2 3 4 Next › Last »

mohe commented on 2020-05-20 20:04

@savagezen May you update this package with the changes from https://github.com/savagezen/pkgbuild/pull/10 please? If you didn't have the time yet it's fine - I just want to make sure you didn't forget.

savagezen commented on 2020-04-23 12:17

@mohe thanks for letting me know!

mohe commented on 2020-04-23 12:10

As this is a -git package you don't need to update the version every time a new one comes out. This just creates unnecessary notifications for people watching this package.

savagezen commented on 2020-04-07 13:31

Sorry for the delay guys. The patch has been added. The package was building fine for me before so I had forgotten to add it. For future reference you can give me a holla on Telegram and all my PKGBUILDs are on GitHub in case I miss something here.

mohe commented on 2020-04-07 12:47

Please apply @grandchild's patch - otherwise everybody has to apply it. Also please check if a package builds before pushing.

CyberGhost commented on 2018-04-09 17:04

Thank you @grandchild for the diff

grandchild commented on 2018-01-08 20:32

Package only builds after these changes:

--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ makedepends=('git' 'go' 'godep' 'inetutils')
 conflicts=('syncthing')
 provides=('syncthing')
 arch=('i686' 'x86_64')
-source=("$pkgname-$pkgver::git+https://github.com/syncthing/syncthing.git")
+source=("$pkgname::git+https://github.com/syncthing/syncthing.git")
 sha256sums=('SKIP')
 install=${pkgname}.install
 _name=syncthing
@@ -21,7 +21,7 @@ prepare() {
 }

 pkgver() {
-   cd "${pkgname}-${pkgver}"
+   cd "${pkgname}"
    git describe --long | sed -E 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
 }

@@ -29,7 +29,7 @@ build() {
    export GOPATH="${srcdir}"
    cd "${srcdir}"
    mkdir -p "src/github.com/syncthing"
-   mv "${pkgname}-${pkgver}" "src/github.com/syncthing/${_name}"
+   mv "${pkgname}" "src/github.com/syncthing/${_name}"
    cd "src/github.com/syncthing/${_name}"
    if [ ${CARCH}" == "i686" ] ; then
            go run build.go -no-upgrade -goarch 386 build

sauyon commented on 2017-02-18 21:34

can somebody inform me why this was flagged out of date?

diggit commented on 2016-07-28 09:41

prepare() moves sources and the pkgver() can't get correct version.
Also, I can't see the reason to pull sources to folder with version in name.

rumpelsepp commented on 2015-06-11 20:48

This package is quite old:

- There are official manpages now: https://github.com/syncthing/syncthing/tree/master/man
- There are official systemd files now: https://github.com/syncthing/syncthing/tree/master/etc/linux-systemd
- The License is MPL now: https://github.com/syncthing/syncthing/blob/master/LICENSE
- Please update the SRCINFO. It does not match the PKGBUILD