Package Details: system-config-lvm 1.1.18-4

Git Clone URL: https://aur.archlinux.org/system-config-lvm.git (read-only)
Package Base: system-config-lvm
Description: A utility for graphical configuration of Logical Volumes
Upstream URL: http://fedoraproject.org/wiki/SystemConfig/lvm
Licenses: GPL
Submitter: phects
Maintainer: phects
Last Packager: phects
Votes: 62
Popularity: 0.563717
First Submitted: 2008-08-04 17:52
Last Updated: 2015-07-05 17:52

Latest Comments

coryt commented on 2017-08-10 07:40

Has anyone figured out a fix for this?

from Volume_Tab_View import Volume_Tab_View File "/usr/share/system-config-lvm/Volume_Tab_View.py", line 11, in <module>
from Properties_Renderer import Properties_Renderer File "/usr/share/system-config-lvm/Properties_Renderer.py", line 33, in <module>
import gnome
ImportError: No module named gnome

As @wayfarer_rus pointed out it seems to be an issue with the gnome-python dependency. @Swipe and @wayfarer did system-config-lvm work for you before you started experiencing these errors?

I ask this because on 1/25/17 about a month before both of you posted about this error the gnome-python package base was updated.

Another reason to believe it is caused by the 1/25/17 package base update is another AUR comment posted by @voyd with the error on it for the package gsieve which was also last updated in 2015. It is the only comment posted after 1/25/17 and judging by the 2 previous comments this specific issue was non-existent.

https://aur.archlinux.org/packages/gsieve/

The last gnome-python commit says "Strip all modules except python2-gconf"
and looking at the differences a few packages were removed.

python2-bonobo, python2-libgnome, python2-gnomecanvas, python2-gnomevfs

I think because mostly they were all combined into one package somewhere as this added line disables them all.

PYTHON=python2 ./configure --prefix=/usr --disable-gnome --disable-gnomeui --disable-gnomecanvas --disable-gnomevfs --disable-gnomevfsbonobo --disable-pyvfsmodule --disable-bonobo_activation --disable-bonobo --disable-bonoboui

My last resort as a sanity check was explicitly running system-config-lvm with python2 from the terminal which gave the same error.


I feel like I've hit a roadblock on this if anyone else sees this and has any thoughts I'd love to hear them.

Swipe commented on 2017-02-27 21:23

This has also stopped working for me:

Traceback (most recent call last):
File "/usr/bin/system-config-lvm", line 47, in <module>
from Volume_Tab_View import Volume_Tab_View
File "/usr/share/system-config-lvm/Volume_Tab_View.py", line 11, in <module>
from Properties_Renderer import Properties_Renderer
File "/usr/share/system-config-lvm/Properties_Renderer.py", line 33, in <module>
import gnome
ImportError: No module named gnome

wayfarer_rus commented on 2017-02-23 11:39

Doesn't work. Some kind of issue with gnome-python dependency:
$ system-config-lvm
Traceback (most recent call last):
File "/usr/bin/system-config-lvm", line 47, in <module>
from Volume_Tab_View import Volume_Tab_View
File "/usr/share/system-config-lvm/Volume_Tab_View.py", line 11, in <module>
from Properties_Renderer import Properties_Renderer
File "/usr/share/system-config-lvm/Properties_Renderer.py", line 33, in <module>
import gnome
ImportError: No module named gnome

albfan commented on 2016-12-03 11:38

uudruid can you post here exact instructions to exec with policy kit. I try with https://bbs.archlinux.org/viewtopic.php?id=127648 but doesn't work

uudruid commented on 2016-10-06 00:16

The package needs a bit of work to be run from desktop, and since this is a GUI app and it would violate my policy to log in to X as root (or even have a root login at all), some work needs to be done.

I've wrapped it in a shell script that runs it from pkexec and created a policykit file for it and it mostly works. It still complains about DBUS ...

Client failed to connect to the D-BUS daemon:
Using X11 for dbus-daemon autolaunch was disabled at compile time, set your DBUS_SESSION_BUS_ADDRESS instead

I thought pkexec would have taken care of that with DISPLAY, but I can't spend more time on this right now.

ams1 commented on 2015-11-02 11:28

The package depends on gksu, but doesn't actually seem to use it?

I can't launch this via the .desktop file, but only from the CLI using sudo.

wayfarer_rus commented on 2015-02-06 17:30

Couldn't build it.
Sources depend on older type of autotools.
Error Log:
/home/wayfarer/aur/system-config-lvm/src/system-config-lvm-1.1.18/missing: line 46: aclocal-1.11: command not found
....
home/wayfarer/aur/system-config-lvm/src/system-config-lvm-1.1.18/missing: line 46: automake-1.11: command not found
.....

Florian commented on 2014-04-09 09:25

Somewhat updated PKGBUILD: http://pastebin.com/LcyTKQgf

dlandau commented on 2013-08-09 11:37

As FlorianD wrote. When installing with yaourt, the package didn't work at all, since yaourt removes the $pkgdir after building.

Florian commented on 2013-06-13 15:46

Please don't link to your $pkgdir, but rather the absolute path of the target binary i.e.
ln -fs $pkgdir/usr/... -> ln -fs /usr/...

mrechte commented on 2013-06-05 09:23

Hello. To become compatible with the /usr/sbin removal, please add --sbindir=/usr/bin to the configure option.

phects commented on 2012-03-27 15:22

Thanks for your suggestions. Updated to 1.1.16.

silasdavis commented on 2012-03-14 12:15

The source link is broken:

http://download.fedora.redhat.com/pub/fedora/linux/releases/14/Fedora/source/SRPMS/system-config-lvm-1.1.15-1.fc14.src.rpm

Could use instead:

http://arm.koji.fedoraproject.org/packages/system-config-lvm/1.1.15/1.fc14/src/system-config-lvm-1.1.15-1.fc14.src.rpm

schalox commented on 2012-03-11 09:00

Updated to 1.1.16 and slightly modified the PKGBUILD:
http://pastebin.com/h0SNDuRA

Anonymous comment on 2011-04-08 17:47

Download link didn't work for me, this one did:
http://download.fedora.redhat.com/pub/fedora/linux/releases/14/Fedora/source/SRPMS/system-config-lvm-1.1.15-1.fc14.src.rpm

phects commented on 2010-10-20 14:41

Done.
Thanks for your proposal!

phects commented on 2010-10-01 13:42

Oh, you're right. Added gksu to depends and uploaded 1.1.13-2.

dcelasun commented on 2010-10-01 13:06

Uhm, if you are going to use that patch, you need to add gksu to the deps array.