Package Details: system76-driver-git 20.04.72.r0.g074844c-1

Git Clone URL: https://aur.archlinux.org/system76-driver-git.git (read-only, click to copy)
Package Base: system76-driver-git
Description: System76 Driver for System76 computers
Upstream URL: https://github.com/pop-os/system76-driver
Licenses: GPL
Conflicts: system76-driver
Provides: system76-driver
Submitter: m3thodic
Maintainer: m3thodic
Last Packager: m3thodic
Votes: 1
Popularity: 0.000000
First Submitted: 2019-04-16 19:13 (UTC)
Last Updated: 2023-01-21 01:54 (UTC)

Pinned Comments

m3thodic commented on 2021-08-05 00:18 (UTC)

With the latest update you may need to manually remove some pycache files before upgrading. This can be done with the following 2 lines:

local site_packages="$(python -c 'import site; print(site.getsitepackages()[0])')"
for i in $(find "${site_packages}/system76driver/__pycache__/" -type f); do pacman -Qo "$i" 2>/dev/null || sudo rm -fv "$i"; done

Thanks!

Latest Comments

m3thodic commented on 2021-08-05 00:18 (UTC)

With the latest update you may need to manually remove some pycache files before upgrading. This can be done with the following 2 lines:

local site_packages="$(python -c 'import site; print(site.getsitepackages()[0])')"
for i in $(find "${site_packages}/system76driver/__pycache__/" -type f); do pacman -Qo "$i" 2>/dev/null || sudo rm -fv "$i"; done

Thanks!

yochananmarqos commented on 2021-05-12 22:06 (UTC)

@m3thodic: The galu1.patch is no longer needed as the model has been added upstream. The gtk.patch was removed before I started maintaining system76-driver.

The __pycache__ files should not be removed, see my comment and recent commits.

Please stop making commits just to bump the pkgver, it's a VCS package. It's completely unnecessary.

tkolo commented on 2020-06-27 00:38 (UTC)

FYI this doesn't build anymore due to different binaries being present in install tree

m3thodic commented on 2019-09-10 17:46 (UTC)

@yochananmarqos just pushed an update, lemme know if that works. thanks again!

m3thodic commented on 2019-09-03 17:23 (UTC)

@yochananmarqos I saw they made changes and I've edited the PKGBUILD just haven't committed/pushed until the new repo stabilized but I'll get to that this week. Thanks!

yochananmarqos commented on 2019-08-20 18:36 (UTC) (edited on 2019-08-21 15:07 (UTC) by yochananmarqos)

This now depends on firmware-manager, see commit.

EDIT: I added it: firmware-manager-git.