Package Details: systemd-kcm 1.2.1-4

Git Clone URL: https://aur.archlinux.org/systemd-kcm.git (read-only)
Package Base: systemd-kcm
Description: Systemd control module for KDE
Upstream URL: https://github.com/rthomsen/kcmsystemd
Licenses: GPL
Submitter: arojas
Maintainer: fordprefect
Last Packager: BluePeril
Votes: 4
Popularity: 0.272765
First Submitted: 2018-05-30 21:58
Last Updated: 2018-06-06 05:46

Latest Comments

1 2 Next › Last »

fightcookie commented on 2018-06-06 10:03

Please change the source URL to the TLS encrypted https variant instead of plain http! I tested it and it works perfectly. Thanks :)

piedro commented on 2018-06-02 11:19

Same error for me: unrecognized option '--color never'

darkbasic commented on 2018-06-01 10:58

Am I the only one who gets the following error? /usr/bin/pacman: unrecognized option '--color never'

Is it because of pacaur or is the pkgbuild broken?

dixi_minga commented on 2018-05-31 20:26

I followed eaburto and Tara:

  • downlaod snapshot
  • do makepkg -> error appears
  • edit src/systemd-kcm-1.2.1/src/CMakeLists.txt
  • there comment last line -> "# qt5_use_modules(kcm_systemd Widgets DBus)"
  • add line below: "target_link_libraries(kcm_systemd Qt5::Widgets Qt5::DBus)"
  • makepkg -e
  • pacman -U systemd-kcm-1.2.1-3-x86_64.pkg.tar.xz

And of course I have no idea, what I have done

Tara commented on 2018-05-31 12:51

I have reported the patch upstream.

Tara commented on 2018-05-31 12:41

I created a patch.

PKGBUILD https://pastebin.com/ZM3YDHQW

qt5_use_modules.patch https://pastebin.com/63XmxpwT

zoe commented on 2018-05-31 08:28

Same error for me. I left that package, and I replaced it with systemdgenie [community], which does the job very well.

eaburto commented on 2018-05-31 07:26

I was getting the same error. Seems like it's an obsolete command and now setting the proper target_link_libraries does import all the dependencies. I commented that line from src/CMakeLists.txt and it compiles and works just fine. I don't know if this should be reported upstream or just patch the PKGBUILD here.

simona commented on 2018-05-31 06:47

CMake Error at src/CMakeLists.txt:41 (qt5_use_modules): Unknown CMake command "qt5_use_modules".

-- Configuring incomplete, errors occurred!

nfs commented on 2018-05-30 23:43

I'm getting the same results as flops.