Package Details: systemd-sysvcompat-git 254.r67937.abcf59970d-1

Git Clone URL: https://aur.archlinux.org/systemd-git.git (read-only, click to copy)
Package Base: systemd-git
Description: sysvinit compat for systemd (git version)
Upstream URL: https://www.github.com/systemd/systemd
Keywords: git init systemd
Licenses: GPL2
Conflicts: systemd-sysvcompat, sysvinit
Provides: systemd-sysvcompat
Submitter: yurikoles
Maintainer: yurikoles
Last Packager: yurikoles
Votes: 9
Popularity: 0.000000
First Submitted: 2015-10-23 20:49 (UTC)
Last Updated: 2023-10-16 15:15 (UTC)

Dependencies (46)

Required by (7)

Sources (19)

Pinned Comments

yurikoles commented on 2018-03-27 13:17 (UTC) (edited on 2019-04-14 16:12 (UTC) by yurikoles)

PRs are welcome: https://github.com/yurikoles/systemd-git

If check fails use makepkg with --nocheck

Latest Comments

1 2 3 4 5 6 Next › Last »

Not_Available commented on 2023-12-11 17:36 (UTC)

outdated. 255 is available

yurikoles commented on 2023-09-20 12:11 (UTC) (edited on 2023-09-21 16:19 (UTC) by yurikoles)

xiota,

This package is aligned with official stable systemd package as much as possible. I double-checked diff between them and I can confirm no single replace block is touched nor added in this package compared to a stable one.

yourealwaysbe commented on 2023-08-29 13:59 (UTC)

Thanks for the package.

I found i also needed to install libpwquality, libselinux, apparmor, and xen to get the build to go through.

ms178 commented on 2023-04-19 16:05 (UTC)

@yurikoles For some reason, I see problems with sudo and systemd-git for a couple of days:

sudo: /etc/sudo.conf is owned by uid 65534, should be 0 sudo: /usr/bin/sudo muss dem Benutzer mit UID 0 gehören und das »setuid«-Bit gesetzt haben

Any ideas?

ms178 commented on 2023-03-26 11:30 (UTC) (edited on 2023-03-26 11:32 (UTC) by ms178)

@yurikoles, after re-syncing my custom package with your PKGBUILD, there seems to be an error in the install script somewhere, I now see:

usr/lib/systemd/system local-fs.target.wants/ tmp.mount /usr/lib/systemd/system remote-fs.target.wants/ var-lib-machines.mount /usr/lib/systemd/system machines.target.wants/ var-lib-machines.mount' Running custom install script '/tmp/makepkg/systemd-git/src/systemd/tools/meson-make-symlink.sh /etc/systemd/user /etc/xdg/systemd/user' Running custom install script '/tmp/makepkg/systemd-git/src/systemd/tools/meson-make-symlink.sh /usr/share/dbus-1/system-services/org.freedesktop.systemd1.service /usr/share/dbus-1/services/org.freedesktop.systemd1.service' Running custom install script '/usr/bin/sh -c mkdir -p $DESTDIR//var/lib/systemd' Running custom install script '/usr/bin/sh -c touch $DESTDIR/usr' mv: der Aufruf von stat für '/tmp/makepkg/systemd-git/pkg/systemd-git/usr/lib/systemd/ukify' ist nicht möglich: Datei oder Verzeichnis nicht gefunden ==> FEHLER: Ein Fehler geschah in package_systemd-git(). Breche ab...

Somehow the new systemd-ukify file or folder was not created?

yurikoles commented on 2022-10-12 04:01 (UTC)

@bittin this is -git / devel package, version is calculated automatically on every build, so no manual bump is required.

yurikoles commented on 2022-08-01 08:29 (UTC)

Hello ms178,

Thank you for the reminder, I actually did this a few days ago, just forgot to push my changes.

ms178 commented on 2022-07-31 15:38 (UTC)

@yurikoles, 0001-Use-Arch-Linux-device-access-groups.patch needs a re-base as it won't apply on latest git any longer.