Package Details: taffybar 3.0.0-2

Git Clone URL: https://aur.archlinux.org/taffybar.git (read-only)
Package Base: taffybar
Description: A desktop bar similar to xmobar, but with more GUI
Upstream URL: http://github.com/travitch/taffybar
Licenses: BSD3
Submitter: pdxleif
Maintainer: pdxleif (yakshaver, SolarAquarion)
Last Packager: SolarAquarion
Votes: 2
Popularity: 0.158486
First Submitted: 2018-01-27 20:24
Last Updated: 2018-10-07 16:16

Latest Comments

dongcarl commented on 2018-06-12 21:12

Can confirm pdxleif's problem.

pdxleif commented on 2018-06-11 18:22

In the install script I get "/tmp/alpm_tWLmKt/.INSTALL: line 5: msg2: command not found" - what package is supposed to provide msg2? Should that just be "echo"?

dongcarl commented on 2018-06-11 18:22

Great to see that the PKGBUILD is now staying up to date with the GitHub repo! <3

anthraxx commented on 2018-06-11 11:05

  • There are two dependencies missing (see dependency list in AUR page)
  • Please don't pull from master HEAD xmonad.hs.example but use a static commit so content doesn't change (you could as well just pull from github instead of hackage and you would have everything you need in one tarball

SolarAquarion commented on 2018-06-07 18:17

https://aur.archlinux.org/packages/haskell-dbus-hslogger/ i added a dependency, but there's seemingly a lot more in 2.0

pdxleif commented on 2018-04-16 07:13

Sorry about the delay - updated to v1.0.1. It now uses gtk3 and dbus 1.0.

yakshaver commented on 2018-04-12 07:56

@alhirzel Using the old version of haskell-dbus isn't necessary since

https://github.com/travitch/taffybar/issues/254

has integrated the new haskell-dbus version, and there is a new version of taffybar that has this change. This package is out of date, and needs to be updated. If it isn't updated, I'm going to request its removal as the maintainer of the package.

alhirzel commented on 2018-04-09 03:35

Due to recent changes, I suggest changing the haskell-dbus dependency to haskell-dbus0.10

pdxleif commented on 2018-04-02 22:53

Sorry - could you give some more context? Where do you see this red-marked dependencies? What command were you running when you saw that? What are "red-marked" dependencies - does that mean they are unavailable? Could you give an example of a specific one? If you are simply downloaded this PKGBUILD manually and are running "makepkg -s" on it, be aware that not all dependencies are already in the official binary repositories such as [community]. For example, if you click on the "haskell-hstringtemplate" dependency in the web page above, it'll take you to the page for another package here on AUR, as opposed to the official package repos. Those dependencies must be installed before this package. I would recommend using an AUR helper to do so, instead of downloading PKGBUILD's and running "makepkg" on each meanually. A list of AUR helpers is on the wiki: https://wiki.archlinux.org/index.php/AUR_helpers I myself use "yaourt", so my install process for this package is just "yaourt -S taffybar".

timelaw commented on 2018-02-24 11:29

What does one do about those red-marked dependencies?