Package Details: tagainijisho 1.0.3-1

Git Clone URL: https://aur.archlinux.org/tagainijisho.git (read-only)
Package Base: tagainijisho
Description: A Free Japanese dictionary and study assistant
Upstream URL: http://www.tagaini.net/
Licenses: GPL3
Submitter: None
Maintainer: Gnurou
Last Packager: Gnurou
Votes: 45
Popularity: 0.191273
First Submitted: 2009-07-24 10:18
Last Updated: 2015-06-21 06:27

Dependencies (4)

Required by (0)

Sources (1)

Latest Comments

Gnurou commented on 2014-05-27 00:22

Updated the archs - thanks for testing!

TwoNotes commented on 2014-05-26 17:07

I can verify that TagainiJisho builds and runs properly on ARM platforms.
(At least, on armv7h.) So the 'arch' limitation in the PKGBUILD can be
updated.

Gnurou commented on 2013-12-18 14:18

Mmm just tried and it works for me. Could it be that the kanji database builder doesn't like UTF-8 in paths, i.e. that "ダウンロード" directory? Can you try building again in a more common directory?

Vamp898 commented on 2013-12-18 10:49

thx, but sadly it doesnt build

[ 3%] Generating ../../../kanjidic2.db
Cannot open database: unable to open database file
/home/vamp898/ダウンロード/tagainijisho/src/tagainijisho-1.0.1/src/core/kanjidic2/BuildKanjiDB.cc: assert condition failed, line 615
src/core/kanjidic2/CMakeFiles/kanjidic2-db.dir/build.make:56: recipe for target 'kanjidic2.db' failed
make[2]: *** [kanjidic2.db] Error 1
CMakeFiles/Makefile2:470: recipe for target 'src/core/kanjidic2/CMakeFiles/kanjidic2-db.dir/all' failed
make[1]: *** [src/core/kanjidic2/CMakeFiles/kanjidic2-db.dir/all] Error 2
Makefile:136: recipe for target 'all' failed
make: *** [all] Error 2

Gnurou commented on 2013-11-25 02:30

Vamp898: your issue should be fixed with the latest version of this package (1.0.1-2).

Vamp898 commented on 2013-10-06 16:57

As i forgot the Link to the Bug-Tracker, and cant find a link to the bug-tracker on the webpage, im asking here.

For me it crashed when i try to export a set as HTML

Worked fine in the Version before

Critical: kfilemodule(9959): couldn't create slave: "Unable to create io-slave:
klauncher said: Unkown Protocoll ??.

Vamp898 commented on 2013-09-08 11:31

awesome, works

Thanks a lot

Gnurou commented on 2013-09-07 14:49

Version 1.0.0 released! Versions of SQLite that crash have been blacklisted. By the meantime the SQLite team fixed the bug in 3.8.0.2. Other small bugfixes are also in.

Gnurou commented on 2013-09-01 23:54

Yes, this is apparently a bug with SQLite. Version 1.0.0 (soon to be officially released) blacklists these versions, you can use it.

Vamp898 commented on 2013-09-01 16:29

On Gentoo this package doesnt work with sqlite 3.8

It throws segfaults when trying to display Descriptions for Kanji and so on

Can anyone reproduce this with Archlinux?

Gnurou commented on 2013-03-17 07:30

Should be fixed now, could you give it a try?

benwbooth commented on 2013-03-16 18:27

I get an error message when I try to build this package:

==> Starting build()...
CMake Error: The source directory "/tmp/yaourt-tmp-ben/aur-tagainijisho/src" does not appear to contain CMakeLists.txt.
Specify --help for usage, or press the help button on the CMake GUI.
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build tagainijisho.

Thanks

Gnurou commented on 2013-03-01 13:17

Fixed, thanks!

o_caino commented on 2013-03-01 12:15

qt<=4.8.4 is now replaced by qt4

Gnurou commented on 2012-07-31 02:10

I have tried building the package on my machine and it worked without any issue. Could you put a full log on pastebin?

Anonymous comment on 2012-07-31 00:08

I've attempted the download five times at my home location throughout a period of two days, all of which had the same effect. I just tried now at a coffee shop and again it reached 100% and I recieved a failed download message. I have installed several other AUR packages within this same timeframe without incident.... and I just looked up how to get you a log file and ran makepkg with the -L option and it worked just fine. I guess maybe the server it's downloading from is just very finicky.

Gnurou commented on 2012-07-30 02:23

Kurayami: this is most likely a one-time download problem. If you can reproduce this please let me know though.

Anonymous comment on 2012-07-29 19:57

When downloading I would get to 100% and then I would get an error stating that it failed to download and the package would not build. I don't know if it's a problem with the PKGBUILD file or not. My workaround was to remove the '.part' from the downloaded file and run makepkg again, after that it installed fine:
mv tagainijisho-0.9.4.tar.gz.part tagainijisho-0.9.4.tar.gz
makepkg -s

Gnurou commented on 2012-05-11 23:55

Updated to 0.9.4.

Gnurou commented on 2012-05-11 10:15

Anyone willing to take over this package? I will like to get some items out of my release checklist and this one seems good.

Gnurou commented on 2012-04-01 11:46

Updated to 0.9.3.

Gnurou commented on 2012-01-26 02:33

StefanHusmann: confirmed and fixed, thanks!

haawda commented on 2012-01-25 22:08

Builds only when passing some more explicite linker flags. The followin builld function does the trick for me.

build() {
cd "$srcdir/$pkgname-$pkgver"
CFLAGS=`echo $CFLAGS | sed 's/-ffast-math//'` cmake \
-DCMAKE_EXE_LINKER_FLAGS="${CMAKE_EXE_LINKER_FLAGS} -lpthread -ldl" \
-DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr .
make
}

haawda commented on 2012-01-25 21:29

Builds only when passing some more explicite linker flags. The followin builld function does the trick for me.

build() {
cd "$srcdir/$pkgname-$pkgver"
CFLAGS=`echo $CFLAGS | sed 's/-ffast-math//'` cmake \
-DCMAKE_EXE_LINKER_FLAGS="${CMAKE_EXE_LINKER_FLAGS} -lpthread -ldl" \
-DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr .
make
}

Gnurou commented on 2011-11-17 13:44

Updated to latest version.

Gnurou commented on 2011-11-15 12:52

Taking over. Thanks for maintaining this package all this time!

Anonymous comment on 2011-11-15 12:45

Hello, I don't have time to do any language studies nowadays and therefore am not using this anymore. So I'm disowning the package.

Anonymous comment on 2010-08-31 14:58

0.2.6.2

Anonymous comment on 2010-08-20 13:14

Back to 0.2.6

Gnurou commented on 2010-08-20 09:21

0.2.6.1 has been withdrawn because of a serious flaw. Sorry for the inconvenience - could you revert the package back to 0.2.6?

Anonymous comment on 2010-08-19 09:42

Updated to 0.2.6.1

Anonymous comment on 2010-08-16 21:09

Updated to 0.2.6

Anonymous comment on 2010-04-01 20:38

Maybe just remove the -ffast-math flag, for example by prefixing the cmake command with

CFLAGS=`echo $CFLAGS | sed 's/-ffast-math//'` cmake ...

That seemed to work, could you test it?

Anonymous comment on 2010-04-01 14:53

It doesn't build with -ffast-math. Maybe the cflags should be unset in the pkgbuild?

Anonymous comment on 2010-04-01 09:32

Updated to 0.2.5