Package Details: tageditor 3.7.4-1

Git Clone URL: https://aur.archlinux.org/tageditor.git (read-only, click to copy)
Package Base: tageditor
Description: A tag editor with Qt GUI and command-line interface supporting MP4/M4A/AAC (iTunes), ID3, Vorbis, Opus, FLAC and Matroska
Upstream URL: https://github.com/Martchus/tageditor
Keywords: aac edit id3 matroska mp3 mp4 ogg opus Qt tags vorbis
Licenses: GPL
Submitter: Martchus
Maintainer: Martchus
Last Packager: Martchus
Votes: 16
Popularity: 0.014699
First Submitted: 2015-08-27 19:29 (UTC)
Last Updated: 2022-08-02 18:37 (UTC)

Pinned Comments

Martchus commented on 2016-05-18 22:03 (UTC) (edited on 2020-04-16 17:06 (UTC) by Martchus)

All my packages are managed at GitHub where you can also contribute directly: https://github.com/Martchus/PKGBUILDs There also exist a binary repository: https://martchus.no-ip.biz/repo/arch/ownstuff


This version contains both, the CLI and the Qt 5 GUI. Checkout tageditor-cli for a minimal CLI-only version.

Latest Comments

demanciel commented on 2021-07-10 08:43 (UTC)

Hello, The sha256sum in the 3.4.1-1 version of PKGBUILD shows the same as for version 3.4.0-1 which is wrong. It should be set to 4d3218531fae449ffa76098fbe9a4693e43f2f93d0d38bb4163d6a9ce864d6c7 for 3.4.1. Cheers.

Martchus commented on 2020-03-28 23:01 (UTC)

I've just had a look at ffmpeg-full and there's indeed room for improvement, see https://aur.archlinux.org/packages/ffmpeg-full/#comment-736172.

tydynrain commented on 2020-03-28 22:56 (UTC)

@Martchus Yes. On the system with the build failure I had ffmpeg-full installed, instead of ffmpeg. I'll reinstall ffmpeg to see if that fixes it.

arichiardi commented on 2020-03-26 02:29 (UTC)

Thank you Martchus. Kinda noob to this. Your suggestion worked.

Martchus commented on 2020-03-21 13:41 (UTC)

@arichiardi The error message tells you actually quite plainly what the problem is: your version of c++utilities is too old. The official distribution does not support partial updates and the same is true for the AUR package I maintain. So you have to build the latest version of c++utilities, qtutilities and tagparser first before building this package.

arichiardi commented on 2020-03-21 00:39 (UTC)

Hi there, I tried this but it does not like something I cannot really grasp.

$ TAGEDITOR_JSON_EXPORT=OFF pamac build tageditor

CMake Error at CMakeLists.txt:184 (find_package): Could not find a configuration file for package "c++utilities" that is compatible with requested version "5.0.0".

The following configuration files were considered but not accepted:

/usr/share/c++utilities/cmake/c++utilitiesConfig.cmake, version: 4.17.1

a_manthey commented on 2020-02-05 22:04 (UTC)

thanks, now i could update the 5 packages

Martchus commented on 2020-02-05 11:02 (UTC)

I'm usually building packages from locally created archives before releasing and then release the projects on GitHub when everything builds fine. This time I screwed up and the checksums of locally created archives ended up in the final PKGBUILDs. It should be fixed now.

a_manthey commented on 2020-02-05 10:27 (UTC)

update not possible because of wrong sha256sum, same for the dependencies reflective-rapidjson, qtutilities aund their dependenciy c++utilities

simona commented on 2019-01-11 18:19 (UTC)

I still get the error

Martchus commented on 2019-01-11 09:26 (UTC)

Checksum should be fixed now.

simona commented on 2019-01-11 09:17 (UTC)

=> Validazione di source file con sha256sums... tageditor-3.1.3.tar.gz ... NON RIUSCITO ==> ERRORE: Uno o più file non hanno superato il controllo di validità!

Martchus commented on 2018-01-27 14:36 (UTC)

@lord_rel I've uploaded the missing packages.

BTW: I also updated this package so using _json_export=OFF should actually work. In this case reflective-rapidjson is not required. So you can save a few build-time dependencies if you don't need the JSON export.

lord_rel commented on 2018-01-27 12:07 (UTC)

reflective-rapidjson is missing from the official repos or AUR

Martchus commented on 2017-09-13 08:51 (UTC) (edited on 2017-09-14 21:30 (UTC) by Martchus)

Version of tagparser 6.4.0 contains serious bugs causing broken MP4 and Matroska files: https://github.com/Martchus/tagparser/issues/7 So it is highly recommended to update to 6.4.1 before continue using tagparser/tageditor. To apply the fixes is not required to rebuild tageditor.

Martchus commented on 2017-02-02 16:07 (UTC)

I will improve this when updating the package anyways. This would also concern the dependencies c++utilities and qtutilities. However, I'm wondering what helper you use. I mean, when updating packages it should ensure that dependencies are built before packages requiring them (regardless of the specific version).

ponsfoot commented on 2017-02-02 05:09 (UTC)

tageditor 2.2.0 requires tagparser>=6.2.0 so depends=() should be specified so. tageditor might be built before tagparser (especially on aur helper).

Martchus commented on 2016-05-18 22:03 (UTC) (edited on 2020-04-16 17:06 (UTC) by Martchus)

All my packages are managed at GitHub where you can also contribute directly: https://github.com/Martchus/PKGBUILDs There also exist a binary repository: https://martchus.no-ip.biz/repo/arch/ownstuff


This version contains both, the CLI and the Qt 5 GUI. Checkout tageditor-cli for a minimal CLI-only version.

Martchus commented on 2015-09-06 19:38 (UTC) (edited on 2016-05-18 22:03 (UTC) by Martchus)

I updated the tagparser library. It should build now.

Martchus commented on 2015-09-06 12:10 (UTC)

I can reproduce the error and will check whats going on. (This problem actually occurs when building the tagparser, not the tageditor.)

Simone98RC commented on 2015-09-06 09:47 (UTC)

Latest release can't be compiled due to a fatal error (../caseinsensitivecomparer.h: File o directory not existing)