Package Details: targetcli-fb 2.1.fb43-1

Git Clone URL: https://aur.archlinux.org/targetcli-fb.git (read-only)
Package Base: targetcli-fb
Description: free branch of the targetcli LIO administration shell (iSCSI + Co)
Upstream URL: https://github.com/agrover/targetcli-fb
Licenses: Apache
Provides: targetcli
Submitter: JonnyJD
Maintainer: JonnyJD
Last Packager: JonnyJD
Votes: 8
Popularity: 0.016600
First Submitted: 2012-02-27 01:05
Last Updated: 2016-05-08 16:53

Latest Comments

JonnyJD commented on 2016-05-17 18:41

Oh thanks. I missed "Make use of pyudev package as much as possible in utils module." as a new dependency in the changelog.
Fixed (in rtslib, where the actual dependency is).

archfan777 commented on 2016-05-12 20:30

community/python-pyudev package required for targetcli-fb
please add depend

JonnyJD commented on 2015-12-08 10:59

thanks, fixed

forumi0721 commented on 2015-12-08 05:58

python-dbus package required to run targetcli
please add depend

JonnyJD commented on 2015-02-23 11:21

I didn't see that yesterday either, but now I see it:

You had python2-configshell-fb installed (Python 2) and now you installed that and python-configshell-fb (Python 3). Pacman said the Python 2 version was installed and installed the Python 3 version ;-)

Many tools still need Python 2, including other LIO tools, but this one works with Python 3 so I use that ;-).

James_Epp commented on 2015-02-22 18:48

@JonnyJD:
I could have sworn I had it installed last night. For whatever reason, today It's working. I decided to re-do the python-configshell-fb installation, and I got this output which I didn't get yesterday, so whatever happened it had to have been my error.

$ sudo pacman -U *.xz
loading packages...
warning: python2-configshell-fb-1.1.fb17-1 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

Packages (4) python-pyparsing-2.0.3-1 python-urwid-1.3.0-1 python-configshell-fb-1.1.fb17-1 python2-configshell-fb-1.1.fb17-1

Total Download Size: 0.39 MiB
Total Installed Size: 4.22 MiB
Net Upgrade Size: 3.49 MiB

:: Proceed with installation? [Y/n]
:: Retrieving packages ...
python-urwid-1.3.0-1-x86_64 332.9 KiB 876K/s 00:00 [#######################################################################################] 100%
python-pyparsing-2.0.3-1-any 68.0 KiB 6.64M/s 00:00 [#######################################################################################] 100%
(4/4) checking keys in keyring [#######################################################################################] 100%
(3/4) checking package integrity [#######################################################################################] 100%
(3/4) loading package files [#######################################################################################] 100%
(4/4) checking for file conflicts [#######################################################################################] 100%
(4/4) checking available disk space [#######################################################################################] 100%
(1/4) reinstalling python2-configshell-fb [#######################################################################################] 100%
(2/4) installing python-pyparsing [#######################################################################################] 100%
(3/4) installing python-urwid [#######################################################################################] 100%
(4/4) installing python-configshell-fb [#######################################################################################] 100%
[

It hadn't downloaded python-urwid or python-pyparsing yesterday when I did this, but it still says that python2-configshell-fb is up to date. This output really sends my head for a spin. Whatever, it works now.

JonnyJD commented on 2015-02-22 11:11

@James_Epp:
Do you have python-configshell-fb 1.1.fb17, or an earlier version, or python2-configshell? There is a minimum required version of python-configshell-fb which currently is *only* the current version of https://aur.archlinux.org/packages/python-configshell-fb/

Having a previous version installed will lead to that error (same as not having it installed at all, I guess).

James_Epp commented on 2015-02-22 02:10

Install dependency error, yet I definitely have the package installed. Can anyone else confirm?

==> Making package: targetcli-fb 2.1.fb39-1 (Sat Feb 21 19:50:43 CST 2015)
==> Checking runtime dependencies...
==> Missing dependencies:
-> python-configshell-fb>=1.1.fb17
==> Checking buildtime dependencies...
==> ERROR: Could not resolve all dependencies.

James_Epp commented on 2015-02-22 02:04

Error during install, I definitely have the dependency met.

==> Making package: targetcli-fb 2.1.fb39-1 (Sat Feb 21 19:50:43 CST 2015)
==> Checking runtime dependencies...
==> Missing dependencies:
-> python-configshell-fb>=1.1.fb17
==> Checking buildtime dependencies...
==> ERROR: Could not resolve all dependencies.

JonnyJD commented on 2014-09-16 13:19

Well, leaving old kernel modules would leave the problem of these accumulating. And on Arch Linux kernel updates are not rare at all.

Anyways, the configfs module is part of the kernel packages, not targetcli/rtslib. That is also the reason it is removed together with the old kernel.
So there is nothing really I can do about that. You have to open an Arch request/ticket for a feature to keep kernel modules on install/update and removing them with a reboot. (you can link the ticket here then)

All comments