Package Details: tauri-devel-meta 1.0.0-3

Git Clone URL: https://aur.archlinux.org/tauri-devel-meta.git (read-only, click to copy)
Package Base: tauri-devel-meta
Description: Meta package to setup development environment for Tauri.
Upstream URL: https://tauri.app/v1/guides/getting-started/prerequisites#setting-up-linux
Licenses: None
Submitter: ouuan
Maintainer: ouuan
Last Packager: ouuan
Votes: 3
Popularity: 0.047582
First Submitted: 2021-08-29 07:33 (UTC)
Last Updated: 2022-06-20 02:15 (UTC)

Latest Comments

ouuan commented on 2022-08-24 18:05 (UTC)

I'm not familiar with this. But if you think it really should be webkit2gtk-4.1, I suggest you open a PR to fix the documentation first. If the PR gets merged, I'll know you are right and modify this AUR package.

RubenKelevra commented on 2022-08-24 17:53 (UTC) (edited on 2022-08-24 17:55 (UTC) by RubenKelevra)

and the guide for Debian explicitly specifies libwebkit2gtk-4.0-dev

Exactly. That's why we need webkit2gtk-4.1 and not the old webkit2gtk.

If you generate an AppImage you end up with these files:

./x.AppDir/usr/lib/webkit2gtk-4.0
./x.AppDir/usr/lib/webkit2gtk-4.0/WebKitNetworkProcess
./x.AppDir/usr/lib/webkit2gtk-4.0/injected-bundle
./x.AppDir/usr/lib/webkit2gtk-4.0/injected-bundle/libwebkit2gtkinjectedbundle.so
./x.AppDir/usr/lib/webkit2gtk-4.0/WebKitWebProcess

And webkit2gtk is on version 2.36.6 right now.

ouuan commented on 2022-08-15 11:56 (UTC)

I think it's webkit2gtk-4.1 not webkit2gtk

Any reference? The documentation says webkit2gtk, and the guide for Debian explicitly specifies libwebkit2gtk-4.0-dev.

RubenKelevra commented on 2022-08-15 11:52 (UTC)

I think it's webkit2gtk-4.1 not webkit2gtk