Package Details: tcl85 8.5.19-1

Git Clone URL: https://aur.archlinux.org/tcl85.git (read-only)
Package Base: tcl85
Description: The Tcl scripting language, 8.5 series
Upstream URL: http://tcl.sourceforge.net/
Licenses: custom
Provides: tcl, tcl=8.5.19
Submitter: b00rt00s
Maintainer: DenBrahe
Last Packager: b00rt00s
Votes: 12
Popularity: 0.099178
First Submitted: 2013-04-13 15:50
Last Updated: 2017-06-06 18:20

Dependencies (0)

Required by (235)

Sources (1)

Latest Comments

b00rt00s commented on 2017-05-29 18:44

I'm dropping this package, because I don't need it anymore.

jnbek commented on 2016-04-20 21:04

I'm looking for someone to take over maintainership of https://aur.archlinux.org/packages/tcloo/ it requires tcl85, but when building it pkg-config's for just tcl which returns for 8.6 I have my hands full keeping up with the rest of my pkgbuilds and would like to pass it along to someone who can give it the love and care it deserves. Comment in said package if interested.

b00rt00s commented on 2015-02-12 12:31

package updated, now coinstallable with tcl8.6.

ant32 commented on 2015-02-11 23:05

http://sourceforge.net/projects/tcl/files/Tcl/8.5.17/

b00rt00s commented on 2014-10-16 09:52

Thanks for the work. However I didn't have time to test this and update PKGBUILDs. I'll try to do it the fastest I can, but I if you want I can leave those packages and you can maintain them.

csslayer commented on 2014-10-09 15:35

I think it would be better to make tcl85 and tcl co-installable. (also tk and tk85).

Following are two working pkgbuilds I adopted from yours, which works well for me.

https://www.dropbox.com/s/xtevc50aiiksu5p/tcl85-8.5.15-2.src.tar.gz?dl=0
https://www.dropbox.com/s/l1yq08wripl8xxz/tk85-8.5.15-1.src.tar.gz?dl=0

b00rt00s commented on 2014-02-05 11:59

@ant32: package updated

ant32 commented on 2014-02-04 23:40

I use this package to install some ubuntu 12.04 packages but they link to libtcl8.5.so.0
Could you create a symlink by adding the following line to your PKGBUILD?
ln -s libtcl8.5.so "${pkgdir}/usr/lib/libtcl8.5.so.0"

eikakot commented on 2014-01-08 14:47

8.5.15 is available

ant32 commented on 2013-11-28 21:37

You'll need to add staticlibs to the options array

All comments