Package Details: tcllib 1.21-1

Git Clone URL: https://aur.archlinux.org/tcllib.git (read-only, click to copy)
Package Base: tcllib
Description: Set of pure-Tcl extensions.
Upstream URL: http://core.tcl.tk/tcllib/
Licenses: BSD
Submitter: Barthalion
Maintainer: gbs
Last Packager: gbs
Votes: 25
Popularity: 0.48
First Submitted: 2018-01-05 17:03 (UTC)
Last Updated: 2022-07-08 13:17 (UTC)

Latest Comments

1 2 Next › Last »

Hupfer commented on 2024-03-15 15:27 (UTC)

Hi,

in the PKGBUILD: tclsh installer.tcl [...] -no-examples [...]

I'd like to have the examples too - would that be possible?

Also, this package is built without critcl - please use critcl, since some routines get a tremendeous speed boost (and I need that...)!

See also the section "Critcl & Accelerators" at https://github.com/tcltk/tcllib/blob/master/embedded/md/tcllib/files/devdoc/tcllib_installer.md#subsection5

Ps.: I fear, this also means, somebody (you / I?) has to add a critcl package to AUR, since actually, there is no (stable) critcl available...

For example, the current 3.2 version from https://andreas-kupries.github.io/critcl/

kind regards Bernhard

fluxus commented on 2021-02-23 16:31 (UTC)

@Merlock - through baph. As a dependency for pd-extended.

merlock commented on 2021-02-17 14:36 (UTC)

@fluxus: How are you trying to install it? Makepkg? Some kind of helper?

fluxus commented on 2021-02-17 13:42 (UTC)

I get "File /var/cache/pacman/pkg/tcllib-1.19-3-any.pkg.tar.zst is corrupted (invalid or corrupted package (checksum))." when trying to install.

skydrome commented on 2020-04-12 06:23 (UTC)

the rest extension requires tdom, if you want to add that to optdepends

slav commented on 2019-06-15 11:51 (UTC)

Thank you!

slav commented on 2019-06-15 11:01 (UTC)

Could you fix please...

/tmp/yaourt-tmp-user/aur-tcllib/./PKGBUILD: line 19: cd: /tmp/yaourt-tmp-user/aur-tcllib/src/tcllib-tcllib-1-19: No such file or directory

Thanks

christianlupus commented on 2019-06-15 07:10 (UTC)

You can use this patch: https://gist.github.com/christianlupus/435f13d860ab60af72c9e624e245a889

kyak commented on 2019-06-14 17:42 (UTC)

It's a bug in PKGBUILD, in the cd $srcdir line.

paxet commented on 2019-06-14 11:36 (UTC) (edited on 2019-06-18 11:52 (UTC) by paxet)

Package cannot be built as there are only Release Candidates for tcllib (at Github) but not a final 1.19 as specified at the PKGBUILD. Maybe they removed it?