Package Details: tcp_wrappers 7.6-20

Git Clone URL: https://aur.archlinux.org/tcp_wrappers.git (read-only)
Package Base: tcp_wrappers
Description: Monitors and Controls incoming TCP connections
Upstream URL: ftp://ftp.porcupine.org/pub/security/index.html
Licenses: custom
Groups: base
Submitter: falconindy
Maintainer: SunRed
Last Packager: SunRed
Votes: 360
Popularity: 1.036658
First Submitted: 2011-09-01 15:06
Last Updated: 2015-12-21 16:04

Latest Comments

jethrogb commented on 2016-08-26 22:48

The patch is now at https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/archlinux-stuff/tcp-wrappers-7.6+.patch.gz

SunRed commented on 2015-12-21 15:29

@oxalin Fixed! Thank you.

oxalin commented on 2015-12-21 03:57

There is a problem with the PKGBUILD file when only tcp_wrappers-libs is being installed. It rapidly fails with the following error:
==> Starting prepare()...
/tmp/yaourt-tmp-ademers/aur-tcp_wrappers-libs/./PKGBUILD: line 25: cd: /tmp/yaourt-tmp-ademers/aur-tcp_wrappers-libs/src/tcp_wrappers-libs_7.6: No such file or directory
==> ERROR: A failure occurred in prepare().
Aborting...

The reason is simple to understand when we look at the culprit line:
cd $srcdir/${pkgname}_${pkgver}

Here, since we are building tcp_wrappers-libs, the pkgname is not "tcp_wrappers" as it should, but it is replace by "tcp_wrappers-libs". If we look at the lib32 version of this package, we see that "tcp_wrappers" was hardcoded in the path under prepare(). So, in the current PKGBUILD, line 25 should be replaced by the following:
cd $srcdir/${pkgbase}_${pkgver}

SunRed commented on 2015-09-02 18:02

There's nothing wrong, no need to flag.

xisberto commented on 2015-09-02 15:42

The upstream URL is non-reacable.

cornholio commented on 2014-10-18 04:20

Added: armv5te, armv6h, armv6l, armv7h, armv7l

mastashake57 commented on 2014-02-20 05:22

I agree with Kernald... I just compiled this on an ARM device, no problems whatsoever.

How do we get ARM as officially supported?

goodmen commented on 2013-11-28 02:55

Wow! 563 votes, why does this pkg not adopted by any TU?

fukawi2 commented on 2013-06-04 01:51

Please update PKGBUILD to install binaries to /usr/bin instead of /usr/sbin in line with recent changes: https://www.archlinux.org/news/binaries-move-to-usrbin-requiring-update-intervention/

Kernald commented on 2012-07-08 10:42

Builds fine and runs fine on arm, which can be added to supported architectures.

alexcortes commented on 2012-04-19 22:43

Gentoo is using a Debian patchset in tcp_wrappers. I don't no if that is better or what but maybe you wanna to take a look.

http://packages.gentoo.org/package/sys-apps/tcp-wrappers

trusktr commented on 2011-10-14 12:06

Built using yaourt today, no error.

khampf commented on 2011-10-03 09:20

Build using yaourt and also using "makepkg" produces error.
install -o root -g root -m 0755 shared/libwrap.so.0.7.6 /tmp/yaourt-tmp-core/aur-tcp_wrappers/pkg/usr/lib/
install: invalid group `root'
make: *** [install-lib] Error 1

sulhan commented on 2011-09-30 17:26

Cannot update because ftp login failed.

log:

++++
==> Retrieving Sources...
-> Downloading tcp_wrappers_7.6.tar.gz...
--2011-10-01 00:21:46-- ftp://ftp.porcupine.org/pub/security/tcp_wrappers_7.6.tar.gz
=> `tcp_wrappers_7.6.tar.gz.part'
Resolving ftp.porcupine.org... 168.100.185.123
Connecting to ftp.porcupine.org|168.100.185.123|:21... connected.
Logging in as Mohgha ...
The server refuses login.
Retrying.

...

--2011-10-01 00:22:06-- ftp://ftp.porcupine.org/pub/security/tcp_wrappers_7.6.tar.gz
(try: 3) => `tcp_wrappers_7.6.tar.gz.part'
Connecting to ftp.porcupine.org|168.100.185.123|:21... connected.
Logging in as Mohgha ...
The server refuses login.
Giving up.
++++