Package Details: teamcity 10.0-1

Git Clone URL: https://aur.archlinux.org/teamcity.git (read-only)
Package Base: teamcity
Description: Continuous integration server from JetBrains
Upstream URL: http://www.jetbrains.com/teamcity/
Keywords: ci dev
Licenses: custom:JetBrains TeamCity
Submitter: None
Maintainer: Yegorius
Last Packager: Yegorius
Votes: 7
Popularity: 1.066505
First Submitted: 2012-07-23 17:48
Last Updated: 2016-08-07 11:53

Latest Comments

Yegorius commented on 2016-08-07 11:54

thank you @Mastacheata, I fixed this

Mastacheata commented on 2016-08-05 23:30

Hey there,
your post_upgrade function is empty, but bash doesn't allow empty functions. You can either leave it away or add a placeholder like : there (colon is short for true in bash).
The way it is now, you get syntax errors when running the install as an upgrade

Yegorius commented on 2016-08-01 12:52

Please test.

Yegorius commented on 2016-07-28 09:15

I will update the package soon.

Mastacheata commented on 2016-02-06 17:04

Hmmpf, just noticed that Teamcity will now use teamcity.pid by default for the "server". That needs to be adjusted in the teamcity-server.service file if you want to upgrade to one of the aforementioned newer versions. (Here: 9.1.6)

Mastacheata commented on 2016-02-05 21:22

9.1.4, 9.1.5 and 9.1.6 have been released in the meantime
No big changes, mostly bugfixes as far as I can tell, but still nice to stay up-to-date.

neio commented on 2015-11-09 11:40

there are no errors in log, server starts properly and all works fine, but killed by timeout by systemd. is this ok?
btw, `/opt/teamcity/bin/teamcity-server.sh start` starts teamcity and exit with 0 in 1-2 seconds, and all works ok

justin8 commented on 2015-10-29 20:07

Did you check the logs?

neio commented on 2015-10-29 09:22

can anyone help me?

teamcity-server.service - TeamCity server
Loaded: loaded (/etc/systemd/system/teamcity-server.service; disabled; vendor preset: disabled)
Active: failed (Result: timeout) since Thu 2015-10-29 12:17:44 MSK; 1min 47s ago
Process: 6930 ExecStart=/opt/teamcity/bin/teamcity-server.sh start (code=exited, status=0/SUCCESS)

vlad commented on 2015-07-09 21:27

Done, thanks.

Kendos_Kenlen commented on 2015-07-09 20:48

Hi,

Can you change JAVA_HOME=/usr/lib/jvm/default-java to JAVA_HOME=/usr/lib/jvm/default or JAVA_HOME=/usr/lib/jvm/default-runtime ? The first one doesn't exist in arch (at least with OpenJDK) so it's not possible to run teamcity with default configuration.

Nowaker commented on 2014-12-18 19:26

@starquake Because my non-conflicting oraclejdk* AUR packages way predate how Java is handled today. You can make the package align with today's Java toolkit.

starquake commented on 2014-12-17 21:54

I'm preparing to make a pull request for version 9.0.0 but why does it need a symlink to /usr/lib/jvm/default-java instead of using /usr/lib/jvm/default-runtime or /usr/lib/jvm/default?

Nowaker commented on 2014-10-07 12:38

Thanks for letting me know. I'm short on time recently - please submit a pull request. https://github.com/Nowaker/aur-packages

roblabla commented on 2014-10-07 12:12

Instead of packaging everything in the build() function, you might want to use the package() function, as PKGBUILDs without the package() function are going to be deprecated.

kraug commented on 2014-05-22 12:41

the sha256sum for the teamcity archive doesn't seem to match anymore

Nowaker commented on 2014-04-03 23:22

Upgraded to 8.1.

Nowaker commented on 2014-02-27 13:54

Thanks for marking out of date, I will bump the version at the weekend.

Nowaker commented on 2013-11-03 14:39

Upgraded to 8.0.4, changed deps to a headless Java. Thanks for flagging and suggesting.

Nowaker commented on 2013-10-06 13:47

Okay, will do. Thanks, justin8.

justin8 commented on 2013-10-06 12:51

When you update this package next time, please change the java-runtime requirement to java-runtime-headless.

Thanks

Nowaker commented on 2013-07-24 09:28

Thanks for flagging. I will update to 8.0 this weekend.

Anonymous comment on 2012-10-20 11:24

found a workaround, rc-scripts now start /bin/sh --login

Anonymous comment on 2012-10-20 10:13

bumped version to latest 7.1.1
unfortunately, rc-scripts do not work currently because of https://bugs.archlinux.org/task/31831
if anyone knows good workaround, please comment