Package Details: teamspeak3-kde-wrapper 0.2-1

Git Clone URL: https://aur.archlinux.org/teamspeak3-kde-wrapper.git (read-only, click to copy)
Package Base: teamspeak3-kde-wrapper
Description: Wrapper script that fixes the bug that URLs do not open on KDE
Upstream URL: None
Keywords: kde kts3wrap plasma teamspeak xdg-open
Licenses: GPL3
Provides: kts3wrap
Submitter: Scrumplex
Maintainer: jkhsjdhjs
Last Packager: jkhsjdhjs
Votes: 7
Popularity: 0.000015
First Submitted: 2018-08-23 11:54 (UTC)
Last Updated: 2022-06-21 15:25 (UTC)

Latest Comments

jkhsjdhjs commented on 2022-06-18 19:50 (UTC) (edited on 2022-06-21 15:26 (UTC) by jkhsjdhjs)

This script currently doesn't work because of this KDE bug: https://bugs.kde.org/show_bug.cgi?id=455515

As a workaround just launch kdeinit5 once after each boot.

EDIT: With the latest update the workaround isn't necessary anymore.

Scrumplex commented on 2021-05-30 19:40 (UTC)

I have stopped using KDE Plasma and switched to Sway full-time. I don't utilize the features of this package, which is why I will disown it.

The package will still work, and someone else might take the job of maintaining this one.

Makalevi commented on 2021-03-14 04:38 (UTC)

Scrumplex: Thank you for your help. My issues was resolved, it was xdg-utils not your package. While I had my browser set with KDE for some reason xdg-utils did not recognize it. I had to go to /usr/bin/xdg-open and edit the line : # if BROWSER variable is not set, check some well known browsers instead if [ x"$BROWSER" = x"" ]; then BROWSER=firefox if [ -n "$DISPLAY" ]; then

to my correct browser. Once again thank you for your help, and your handy package!

Scrumplex commented on 2021-03-13 23:27 (UTC)

Makalevi: Okay so the script is executing stuff. Is your browser set right in Plasma's settings?

What happens if you run xdg-open https://archlinux.org? If that does not work, then it has to do with your default apps configuration in Plasma

Makalevi commented on 2021-03-13 22:41 (UTC)

Scrumplex: Thank you in advance for your time and help. When I click a link while running in terminal I get no result and the output:

Running KTS3wrap... 0

42089

Scrumplex commented on 2021-03-13 22:32 (UTC)

Makalevi: I suggest that you run TeamSpeak in a terminal and look at the output.

The command of the wrapper is kts3wrap

Makalevi commented on 2021-03-13 22:02 (UTC)

Scrumplex: I am, Plasma 5.21.2.

Scrumplex commented on 2021-03-13 21:16 (UTC)

Makalevi. Hmm works for me though. Are you running KDE Plasma?

Makalevi commented on 2021-03-13 20:08 (UTC) (edited on 2021-03-13 20:15 (UTC) by Makalevi)

Scrumplex: Unfortunately this wrapper does not provide a fix for the KDE Link bug you describe in your post from 2017. I launch in the KDE Optimized option for TS3 (Version 3.5.6) and still no fix. Does it require addition configuration?

Scrumplex commented on 2021-03-13 19:56 (UTC)

Makalevi: This package is still relevant. Ignore my comment from 2019, as that was reverted shortly after, which still makes this package more or less mandatory

Makalevi commented on 2021-03-13 19:54 (UTC)

Now that this is out of date, is there any other known solution for this bug?

jkhsjdhjs commented on 2020-03-22 22:06 (UTC)

For me, this script is still necessary as of TeamSpeak 3.5.0. Opening links posted in a channel doesn't work without it.

Scrumplex commented on 2019-06-27 16:21 (UTC)

As of TeamSpeak 3.3.0 this wrapper is not useful anymore, as TS3 updated it's Qt dependencies to 5.12 LTS. This script may be needed in the future again. Therefore I will leave package up on the AUR.