Package Details: teamspeak3-wbundled 3.5.6-1

Git Clone URL: https://aur.archlinux.org/teamspeak3-wbundled.git (read-only, click to copy)
Package Base: teamspeak3-wbundled
Description: TeamSpeak is software for quality voice communication via the Internet
Upstream URL: http://www.teamspeak.com
Licenses: custom
Conflicts: teamspeak3
Provides: teamspeak3
Submitter: Thaodan
Maintainer: Thaodan
Last Packager: Thaodan
Votes: 3
Popularity: 0.002329
First Submitted: 2018-06-05 18:20
Last Updated: 2020-12-27 16:08

Pinned Comments

frebib commented on 2020-12-02 09:42

Seems like libc++ 11.0.0 breaks this package. I guess it's an upstream teamspeak problem. For now I'm holding back the libc++ upgrade until upstream fixes. You probably also want to unpin the 2 year old comment, it's not relevant any more

Latest Comments

1 2 Next › Last »

Thaodan commented on 2020-12-24 17:40

@frebib unpinned mine and pinned yours. Which libc++ version did you use before? Maybe the ABI changed but it seams we could workaround that.

frebib commented on 2020-12-02 09:42

Seems like libc++ 11.0.0 breaks this package. I guess it's an upstream teamspeak problem. For now I'm holding back the libc++ upgrade until upstream fixes. You probably also want to unpin the 2 year old comment, it's not relevant any more

frebib commented on 2020-10-14 15:49

Alternatively, the quazip package ships with this library, which if you replace the name in the patchelf line for this file, seems to work just fine

frebib@frebib-Cf ~> p -Ql | grep /usr/lib/libquazip1-qt5.so quazip /usr/lib/libquazip1-qt5.so

Edgemaster commented on 2020-10-14 15:18

The quazip dependency needs to be replaced by quazip-legacy

frebib commented on 2020-03-21 11:34

Updated for 3.5.0-1 https://github.com/frebib/teamspeak3-bin

Thaodan commented on 2019-01-06 18:00

Hey guy,

Sorry for not communicating my findings. I tested a week ago why it doesn't run anymore. Apperently Teamspeak is only compatibe with Qt < 5.11. NixOS had the same issue and installed Qt 5.9 along side. I tried if the issue is related to patchelf but its not.

So I think we have to wait unless someone found a fix for the ABI issue.

frebib commented on 2019-01-06 17:55

Unfortunately there's probably not a lot we can do if there is an ABI incompatibility except complain to 4players and hope they'll build an updated version with the newer dependencies. For now I've had to abandon this for the official package, which is a shame :(

Andr0med4 commented on 2019-01-06 13:17

Download link appears to be broken, package in [Community] switched to http://dl.4players.de/ts/releases/[...]

Furthermore, while installing this package works fine, it instantly crashes upon launch with error: teamspeak3: relocation error: teamspeak3: symbol calloc version Qt_5 not defined in file libQt5WebEngineCore.so.5 with link time reference

Couldn't find the reason for this link error. Might be in the upstream bundle?

Thaodan commented on 2018-11-25 20:03

Can you point those out? Execpt the updated description I see none. I never had issues with patchelf. Sadly there's no real tagged version lately. I don't really like to put symlinks of lib inside /usr/lib because these could conflict with other pkgs.

frebib commented on 2018-11-25 19:58

Amongst other stuff, yes. A couple builds actually broke with patchelf for me