Package Details: teamviewer 15.0.8397-1

Git Clone URL: https://aur.archlinux.org/teamviewer.git (read-only, click to copy)
Package Base: teamviewer
Description: All-In-One Software for Remote Support and Online Meetings
Upstream URL: http://www.teamviewer.com
Licenses: custom
Conflicts: teamviewer-beta
Provides: teamviewer
Submitter: Hilinus
Maintainer: swiftgeek (nickoe, astronautlevel)
Last Packager: swiftgeek
Votes: 1340
Popularity: 7.10
First Submitted: 2010-04-15 10:29
Last Updated: 2019-11-23 15:16

Pinned Comments

swiftgeek commented on 2018-10-26 07:34

Go to teamviewer-beta for beta/preview releases

(unless teamviewer messes it up again like with 12->13, where 12 was abandoned)

seenxu commented on 2018-04-05 08:27

https://aur.archlinux.org/packages/teamviewer12/

seenxu commented on 2018-04-05 07:26

https://community.teamviewer.com/t5/Linux/uninstalled-tar-package-running-without-display-manager/m-p/32597/highlight/true#M2034

WARNING!

teamviewer 13 requires a desktop environment or login with lightdm etc, with startx it won't work, the staff of teamviewer confirmed, startx feature won't come in this year, it seems reverting back to teamviewer 12 is the only option for startx folks.

mikes commented on 2010-09-13 03:35

This package, since the last change is the only package i am unable to upgrade via yaourt. I also tried to build the package with makepkg but it seems that the new warning causes a problem and it stops. Although i have multilib repo enabled it keeps warning me to add it in /etc/pacman.conf. Anyone else having the same problem?

Hilinus commented on 2010-09-11 08:03

Added annoying reminder to make users add the [multilib] repo before installing on x86_64.

coolpyrofreak commented on 2010-09-10 20:11

@irpye: You need to enable the multilib repository in pacman.conf. Most of the lib32 and bin32 packages are now in that repo.

irpye commented on 2010-09-10 20:10

I tried to update teamviewer from AUR. I am on x86_64.
I have this message :
Erreur: 'lib32-alsa-lib': impossible de trouver ou de lire le paquet
(error : 'lib32-alsa-lib': impossible to find or read the package)
lib32-alsa-lib is listed in the dependancies, but i can not find it in AUR
What should i do ? Thanks.

Anonymous comment on 2010-09-10 03:44

Installing lib32-libxtst solved problems in Arch amd64 :D

Bevan commented on 2010-09-07 21:34

lib32-libxtst is included in official multilib repository. See: http://www.archlinux.org/news/508/

petRUShka commented on 2010-09-07 19:23

I can't find lib32-libxtst in AUR:
"error: 'lib32-libxtst': could not find or read package"

And so I can't build teamviewer.

If I try to use previous version of PKGBUILD, I get an error with tvwine.dll.so...


Bevan commented on 2010-09-07 14:39

Works for me now! :-)
The only package that I didn't have installed before is lib32-libxtst.
@MASSER: Can you confirm that installing lib32-libxtst solves the problem?

Hilinus commented on 2010-09-07 14:06

Updated dependencies to include additional 32bit X libs. Let me know if it doesn't work.

Hilinus commented on 2010-09-07 11:34

http://www.teamviewer.com/download/teamviewer_linux.tar.gz

Try this package. Untar in home and run teamviewer.