Package Details: teamviewer12 12.0.90041-1

Git Clone URL: https://aur.archlinux.org/teamviewer12.git (read-only)
Package Base: teamviewer12
Description: All-In-One Software for Remote Support and Online Meetings
Upstream URL: http://www.teamviewer.com
Licenses: custom
Conflicts: teamviewer, teamviewer-beta
Provides: teamviewer
Submitter: seenxu
Maintainer: severach
Last Packager: seenxu
Votes: 19
Popularity: 0.014363
First Submitted: 2018-04-05 08:26
Last Updated: 2018-04-06 08:11

Latest Comments

1 2 Next › Last »

Atilir commented on 2019-07-24 14:27

Hi, I've worked on it and I finally get it working :

I used the newer version of freetype2 and it is working just fine (it's a little slow on startup)

I also used the last version available 12.0.137452

You can update the package if you want (I can provide you my PKGBUILD)

Atilir commented on 2019-07-24 07:50

Thanks for your reply,

but I think that the teamviewer9 with the pkgver changed to 12.0.85001 is broken.

severach commented on 2019-07-23 19:15

Get my teamviewer9 and change the PKGVER to the included 12. Teamviewer 12 and below run under Wine, have a lot of hard to get dependencies, and don't work well. Linux native >=13 work much better.

Atilir commented on 2019-07-23 15:10

Hi,

I'm new to Arch and I am curently running it on a virtual machine before fully migrate to it but this really bothered me...

This is the only thing that stop me right now to switch to Arch after many years of Ubuntu

I work in a small a company and we curently have a licence for 3 technicians but on teamviewer 12 and it's not compatible with an upgrade to version 14.

Do you have any workarounds for installing teamviewer 12 on Arch ?

seenxu commented on 2019-05-09 08:18

According to the teamviewer community announcement[1], free user has only 5 minutes of connection time for older version, I disowned the package, and dropped further maintenance.

[1] https://community.teamviewer.com/t5/Announcements/Updating-to-the-latest-and-greatest-version-of-TeamViewer/td-p/49692

esuhl commented on 2019-05-08 21:39

Installation of teamviewer12 12.0.90041-1 fails as the lib32-freetype2-2.8-2-x86_64.pkg.tar.xz dependency file is not available:

curl: (22) The requested URL returned error: 404 ==> ERROR: Failure while downloading https://archive.archlinux.org/packages/l/lib32-freetype2/lib32-freetype2-2.8-2-x86_64.pkg.tar.xz Aborting... Error downloading sources: teamviewer12

seenxu commented on 2018-10-20 13:57

@andreas_baumann use systemctl start teamviewerd, then teamviewer

andreas_baumann commented on 2018-10-20 08:11

teamviewer --daemon

says

unknown option ''

/opt/teamviewer/tv_bin/script/tvw_exec: line 40: 10951 Aborted (core dumped) "$TV_BIN_DIR/teamviewerd" -n -f

Starting the GUI with the wrapper gives an error

I was able to use it with:

(as root) /opt/teamviewer/tv_bin/teamviewerd then teamviewer

seenxu commented on 2018-04-13 08:49

@StefanT

I don't use any desktop environment and no expert about .desktop file, use Thunar browse to /usr/share/applications/, Teamviewer desktop file did associate with correct Teamviewer Icon, if I start teamviewer12 per /usr/share/applications/com.teamviewer.TeamViewer.desktop, then inspect its window per xprop, I saw WM_CLASS(STRING) = "TeamViewer", "TeamViewer" there.

StefanT commented on 2018-04-13 08:22

Would it be possible to add StartupWMClass=TeamViewer to the .desktop entry?

As it is now Gnome does not recognize the application and uses a generic icon for it.