Package Details: tectonic 0.1.10-1

Git Clone URL: https://aur.archlinux.org/tectonic.git (read-only)
Package Base: tectonic
Description: Modernized, complete, self-contained TeX/LaTeX engine, powered by XeTeX and TeXLive
Upstream URL: https://tectonic-typesetting.github.io/
Keywords: latex tex typesetting
Licenses: MIT
Submitter: jtojnar
Maintainer: tectonic-deploy (polyzen)
Last Packager: tectonic-deploy
Votes: 4
Popularity: 0.862853
First Submitted: 2017-05-30 18:36
Last Updated: 2018-09-30 21:13

Latest Comments

tfl5034 commented on 2018-08-22 01:06

I don't know what the correct solution to this is, but I problems running tectonic because my system was missing libicuuc.so.61. This was because the icu library on Arch is on version 62 so I had to install icu61 from the AUR here: https://aur.archlinux.org/packages/icu61/

I guess either this should be added as a dependency or perhaps the package could be updated to use icu 62.

jtojnar commented on 2017-12-09 15:52

The new version is actually supposed to be deployed automatically on release, see https://github.com/tectonic-typesetting/tectonic/issues/54

Only nobody updated https://github.com/tectonic-typesetting/tectonic/blob/master/dist/arch/PKGBUILD so nothing happened.

beardhatcode commented on 2017-11-10 14:20

there is a newer version on GitHub (https://github.com/tectonic-typesetting/tectonic/releases/tag/v0.1.6)

Changing the pkgver to 0.1.6 and setting 5c201c979069dfb780040b42d8c516847668bd6d429eabb20f5fb15a3873832c as checksum gives the last version

jtojnar commented on 2017-06-01 01:14

@alexanderbauer you are right, I was not too careful when filling my template. Fixed.

alexanderbauer commented on 2017-05-31 23:11

I believe the license is incorrectly listed. The repository contains the MIT license, but the package claims it is GPL.

https://github.com/tectonic-typesetting/tectonic/blob/master/LICENSE

jtojnar commented on 2017-05-31 14:08

@rich_o Oops, fixed. Thanks for letting me know.

rich_o commented on 2017-05-31 07:28

The description does not match the package.