Package Details: termbox-git r230.707f62e-1

Git Clone URL: https://aur.archlinux.org/termbox-git.git (read-only)
Package Base: termbox-git
Description: termbox library (ncurses alternative)
Upstream URL: http://code.google.com/p/termbox/
Licenses: custom
Conflicts: termbox
Provides: termbox
Submitter: None
Maintainer: mlq
Last Packager: mlq
Votes: 3
Popularity: 0.000004
First Submitted: 2010-02-19 13:10
Last Updated: 2016-06-01 06:11

Dependencies (2)

Required by (0)

Sources (1)

Latest Comments

gciruelos commented on 2016-06-01 01:02

+1 to linkmauve and grandchild.

linkmauve commented on 2016-05-22 18:36

Please add conflicts and provides for termbox, so programs depending on it can just use 'termbox' in their depends.

grandchild commented on 2016-03-02 14:51

Please fix the pkgver(), as requested several times. There are suggestions in the comments as well as on https://wiki.archlinux.org/index.php/VCS_package_guidelines#The_pkgver.28.29_function
Thanks! :)

demizer commented on 2015-07-11 23:31

The PKGBUILD is missing "python" in makedepends. This package does not build in a clean chroot environment.

Anonymous comment on 2015-05-24 10:53

fixed pkgbuild w/o waf dependency: https://gist.githubusercontent.com/MehLON/e4d5fd6ce3383ebfa36f/raw/PKGBUILD

Anonymous comment on 2015-05-24 10:53

fixed pkgbuild: https://gist.githubusercontent.com/MehLON/e4d5fd6ce3383ebfa36f/raw/PKGBUILD

stevenhoneyman commented on 2014-08-08 19:44

oops forgot 1 more: please add "staticlibs" option - as this library is popular as a lightweight alternative for ncurses, people might/will want to link statically against it for small/embedded systems

stevenhoneyman commented on 2014-08-08 19:42

waf shouldn't be a dependency -- it's already included in the git repo (you run ./waf ___ in your pkgbuild)

the main issue is the pkgver() function is broken, and always thinks there is an update

tim.cooper commented on 2014-03-20 14:23

Whenever I go to do an update with yaourt, it thinks that termbox-git needs to be updated, even when it does not. I believe this is do to the current `pkgver` function not using a comparable value. The following function should work well when trying to do a system update:

pkgver() {
cd $_gitname
echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
}

tim.cooper commented on 2013-12-15 00:40

Could you set the pkgver in the PKGBUILD to 0.0.0? My AUR helper keeps wanting to update the package, even though nothing has changed.

iv597 commented on 2013-01-27 04:48

Updated PKGBUILD available at http://sprunge.us/EGaH
If mlq doesn't want to maintain this any longer, I gladly would. I've taken a bit of a liking to this library so far :P

WFCody commented on 2012-06-13 11:35

packaging fails at "install -D"

Either add a full path, like $srcdir/termbox-build/src/libtermbox.a, or do a

"cd src" before the "install" commands...