Package Details: terminal-parrot 1.1.1-2

Git Clone URL: https://aur.archlinux.org/terminal-parrot.git (read-only, click to copy)
Package Base: terminal-parrot
Description: Party parrot (http://cultofthepartyparrot.com) for your terminal
Upstream URL: https://github.com/jmhobbs/terminal-parrot
Keywords: parrot
Licenses: MIT
Conflicts: terminal-parrot-git
Submitter: Horgix
Maintainer: kleintux (Horgix)
Last Packager: kleintux
Votes: 3
Popularity: 0.000347
First Submitted: 2016-09-12 23:26 (UTC)
Last Updated: 2022-05-26 18:10 (UTC)

Dependencies (1)

Required by (0)

Sources (1)

Latest Comments

kleintux commented on 2022-05-26 18:10 (UTC)

@butla thx for mentioning the problem. Fixed the problem with the new module routine.

butla commented on 2022-05-26 17:55 (UTC)

This doesn't build anymore. Here's the error:

/home/butla/.cache/yay/terminal-parrot/src
go: go.mod file not found in current directory or any parent directory.
        'go get' is no longer supported outside a module.
        To build and install a command, use 'go install' with a version,
        like 'go install example.com/cmd@latest'
        For more information, see https://golang.org/doc/go-get-install-deprecation
        or run 'go help get' or 'go help install'.

So I tried changing the PKGBUILD

go get github.com/nsf/termbox-go

to

go install github.com/nsf/termbox-go@latest

which leads me to getting this error:

package github.com/nsf/termbox-go is not a main package

and I don't know what to do with that. Sorry, not a Golang person.