Package Details: textlint 11.7.6-1

Git Clone URL: https://aur.archlinux.org/textlint.git (read-only, click to copy)
Package Base: textlint
Description: The pluggable natural language linter for text and markdown.
Upstream URL: https://github.com/textlint/textlint/
Keywords: textlint
Licenses: MIT
Submitter: nemaniarjun
Maintainer: pychuang
Last Packager: pychuang
Votes: 1
Popularity: 0.000809
First Submitted: 2018-07-09 04:50
Last Updated: 2020-09-20 09:40

Latest Comments

pychuang commented on 2020-09-20 09:48

I just adpoted this package and bumped the version to 11.7.6. Now it installs the package through a local tarball using source. I'm not familiar with nodejs and npm stuff, though. Let me know if something's not right. It'll be easier to discuss issue on GitHub: https://github.com/piyueh/pkgbuilds

This package needs plugins. I'm trying to adopt the plugins. But the original maintainer has to relinquish the maintainership.

dreieck commented on 2020-03-15 17:34

Fails to download for me since npm's builtin downloader is used which is too restrictive for slow internet connections:

npm ERR! Response timeout while trying to fetch https://registry.npmjs.org/@types%2fbluebird (over 30000ms)

→ please use "proper" system-provided download methods via the source-array.

dreieck commented on 2020-03-15 17:33

This package's PKGBUILD does download stuff in package().

Please avoid that!

build(), check() and package() must not assume internet connection.

Please use the sources array.

If not possible, as an exception, use the prepare()-functiont.

Everything else is not acceptable.

Advantage of the source-array over prepare():
Enabling the user to specify the way things should be downloaded (e.g. in makepkg.conf), so users can cater for 'special' setups like special proxies, unreliable internet connections, etc.

Please also check your other packages for this problem.

Thanks for the package! (-:!