Package Details: thunar-extended 1.6.10-5

Git Clone URL: https://aur.archlinux.org/thunar-extended.git (read-only)
Package Base: thunar-extended
Description: Thunar with split view, cursor audio preview and extra options for trash, desktop files and user actions
Upstream URL: http://thunar.xfce.org
Licenses: GPL2, LGPL2.1
Groups: xfce4
Conflicts: thunar
Provides: thunar=1.6.10
Replaces: thunar
Submitter: ConnorBehan
Maintainer: ConnorBehan
Last Packager: ConnorBehan
Votes: 66
Popularity: 2.331628
First Submitted: 2010-09-01 01:22
Last Updated: 2016-12-05 09:37

Dependencies (22)

Required by (22)

Sources (6)

Latest Comments

Speranskiy commented on 2016-12-07 20:10

To prevent crashing patches from here https://bbs.archlinux.org/viewtopic.php?id=203663&p=2 (post #48) must be applied. Maybe an appropriate patch is located here https://bugzilla.xfce.org/show_bug.cgi?id=12264 but I haven't checked it.

Speranskiy commented on 2016-12-07 10:47

It crashes on moving files in the split view.

uwe commented on 2016-09-18 21:13

No, defaults.list does not change

ConnorBehan commented on 2016-09-17 21:44

What is in ~/.local/share/applications? Does defaults.list at least change when you click "Open with"?

uwe commented on 2016-09-17 21:06

same here, "open with" never worked for me with thunar extended :-(

mareex commented on 2016-09-09 19:15

Has anyone else the problem opening files with different applications in thunar? For example when i right click on an image file and select "open with -> Gimp" Gimp is not starting.
Besides that the entries in "send to" do not work.

Stock thunar works as expected.

Brottweiler commented on 2016-06-11 22:59

I got this package to replace thunar, but I don't really get it... It seems like after installing this package, nothing in thunar is different?

I can't find anything about split view, it crashed when I renamed a file, which it has a patch fix for... Any ideas?

Edit: Actually, pressing F3 I get split pane view, but the crash still happens as I explained above.

cassava commented on 2016-04-23 11:09

Wow. Thanks a lot ConnorBehan and janis.mezitis, this bug has been plaguing me for quite a while!

mmd commented on 2016-04-16 19:49

I created another patched thunar package if anyone is interested: thunar-split. It includes only the split pane patch (I don't use the other ones), as well as all upstream bug fixes made since the stable release (like the one mentioned below). Feedback welcome.

janis.mezitis commented on 2016-04-01 16:42

Could You add following patch to package:
http://git.xfce.org/xfce/thunar/commit/?id=029012f4c39d9d3d9ae617491a69f76f54a4192f

Thanks

uwe commented on 2015-05-11 22:01

if I delete "--enable-gtk-doc" thunar-extended 1.6.8-1 does build

uwe commented on 2015-05-11 21:53

before:
build() {
cd "$srcdir/Thunar-$pkgver"

./configure \



after:
build() {
cd "$srcdir/Thunar-$pkgver"
mkdir m4
sed -i -e 's/Thunar_CFLAGS/thunar_CFLAGS/' -e 's/Thunar_LDADD/thunar_LDADD/' thunar/Makefile.am
xdt-autogen
./configure \


result:
build process is fine, does not break

ConnorBehan commented on 2015-05-11 15:59

The answer my have to do with rerunning autotools in this PKGBUILD. If you add the xdt-autogen line before configuring thunar-split-view, does that build then break too?

uwe commented on 2015-05-11 08:09

I can build this without errors:

thunar-split-view 1.6.8-1

https://aur.archlinux.org/packages.php?ID=174520

ConnorBehan commented on 2015-05-10 20:53

Those are the same "build" errors as Drew. Do they happen when you build the regular thunar package from abs?

uwe commented on 2015-05-10 20:48

getting build errors:

../thunarx-docs.sgml:453: parser error : Failure to process entity ThunarxPropertyPage
&ThunarxPropertyPage;
^
../thunarx-docs.sgml:453: parser error : Entity 'ThunarxPropertyPage' not defined
&ThunarxPropertyPage;
^
unable to parse ../thunarx-docs.sgml

os7een commented on 2015-05-09 20:31

Hi guys,
I have modified the patches for the split-view-mode to work with the 1.6.8 version of Thunar.

You can find them here, thunar-standard-view.patch[0], thunar-window.patch[1].
Best regards.

[0] https://bitbucket.org/snippets/mijomedvedec/k677/untitled-snippet
[1] https://bitbucket.org/snippets/mijomedvedec/76qk/untitled-snippet

os7een commented on 2015-05-09 20:30

Hi guys,
I have modified the patches for the split-view-mode to work with the 1.6.8 version of Thunar.

You can find them here, thunar-standard-view.patch[0], thunar-window[1].
Best regards.

[0] https://bitbucket.org/snippets/mijomedvedec/k677/untitled-snippet
[1] https://bitbucket.org/snippets/mijomedvedec/76qk/untitled-snippet

os7een commented on 2015-05-09 20:29

Hi guys,

I have modified the patches for the split-view-mode to work with the 1.6.8 version of Thunar.

You can find them here, thunar-standard-view.patch[0], thunar-window[1].
Best regards.

[0] https://bitbucket.org/snippets/mijomedvedec/k677/untitled-snippet
[1] https://bitbucket.org/snippets/mijomedvedec/76qk/untitled-snippet

ConnorBehan commented on 2015-05-08 07:08

Change versions of xfce4-dev-tools, gtk-doc, gnome-doc-utils, yelp, redland, rasqal, rarian? I hate doc generation issues. The actual executable has been built so in the worst case scenario, you should be able to fish that out manually.

Drew commented on 2015-05-08 07:00

I keep getting build errors. Not sure how to approach this. http://pastebin.com/uWAQBTFZ

zegoti commented on 2015-04-24 01:18

Here is the Split-view patch to suit with Thunar 1.6.7 https://gist.github.com/anonymous/959cd4a1367680b4c6a5

zegoti commented on 2015-04-01 14:17

it would be great if custom action work across split view

Kilzool commented on 2015-03-29 16:03

Has the patch been applied to this version, to fix this:

https://bbs.archlinux.org/viewtopic.php?id=194955

zegoti commented on 2015-03-27 16:58

No, I have not tried removing. And since I did not apply this patch, I do not have the error "glib-critical"

Edit: Thanks, it works if I delete ~/.config/Thunar/uca.xml

zegoti commented on 2015-03-27 15:58

No, I have not tried removing. And since I did not apply this patch, I do not have the error "glib-critical"

Edit: trying..

zegoti commented on 2015-03-27 15:52

No, I have not tried removing. And since I did not apply this patch, I do not have the error "glib-critical"

ConnorBehan commented on 2015-03-26 22:43

Does it work if you delete your custom actions and make them again? The point is that it adds two new settings to make your actions more selective so the XML file storing them needs to be different.

zegoti commented on 2015-03-26 13:04

Hi, Xfce 4.12 here
getting glib-critical after thunar -q && thunar
GLib-CRITICAL **: g_strtod: assertion 'nptr != NULL' failed
And I see no obvious change, nor even the dual panel

Edit: I found the split view with F3
Edit: uca_num_files.patch broke the right-click custom action menu.

zegoti commented on 2015-03-25 09:59

Hi, Xfce 4.12 here
getting glib-critical after thunar -q && thunar
GLib-CRITICAL **: g_strtod: assertion 'nptr != NULL' failed

And I see no obvious change, nor even the dual panel

Edit: I found the split view with F3

zegoti commented on 2015-03-25 09:10

Hi, Xfce 4.12 here
getting glib-critical after thunar -q && thunar
GLib-CRITICAL **: g_strtod: assertion 'nptr != NULL' failed

And I see no obvious change, nor even the dual panel

McLenin commented on 2015-03-12 07:38

It only crashed becouse it was built against an older version of libxfce4util. Rebuilding/updating to a new version fixed it

ConnorBehan commented on 2015-03-10 19:48

Split view implemented. I'm not sure why it would be crashing for you. Any chance you can get debugging output the next time it does that?

McLenin commented on 2015-03-09 12:28

If you updated to the new XFCE and Thunar does not start any more (missing libxfce4util.so.6 library), recompile this package and reinstall it again. It should work after that, still this package should be updated ASAP.

swanson commented on 2014-12-30 09:16

Got it to work on Ubuntu too! Thanks!

Shadow_Reaper commented on 2014-11-17 02:58

Hi, I think that you should integrate in this package the split-view like Nautilus used to have. Tha's something that Thunar needs and it would be good to have it on this package. Also you should improve overall stability. I remeber that when I had this installed, if I opened Thunar as root, after a while it would crash with no error messages or anything. it just disappeared. That's the reason I removed it. Fix that and add the split-view and I'll install again.

Thanks in advance

http://www.webupd8.org/2014/11/split-view-patch-available-for-thunar.html
https://bugzilla.xfce.org/show_bug.cgi?id=10232

I-sty commented on 2014-06-10 06:27

For mp3 and wav files I have no error message, but for ogg file I get this text: Message: don't know how to handle application/ogg

ConnorBehan commented on 2014-06-10 06:02

Interesting. I'm seeing it work for flac but not mp3. I don't have any standalone gstreamer frontends installed right now, but I'll test them out to see if there's a way out of "Message: don't know how to handle audio/mpeg".

I-sty commented on 2014-06-10 05:37

I have these gstream packages installed:

extra/gstreamer 1.2.4-1
extra/gstreamer0.10 0.10.36-4
extra/gstreamer0.10-base 0.10.36-3
extra/gstreamer0.10-good 0.10.31-6
extra/gstreamer0.10-ugly 0.10.19-11
extra/gstreamer0.10-ugly-plugins 0.10.19-11 (gstreamer0.10-plugins)

I point the mouse over a mp3 file, I wait ~10seconds but I don't hear the sound.

ConnorBehan commented on 2014-06-09 23:10

If you have the appropriate gstreamer0.10 plugins installed, it should just work. Point the mouse over an audio file and let it be still for a second.

I-sty commented on 2014-06-09 13:20

Hi,
How can I set the audio-preview part?
Is neccessary to set a media-player in the mime editor?

swanson commented on 2014-05-07 18:44

You might want to add perl-uri as a dependency. "send-to-mail-recipient" doesn't wok without it.

ConnorBehan commented on 2014-03-27 21:31

I'm not sure what would make this more likely to freeze. Can you try applying the patches separately so we know which one is the problem?

Shadow_Reaper commented on 2014-03-27 20:56

Hello, I want to report an issue that doesn't allow me to keep using thunar-extended instead of stock Thunar. The problem is this: thunar-extended works just fine except when I open it as root. When I open it as root everything seems to be working fine until it freezes and I have to kill Thunar. I can't use thunar-extended if it freezes when using it as root. I open it as root with "gksudo thunar".

I hope you can fix this soon so I can use it once again.

swanson commented on 2013-06-15 09:39

Just made a reinstall on a fresh arch install and audio preview stopped working. I've installed several gstreamer packages and I have several libs concerning mp3 installed too. I get the note cursor when hovering over audio files but no sound. I have all the deps in the PKGBUILD installed but some audio library/app must be missing. Which? Video thumbs does work after some gstreamer libs got installed.

Anonymous comment on 2013-05-14 20:52

I've got no time right now to learn how patches work at the PKGBUILD. I've just had to change a line at `configure.ac` where the error was (Indeed only one letter and it's ready to go).

I've got it fixed hosted on my dropbox waiting for the proper way of doing this. Meanwhile you can use this PKGBUILD at your own risk

http://pastebin.com/sYyw3wcE

bkuri commented on 2013-01-09 15:18

@Noctivivans: That fixed it. Thanks!

Noctivivans commented on 2013-01-08 23:32

@bkuri: (temporary solution) you can downgrade automake to 1.12.6 - on this version thunar-extended compiles fine.

bkuri commented on 2013-01-08 02:43

I'm getting the following error when attempting to upgrade:

configure.ac:57: error: 'AM_CONFIG_HEADER': this macro is obsolete. You should use the 'AC_CONFIG_HEADERS' macro instead.

gilmoreja commented on 2012-12-29 02:51

Issue reported in previous comment below was fixed with thunar-extended 1.6.2-1, please disregard.

gilmoreja commented on 2012-12-12 17:26

The icons shown for drives and network locations no longer work after updating. Here's an example of what I mean:

http://i.imgur.com/fasoF.png

I've tried reinstalling icon themes, rebuilding icon caches, and I'm stumped.

swanson commented on 2012-12-11 17:31

Do you guys have video thumbnails? It used to work until this upgrade. Reinstalled Tumbler but no luck. Starting thunar from terminal gives no clues either.

swanson commented on 2012-12-11 14:32

If you don't use xfce or xfce4-panel you can take xfce4-panel away from the makedepends and add "--disable-tpa-plugin" to the build options. Seems to work OK, audio preview and all.

capoeira commented on 2012-12-10 11:25

thanks, it worked afterwards. don't know why it didn't at first.

ConnorBehan commented on 2012-12-07 21:43

Once the cursor changes, have you tried holding it still over the file for a few seconds? And do old version of this package work? I can send them to you if needed.

capoeira commented on 2012-12-07 12:15

doesn't work for me here.
The curser changes to a note. but no sound

swanson commented on 2012-11-16 04:14

Ok, I see. Sorry for my impatience but I'm a Thunar addict since many years and this extended version is really nice! Thanks for the good work!

PS works nicely with exo-devel!

swanson commented on 2012-11-16 04:03

Ok, I see. Sorry for my impatience but I'm a Thunar addict since many years and this extended version is really nice! Thanks for the good work!

ConnorBehan commented on 2012-11-15 21:20

The official packages for thunar and exo are marked out of date so I can only assume that exo 0.9 is coming soon. I could make this depend on exo-devel if it stays marked for a long time though.

How does this install xfce4-panel and garcon? It installs a panel plugin which will work in case you have xfce.

swanson commented on 2012-11-15 16:25

Doesn't build here because it needs exo 0.9.0. And why does it install xfce4-panel and garcon? I don't use xfce.

swanson commented on 2012-11-15 16:20

Doesn't build here because it needs exo 0.9.0. And why does it install xfce4-panel and garcon? I don't use xfce.

ConnorBehan commented on 2012-08-26 05:07

It's in base-devel...

zootboy commented on 2012-08-26 02:06

It seems that libtool is a dependency that isn't included in the PKGFILE. Maybe it should be added?

ConnorBehan commented on 2012-04-25 19:40

They have been reported. Show all comments to see my three bugzilla links near the bottom.

killermoehre commented on 2012-04-25 12:46

Why are this patches not reported upstream? Existing code is always welcome.

swanson commented on 2012-04-11 06:15

Works great! Even better after unchecking that "only lie about names of desktop files on the Desktop" in the settings. I went for a long time without names for trash, network and filesystem in the left pane.

Anonymous comment on 2011-09-26 22:33

works likes a charm.. musta been some of my permissions.

ConnorBehan commented on 2011-09-05 16:26

Yeah well try using makepkg directly or try using sudo or changing the permissions of some yaourt things, etc...

Anonymous comment on 2011-09-05 05:52

i use yaourt for all my installs and upgrades

ConnorBehan commented on 2011-09-04 00:04

Does that happen with or without yaourt?

Anonymous comment on 2011-09-03 23:05

Encountered installation errors:

Running /tmp/yaourt-tmp-xaer0/aur-thunar-extended/src/Thunar-1.3.0/configure --enable-maintainer-mode ...
/usr/bin/xdt-autogen: line 653: ./configure: Permission denied
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build thunar-extended.

kellerman commented on 2011-08-28 19:54

Seems that this fixed both issues! Thanks! I have no more segfaults, network:// works, detailed listing works, audio previews too... so far no issues.

ConnorBehan commented on 2011-08-28 18:23

In that case try version -6 which fixes the bug with detailed lists. I also added some safeguards that might help with network:// too, who knows.

kellerman commented on 2011-08-28 12:41

Whoah, there is a segfault when trying to view any folder as a detailed list. Crashes the same way, when mouse cursor is moved onto file list. Compact view and icon view works fine. This happened using http://pastebin.com/gkr6fsHu instead of original preview.patch . Don't know if this happens with the original patch (which crashed with network:// ), but again with no preiview.patch at all I can overview files also as a detailed list.

kellerman commented on 2011-08-28 12:34

Whoah, there is a segfault when trying to view any folder as a detailed list. Crashes the same way, when mouse cursor is moved onto file list. Compact view and icon view works fine.

kellerman commented on 2011-08-27 21:21

No crashes with your patch and the previews does not work. Anything else seems to work.

ConnorBehan commented on 2011-08-27 15:31

Does this preview.patch make it crash? http://pastebin.com/gkr6fsHu Note that previews will not work with this... it is just to help diagnose the problem.

kellerman commented on 2011-08-27 13:50

Opening network location manually still works, for example, smb://myhostnamehere/mysharehere/... . I checked that audio previews do work under network locations.

kellerman commented on 2011-08-27 13:46

I just tried it with all 3 patches and it still crashes, but now I can move my cursor on the file list, I can even do right click. The problem still occurs when I point directly to an icon - any icon in network tab.

kellerman commented on 2011-08-27 13:46

I just tried it with all 3 patches and it still crashes, but now I can move my cursor on the file list, I can even do right click. The problem still occurs when I point directly to an icon.

kellerman commented on 2011-08-27 13:43

I just tried it with all 3 patches and it still crashes!

ConnorBehan commented on 2011-08-27 04:46

Thanks for doing that. Parts of preview.patch were assuming local files so I changed it. This might take a few tries to get right but see if -5 helps.

kellerman commented on 2011-08-26 14:11

Your package is 100% fine without any patch installed and is fine with both 2 patches used except preview patch. As soon as I run it with preview.patch - it crashes the same way before, I think it happens only when the path==network:// and it might try to "play" the share. What is used to preview audio files?
So the problem for me is in preview.patch and crashes with segfault.
Till now working good without preview.patch

kellerman commented on 2011-08-26 14:01

Well I'll try installing it without all those patches and see what happens then. Maybe it tries to make audio previews for samba shares? :D Who knows...
Installing thunar-devel also was pain in the ass, all *-devel dependencies were horrible. Now I even cant install xfburn, because it doesnt like exo-devel and a bunch of other *-devel deps (-Sdd didn't work when installing everything manually). Thunar itself works (except it has unremovable background setting plugin which doesnt work for me in openbox, because I use pcmanfm --desktop to set background images).
When I'll have more free time, I might take a deeper look on which patch doesnt work. :)
Yes, and thunar-extended ir newer than thunar-devel for sure.

kellerman commented on 2011-08-26 13:42

Well I'll try installing it without all those patches and see what happens then. Maybe it tries to make audio previews for samba shares? :D Who knows...
Installing thunar-devel also was pain in the ass, all *-devel dependencies were horrible. Now I even cant install xfburn, because it doesnt like exo-devel and a bunch of other *-devel deps (-Sdd didn't work when installing everything manually). Thunar itself works (except it has unremovable background setting plugin which doesnt work for me in openbox, because I use pcmanfm --desktop to set background images).
When I'll have more free time, I might take a deeper look on which patch doesnt work. :)
Yes, and thunar-extended ir newer than thunar-devel for sure.

ConnorBehan commented on 2011-08-24 02:12

Yes, put provides=('thunar=1.3.0') in the thunar-devel PKGBUILD. Back to thunar-extended... is it possible that you can verify which patch causes the problem? That is, compile once with more_options only, compile once with preview only and compile once with uca_num_files only? I know it's a pain in the ass but it can probably help.

kellerman commented on 2011-08-23 13:02

The vanilla build works without any problems. Only now pacman shows missing deps for thunar-archive-plugin, dropbox plugin, media-tags-plugin, xfce4-notifyd and xfce4-appfinder (I see the conflicts). The apps still work, all of them. Any way to fix that missing dependencies errors?

ConnorBehan commented on 2011-08-23 02:21

I find it very strange that the segfault would come from preview.patch or uca_num_files.patch. The easiest way to try the "vanilla build" would be to compile "thunar-devel" from the AUR.

kellerman commented on 2011-08-22 21:21

And I haven't tried that vanilla build. Where can I get it?

kellerman commented on 2011-08-22 21:20

Both when that option is checked or unchecked the segfault happens, I tried it many ways with this build - still same segmentation fault.
Tried building without more_options.patch - the text besides icons is fine, but still got the segfault.

ConnorBehan commented on 2011-08-22 03:18

So the segfault happens regardless of whether you uncheck the "trash" and "desktop" options? What if you rebuild so that you don't even apply the more_options.patch? One other question: have you tried a vanilla build of thunar-1.3.0 since the official repos are still 1.2.2? Sorry I haven't done this troubleshooting myself, but I don't have a samba network to test.

kellerman commented on 2011-08-21 19:56

Oh, there are lots of these appear in terminal:
GLib-CRITICAL **: g_error_free: assertion `error != NULL' failed
But they appear as soon as launch thunar and it doesnt make it crash instantly. Every other things seem to work just fine! And as a temporary solution I can use pcmanfm for browsing samba shares.

kellerman commented on 2011-08-21 19:49

Well when unchecking that "only lie about names of desktop files on the Desktop" - Trash, Root FS and Network in Places bar shows up correctly. Thanks for hint!
When opening Network, there's still crash, terminal throws out only Segmentation fault.
It's like:
1. I click Network in Places sidebar.
2. My cursor is still on Places.
3. I simply move it to the right (where all the icons appear) and there's crash.

P.S. When opening a Network location by manually entering the path, it works without a crash as soon it's into a directory (not showing network:///).

ConnorBehan commented on 2011-08-20 01:34

Can you paste the messages that get printed to the terminal when you open the network and make it crash? Also please confirm that this only happens when the option "only lie about names of desktop files on the Desktop" is checked.

kellerman commented on 2011-08-19 12:36

crashes when opening Network and Trash appears as "/", root filesystem too.

ConnorBehan commented on 2011-05-25 00:58

Good point. Those things were depending on specific versions of thunar. So even though I wrote provides=('thunar') there was no way for it to be sure that the version was adequate. Fixed.

Anonymous comment on 2011-05-24 05:28

I seem to have a bit of a problem installing this (not a problem with the package necessarily). When pacman tries to install over thunar (replace it), thunar-archive-plugin, thunar-volman, and xfdesktop complain that they need thunar. Is there an easy way to fix this, apart from uninstalling them? To be honest, the only one I want is thunar-volman.

ConnorBehan commented on 2011-05-24 02:32

It means g_file_get_path is failing to return a path for something that is a valid GFile. Not sure why that would happen but see if -2 fixes it.

anoknusa commented on 2011-05-19 18:02

I keep receiving this error:

(thunar:30766): GLib-CRITICAL **: g_path_get_dirname: assertion `file_name != NULL' failed

(thunar:30766): GLib-CRITICAL **: g_path_get_basename: assertion `file_name != NULL' failed
Segmentation fault

Any suggestions?

ConnorBehan commented on 2011-02-26 19:52

Proposed :)

http://bugzilla.xfce.org/show_bug.cgi?id=7352
http://bugzilla.xfce.org/show_bug.cgi?id=7353
http://bugzilla.xfce.org/show_bug.cgi?id=7354

ConnorBehan commented on 2010-09-03 14:16

I was thinking of waiting until after GIO as some of this will have to change.

Anonymous comment on 2010-09-02 08:20

Thank you!

Have you proposed your patch on bugzilla.xfce.org?

Anonymous comment on 2010-09-01 04:35

Source line is wrong, no thunar-extended directory, you could use ${provides} instead of {pkgname} there or just hardcode it