Package Details: thunderbird-appmenu 60.7.0-1

Git Clone URL: https://aur.archlinux.org/thunderbird-appmenu.git (read-only)
Package Base: thunderbird-appmenu
Description: Thunderbird from extra with appmenu patch
Upstream URL: https://aur.archlinux.org/packages/thunderbird-appmenu/
Licenses: GPL, MPL, LGPL
Conflicts: thunderbird
Provides: thunderbird=60.7.0
Submitter: nikatar
Maintainer: nikatar
Last Packager: nikatar
Votes: 6
Popularity: 0.891953
First Submitted: 2018-06-06 17:47
Last Updated: 2019-06-03 10:39

Dependencies (29)

Required by (93)

Sources (4)

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

farseerfc commented on 2019-02-22 05:32

maybe we should add appmenu-gtk-module into optdepends

nikatar commented on 2019-02-22 03:58

I don't use KDE, therefore I can't help you. But, as I know, @michaldybczak is KDE user. Write to him by email. I hope, he will help you.

alexm commented on 2019-02-22 03:41

I have built and installed the package (60.5.1-1), but still don't see any menu, neither in the dedicated button in the program title, nor in the global menu. Most of other applications: Qt-apps, GTK2-apps (e.g. dia), GTK3-apps (gvim), LibreOffice, - do support global menus in the system (KDE/Plasma-5.15).

Maybe I have to active the feature somehow within thunderbird?

Thank you in advance.

nikatar commented on 2019-02-21 01:27

Updated.

Everything is working.

nikatar commented on 2019-02-10 00:09

Contrary to my expectations the patch for 60.4.0 doesn't work for the version 60.5.0. Although, as a rule, within the major version everything was ok.

I note that I myself don't create this patches, but only use the ready-made from Ubuntu. Therefore, I will wait until thunderbird is updated to version 60.5.0 in Ubuntu and a fresh patch appears.

michaldybczak commented on 2019-02-09 17:11

I believe that the issue is with the version of a patch. I found this explanation about the error:

"A hunk might fail if the similarities of a hunk don't match what's in the original file. When you see this error, it is almost always because you're using a patch for the wrong version of the code you're patching."

I checked the patch and today they made version error. It is said to be 60.5.1 update but when we look inside code there us... 60.5.0 and that is the problem.

Also, AUR description shows 60.5.0 version so there is a mix up in various places.

michaldybczak commented on 2019-02-09 14:24

Yeah, I have a similar problem:

Hunk #2 succeeded at 116 with fuzz 1 (offset -1 lines). Hunk #3 succeeded at 223 with fuzz 2 (offset -9 lines). Hunk #4 FAILED at 268. Hunk #5 FAILED at 305. 2 out of 5 hunks FAILED -- saving rejects to file widget/gtk/nsWidgetFactory.cpp.rej patching file widget/gtk/nsWindow.cpp Hunk #2 FAILED at 5156. 1 out of 2 hunks FAILED -- saving rejects to file widget/gtk/nsWindow.cpp.rej patching file widget/gtk/nsWindow.h Hunk #2 FAILED at 165. Hunk #3 FAILED at 602. 2 out of 3 hunks FAILED -- saving rejects to file widget/gtk/nsWindow.h.rej patching file widget/moz.build patching file xpfe/appshell/nsWebShellWindow.cpp Hunk #1 succeeded at 70 (offset -1 lines). ==> ERROR: There is an error in prepare(). Aborting...

nikatar commented on 2019-02-08 23:44

!!!ATTENTION!!!

Patch issues found in 60.0.5. The package is not built. While waiting and don't update.

Log: https://bin.disroot.org/?543fb79df7b5861e#Y+kJr9mSD/f3scgYF3kzB+Jiiv3Ucp3wUDl/cgogES0=https://bin.disroot.org/?543fb79df7b5861e#Y+kJr9mSD/f3scgYF3kzB+Jiiv3Ucp3wUDl/cgogES0=

arifzeeshan commented on 2019-01-11 13:33

@nikatar

Updated.

Replacement for FireTray:

https://github.com/gyunaev/birdtray

https://aur.archlinux.org/packages/birdtray

But I don't see any notification icon, do I need to keep it running minimized ?

farseerfc commented on 2019-01-10 16:30

@arifzeeshan not on AUR but the unofficial [archlinuxcn] repo is building this package and providing binary https://wiki.archlinux.org/index.php/Unofficial_user_repositories#archlinuxcn