Package Details: thunderbird-extension-gnome-keyring-git 0.11-4

Git Clone URL: https://aur.archlinux.org/mozilla-extension-gnome-keyring-git.git (read-only)
Package Base: mozilla-extension-gnome-keyring-git
Description: Mozilla extension to store passwords and form logins in gnome-keyring.
Upstream URL: https://github.com/swick/mozilla-gnome-keyring
Licenses: GPLv3
Conflicts: thunderbird-extension-gnome-keyring
Provides: thunderbird-extension-gnome-keyring
Submitter: XZS
Maintainer: XZS
Last Packager: XZS
Votes: 9
Popularity: 0.301842
First Submitted: 2014-10-20 08:03
Last Updated: 2016-05-11 14:01

Latest Comments

XZS commented on 2016-05-09 23:10

This a so-called split package. It produces multiple packages from one PKGBUILD. You can choose to only install the ones needed for Firefox.

curl -LO https://aur.archlinux.org/cgit/aur.git/snapshot/mozilla-extension-gnome-keyring-git.tar.xz | tar xJ -C /tmp
cd /tmp/mozilla-extension-gnome-keyring-git
makepkg
sudo pacman -U {mozilla,firefox}-extension-gnome-keyring-git-*-any.pkg.tar.xz

gj545rndmu commented on 2016-05-09 23:00

It tries to install thunderbird and thunderbird-extension-gnome-keyring-git.
I don't want to have neither thunderbird nor thunderbird-extension-gnome-keyring-git.

I just want to have the one for firefox.

XZS commented on 2016-01-08 16:49

The original maintainer has declared the extension to be compatible with the current Firefox version. So the workaround I announced in my last comment is no longer needed.

tad commented on 2015-12-06 00:53

Possible to create an "aurora-extension-gnome-keyring-git" variant? I don't have a package providing "firefox" on my system.

XZS commented on 2015-09-29 10:43

Because it's install.rdf <https://github.com/swick/mozilla-gnome-keyring/blob/master/install.rdf> tells so. As far as I can tell, it works fine with the current Firefox, so I requested an update <https://github.com/swick/mozilla-gnome-keyring/pull/30#issuecomment-143884717> and switched to a fork pretending it would be compatible up to imaginary Firefox version 50. Please handle with care until the original maintainer updates.

ewtoombs commented on 2015-09-27 11:34

Why does this package require firefox<40? It no longer installs because of this.