Package Details: tidal-dl 2022.10.31.1-1

Git Clone URL: https://aur.archlinux.org/tidal-dl.git (read-only, click to copy)
Package Base: tidal-dl
Description: Download videos and tracks from Tidal.
Upstream URL: https://github.com/yaronzz/Tidal-Media-Downloader
Keywords: Audio Music Tidal Video
Licenses: Apache
Submitter: peeweep
Maintainer: Frikilinux
Last Packager: Frikilinux
Votes: 7
Popularity: 0.110143
First Submitted: 2019-10-01 06:37 (UTC)
Last Updated: 2022-11-02 01:28 (UTC)

Latest Comments

Frikilinux commented on 2022-07-06 02:26 (UTC)

@yeti, thanks, fixed in the new version.

yeti commented on 2022-07-05 23:42 (UTC)

Traceback (most recent call last):
  File "/usr/bin/tidal-dl", line 33, in <module>
    sys.exit(load_entry_point('tidal-dl==2022.6.23.3', 'console_scripts', 'tidal-dl')())
  File "/usr/lib/python3.10/site-packages/tidal_dl/__init__.py", line 103, in main
    changeSettings()
  File "/usr/lib/python3.10/site-packages/tidal_dl/events.py", line 184, in changeSettings
    Printf.settings(SETTINGS)
TypeError: Printf.settings() takes 0 positional arguments but 1 was given

Any idea why I keep getting that

Frikilinux commented on 2022-01-15 18:47 (UTC) (edited on 2022-01-22 22:56 (UTC) by Frikilinux)

@miladiir, try building the package with makepkg directly or clear the cache of yay. python-liricsgenius is present in the depends array and the pkg is built as expected.

miladiir commented on 2022-01-15 10:19 (UTC) (edited on 2022-01-15 10:19 (UTC) by miladiir)

Traceback (most recent call last):
  File "/home/miladiir/.cache/yay/tidal-dl/src/tidal-dl-2022.1.11.1/setup.py", line 2, in <module>
    from tidal_dl.printf import VERSION
  File "/home/miladiir/.cache/yay/tidal-dl/src/tidal-dl-2022.1.11.1/tidal_dl/__init__.py", line 23, in <module>
    from tidal_dl.download import start
  File "/home/miladiir/.cache/yay/tidal-dl/src/tidal-dl-2022.1.11.1/tidal_dl/download.py", line 17, in <module>
    import lyricsgenius
ModuleNotFoundError: No module named 'lyricsgenius'

Win8Error commented on 2021-12-04 20:13 (UTC)

Please add python-setuptools and python-pydub as runtime dependency.

peeweep commented on 2019-10-29 12:23 (UTC)

Sorry, updated.

makikatze commented on 2019-10-29 07:41 (UTC)

You forgot to update the checksums while updating the PKGBUILD file to version 1.1.0.9