Package Details: tilix-git 1.7.5.r49.aba1c15-1

Git Clone URL: https://aur.archlinux.org/tilix-git.git (read-only)
Package Base: tilix-git
Description: A tiling terminal emulator based on GTK+ 3 (git master)
Upstream URL: http://github.com/gnunn1/tilix
Licenses: MPL
Conflicts: terminix, tilix
Provides: terminix, tilix
Submitter: dsboger
Maintainer: dsboger
Last Packager: dsboger
Votes: 23
Popularity: 0.093251
First Submitted: 2017-03-12 01:46
Last Updated: 2018-03-08 04:35

Dependencies (12)

Required by (6)

Sources (1)

Pinned Comments

dsboger commented on 2017-10-16 16:20

@PrzemekS I think you've discarded the important messages, but it certainly looks like a linker error. In this case, it is probably caused by an update of some dependency (either ldc/liblphobos or gtkd). So, the likely solution is to rebuild gtkd/gtkd-git and then tilix/tilix-git. Please, let me know if that does not work!

As a side note, this same rule also applies for other AUR packages written in compiled programming languages (e.g. C, C++ and D).

Latest Comments

dsboger commented on 2018-01-08 15:10

When I rebuilt tilix/tilix-git they stopped working, but now I've pushed a fix proposed by @Wild in [1] and It works for me again. Could you test again, please, and report issues here? Thanks!

[1] https://github.com/gnunn1/tilix/pull/1244

dsboger commented on 2018-01-07 18:27

I've pushed a change to gtkd that fixes the issue on my end. Please, rebuild gtkd and test tilix again.

dsboger commented on 2018-01-07 13:58

It was reported upstream [1].

[1] https://github.com/gnunn1/tilix/issues/1243

cjdmtester commented on 2018-01-07 07:55

After the last update of ldc, I rebuild gtkd and then tilix to fix the linker error, but still I get this message when launching the app: Aborting from rt/sections_elf_shared.d(500) Only one D shared object allowed for static runtimeAborted (core dumped).

dsboger commented on 2017-11-03 14:23

I fixed tilix by merging an unreleased commit that allows building with gtkd 3.7.1. So I updated gtkd and now this package should work with gtkd too.

dsboger commented on 2017-10-28 00:14

Right now, this package will not build with gtkd 3.6.6, but will with 3.7.0. I won't update gtkd because that breaks the tilix package. Please, use this package together with gtkd-git, at least until tilix gets a new release.

dsboger commented on 2017-10-16 16:20

@PrzemekS I think you've discarded the important messages, but it certainly looks like a linker error. In this case, it is probably caused by an update of some dependency (either ldc/liblphobos or gtkd). So, the likely solution is to rebuild gtkd/gtkd-git and then tilix/tilix-git. Please, let me know if that does not work!

As a side note, this same rule also applies for other AUR packages written in compiled programming languages (e.g. C, C++ and D).

PrzemekS commented on 2017-10-16 06:33

Hello, today I try to upgrade tilix-git but have that error:

collect2: error: ld returned 1 exit status
Error: /usr/bin/gcc failed with status: 1
make[1]: *** [Makefile:1037: tilix] Error 1
make[1]: Leaving folder '/tmp/pamac-build-przemek/tilix-git/src/tilix'
make: *** [Makefile:606: all-recursive] Error 1

dsboger commented on 2017-09-20 20:10

@sergiodlc have you rebuilt gtkd? ldc got updated so you must rebuild both gtkd and tilix. Also, could you give details of the issue? Not everyone might be having the same problem. I, for one, have just rebuilt it without any issue.

P.S.: "dub build" works because it links gtkd statically with tilix, so they are both built together.

sergiodlc commented on 2017-09-20 20:06

@dsboger, build is broken since a couple of days ago. Building with "dub build" and installing using the provided install.sh, as explained in the github's project page works.

All comments