Package Details: timeshift 19.01-3

Git Clone URL: https://aur.archlinux.org/timeshift.git (read-only)
Package Base: timeshift
Description: A system restore utility for Linux
Upstream URL: https://github.com/teejee2008/timeshift
Licenses: GPL
Submitter: severach
Maintainer: severach
Last Packager: severach
Votes: 67
Popularity: 4.132094
First Submitted: 2015-08-19 07:22
Last Updated: 2019-06-11 04:24

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

joshirio commented on 2017-05-17 21:19

So how to compile it?
With vala 0.36.3 it fails

severach commented on 2017-05-13 06:20

It builds with vala-0.34.6-1

Zorg commented on 2017-05-13 02:29

The same problem Pumba and Kaveiros have. Can't install at all.

Kaveiros commented on 2017-04-30 05:50

Same problem with same message as Pumba described.

pumba commented on 2017-04-25 17:54

@severach I'm having problems to compile this package.

Gtk/ExcludeBox.vala:301.17-301.20: error: Argument 1: Cannot pass value to reference or output parameter
store.remove(item);
^^^^
Gtk/RsyncLogWindow.vala:167.4-167.22: warning: GLib.Thread.create has been deprecated since 2.32. Use new Thread<T> ()
Compilation failed: 1 error(s), 21 warning(s)
make[1]: *** [makefile:27: all] Error 1
make: *** [makefile:2: all] Error 2
/usr/bin/makepkg: line 729: logpipe: unbound variable
warning: package timeshift failed to build, skipping

alesk commented on 2017-04-20 19:08

timeshift --restore
...
Failed to mount device...
https://cs7063.userapi.com/c836121/v836121635/52c97/kq4B2Y7ZqME.jpg
Why?

crowja commented on 2017-01-29 01:30

seems invalid sha256sum for timeshift_v17.2_r429.tgz, works after changing PKGBUILD:

sha256sums=('14e22d20516bd8c0caa9822f2b1d79a309bb1ca1b6ccda5e2da448f5ce630147'
'85fe8263aacd294cb455d9216e649ba16d7710afbb5d0b64d2a29b932f76283e')

severach commented on 2016-07-14 16:07

Install Debian to a spare machine from the junk box. Install timeshift. If the check box problem is there too then you report to the developer. If not then look for differences between Arch and Debian.

Maxiride commented on 2016-07-14 11:12

@severach do you mean I need to switch linux distro? I don't get it :\

severach commented on 2016-07-07 08:19

Try installing Debian to see if your checkbox issue is fixed.