Package Details: tiny-irc-client 0.9.0-2

Git Clone URL: https://aur.archlinux.org/tiny-irc-client.git (read-only, click to copy)
Package Base: tiny-irc-client
Description: Console IRC client written in Rust
Upstream URL: https://github.com/osa1/tiny
Licenses: MIT
Submitter: flacks
Maintainer: ny-a
Last Packager: ny-a
Votes: 5
Popularity: 0.22
First Submitted: 2018-07-09 15:31
Last Updated: 2021-05-14 14:08

Latest Comments

salkin-mada commented on 2021-05-16 12:43

@ny-a: No worries :) Thank you so much for maintaining this package! All good now.

ny-a commented on 2021-05-14 14:16

@salkin-mada: Sorry for inconvenience. I thought I built successfully in clean environment, but it was not clean I guess. I'd updated this package, so please try again and let me know about its result. Thanks.

salkin-mada commented on 2021-05-14 12:16

Today i did an update of tiny and this was the result.

==> Making package: tiny-irc-client 0.9.0-1 (2021-05-14T13:06:45 CEST)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found v0.9.0.tar.gz
==> Validating source files with md5sums...
    v0.9.0.tar.gz ... Passed
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Extracting v0.9.0.tar.gz with bsdtar
==> Sources are ready.
==> Making package: tiny-irc-client 0.9.0-1 (2021-05-14T13:06:48 CEST)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> WARNING: Using existing $srcdir/ tree
==> Starting build()...
error: --features is not allowed in the root of a virtual workspace
note: while this was previously accepted, it didn't actually do anything
help: change the current directory to the package directory, or use the --manifest-path flag to the path of the package
==> ERROR: A failure occurred in build().
    Aborting...
error making: tiny-irc-client

deko commented on 2021-03-11 22:39

You don't need rustup to build this package, please, replace it with cargo.

bbx0 commented on 2020-11-21 21:43

Thanks for making this. Please find below a proposed changed version to enable the newer features.

  • Removed the nightly part
  • Removed the git make dependency as it's not used.
  • Enabled feature desktop-notifications (and kept the libdbus dependency)
  • Added openssl as dependency and enabled feature tls-native
  • Changed the cd to subdir tiny to allow the usage of features
# Maintainer: ny-a <nyaarch64@gmail..com>
# Contributor: Jean Lucas <jean@4ray.co>

pkgname=tiny-irc-client
pkgver=0.7.0
pkgrel=1
pkgdesc='Console IRC client written in Rust'
arch=(i686 x86_64 aarch64)
url=https://github.com/osa1/tiny
license=(MIT)
depends=(libdbus openssl)
makedepends=(rustup)
source=("https://github.com/osa1/tiny/archive/v${pkgver}.tar.gz")
md5sums=('13046d60e7a501b29a56cebe9911c9fa')

build() {
  cd "${srcdir}/tiny-${pkgver}/tiny"
  cargo build --no-default-features --features=tls-native,desktop-notifications --release --locked
}

check() {
  cd "${srcdir}/tiny-${pkgver}/tiny"
  cargo test --no-default-features --features=tls-native,desktop-notifications --release --locked
}

package() {
  cd "${srcdir}/tiny-${pkgver}"
  install -D target/release/tiny -t "$pkgdir"/usr/bin
  install -Dm 644 README.md -t "$pkgdir"/usr/share/doc/tiny
  install -Dm 644 LICENSE -t "$pkgdir"/usr/share/licenses/tiny
}

salkin-mada commented on 2020-11-15 14:13

Could you update the build function in the PKGBUILD? There is no notifications enabled in the build provided by this package. When building from source we need to use --features desktop-notifications. As of now this package does not depend on libdbus nevertheless stated.

And yes there is no longer any need for nightly rustc to build tiny.

And thanks for maintaining this aur :)

jonasmalacofilho commented on 2020-10-10 09:49

I it seems that nightly is no longer necessary with rust 1.47.0.