Package Details: tlpui-git 2:1.6.4.r0.g2caad18-2

Git Clone URL: https://aur.archlinux.org/tlpui-git.git (read-only, click to copy)
Package Base: tlpui-git
Description: A GTK user interface for TLP written in Python
Upstream URL: https://github.com/d4nj1/TLPUI
Licenses: GPL-2.0-or-later
Conflicts: tlpui
Provides: tlpui
Submitter: slact
Maintainer: yochananmarqos
Last Packager: yochananmarqos
Votes: 35
Popularity: 0.069892
First Submitted: 2018-05-13 23:54 (UTC)
Last Updated: 2024-02-06 09:01 (UTC)

Latest Comments

1 2 Next › Last »

frittentheke commented on 2024-04-11 09:09 (UTC) (edited on 2024-04-11 09:10 (UTC) by frittentheke)

There seems to be an issue building this package if the system has the tool "pyenv" installed. The .python-version files (see https://github.com/pyenv/pyenv?tab=readme-ov-file#understanding-python-version-selection) contained in the package then causes the build to fail:

==> Making package: tlpui-git 2:1.6.4.r0.g2caad18-2 (Thu 11 Apr 2024 11:07:46 AM CEST)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Updating tlpui git repo...
==> Validating source files with sha256sums...
    tlpui ... Skipped
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Creating working copy of tlpui git repo...
Cloning into 'tlpui'...
done.
==> Starting pkgver()...
==> Updated version: tlpui-git 2:1.6.5.r0.ged1b2d4-1
==> Sources are ready.
==> Making package: tlpui-git 2:1.6.5.r0.ged1b2d4-1 (Thu 11 Apr 2024 11:07:48 AM CEST)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> WARNING: Using existing $srcdir/ tree
==> Starting pkgver()...
==> Starting build()...
pyenv: version `3.8' is not installed (set by /home/itsme/.cache/yay/tlpui-git/src/tlpui/.python-version)
pyenv: version `3.9' is not installed (set by /home/itsme/.cache/yay/tlpui-git/src/tlpui/.python-version)
==> ERROR: A failure occurred in build().
    Aborting...
 -> error making: tlpui-git-exit status 4
 -> Failed to install the following packages. Manual intervention is required:
tlpui-git - exit status 4

This file was just added upstream with the 1.6.5 release - https://github.com/d4nj1/TLPUI/commit/abe24c2944bc54a2d15f13da7d691ff5ba4dcb53

RogueToad50 commented on 2024-02-07 07:47 (UTC)

This issue seems to have been fixed in the latest update.

solarisfire commented on 2024-01-23 11:22 (UTC)

Changing one line in the PKGBUILD fixes this...

install -Dm644 "AppImage/com.github.d4nj1.tlpui.appdata.xml" -t "$pkgdir/usr/share/metainfo/"

For some reason _app_id is wrong here, I don't know if they changed the name of the appdata.xml file upstream or something?

Setting _app_id=com.github.d4nj1.tlpui breaks things further though, so don't do that.

frittentheke commented on 2024-01-23 08:09 (UTC) (edited on 2024-01-23 08:09 (UTC) by frittentheke)

There currently seems to be a packaging error:

Successfully built tlp_ui-1.6.3-py3-none-any.whl
==> Entering fakeroot environment...
==> Starting package()...
install: cannot stat 'AppImage/.appdata.xml': No such file or directory
==> ERROR: A failure occurred in package().
    Aborting...
 -> error making: tlpui-git-exit status 4
 -> Failed to install the following packages. Manual intervention is required:
tlpui-git - exit status 4

yochananmarqos commented on 2021-09-27 22:02 (UTC)

@katt: Please do not flag VCS packages out of date. Instead, leave a comment.

NK1406 commented on 2020-12-13 17:47 (UTC) (edited on 2020-12-13 17:47 (UTC) by NK1406)

It should be mentioned that there is now a stable version of this package in the AUR. This may be helpful for people experiencing difficulties with the current git version.

x3oo commented on 2020-12-07 13:44 (UTC)

Traceback (most recent call last): File "/usr/bin/tlpui", line 6, in <module> from pkg_resources import load_entry_point File "/usr/lib/python3.9/site-packages/pkg_resources/init.py", line 3239, in <module> def _initialize_master_working_set(): File "/usr/lib/python3.9/site-packages/pkg_resources/init.py", line 3222, in _call_aside f(args, *kwargs) File "/usr/lib/python3.9/site-packages/pkg_resources/init.py", line 3251, in _initialize_master_working_set working_set = WorkingSet._build_master() File "/usr/lib/python3.9/site-packages/pkg_resources/init.py", line 567, in _build_master ws.require(requires) File "/usr/lib/python3.9/site-packages/pkg_resources/init.py", line 884, in require needed = self.resolve(parse_requirements(requirements)) File "/usr/lib/python3.9/site-packages/pkg_resources/init.py", line 770, in resolve raise DistributionNotFound(req, requirers) pkg_resources.DistributionNotFound: The 'TLPUI==0.1' distribution was not found and is required by the application

yochananmarqos commented on 2020-05-28 14:21 (UTC)

@Moonglade: Thanks for the heads up. It turns out the release tags were removed upstream, that's why it doesn't work. The setup.py version has never changed since it's creation, but I suppose that's all all there is for now.

Moonglade commented on 2020-05-28 08:29 (UTC) (edited on 2020-05-28 08:37 (UTC) by Moonglade)

pkgver() shows errors for me, use this instead:


pkgver() {
    cd "$srcdir/${pkgname%-git}"
    echo "$(python setup.py --version).r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
}