Package Details: tmuxp 1.3.2-2

Git Clone URL: https://aur.archlinux.org/tmuxp.git (read-only)
Package Base: tmuxp
Description: Manage tmux workspaces from JSON and YAML, pythonic API, shell completion.
Upstream URL: https://github.com/tony/tmuxp
Licenses: BSD
Submitter: kageurufu
Maintainer: kageurufu
Last Packager: kageurufu
Votes: 11
Popularity: 0.080524
First Submitted: 2015-08-10 23:44
Last Updated: 2017-08-30 20:51

Latest Comments

jomasti commented on 2017-05-03 22:45

You have an extra equal sign for the python-colorama dependency.

kageurufu commented on 2017-04-28 21:40

You're going to need to install python-colorama-git until python-colorama is updated, and I had to use --nocheck to install python-colorama

thebopshoobop commented on 2017-01-14 04:41

Updated PKGBUILD for 1.2.4:
https://gist.github.com/thebopshoobop/833aaf922e3d6187bbb123168a59d128

pepper_chico commented on 2017-01-11 04:53

After last upgrade, now having conflicts with click package.

click is on 6.7 now, package requires == 6.6.

If one wishes to fix it locally after install:

- vim /usr/lib/python3.6/site-packages/tmuxp-1.2.3-py3.6.egg-info/requires.txt

svenXY commented on 2017-01-09 08:59

This seems to have been bumped to 1.2.3, but the dependency to python-libtmux>=0.6.1 cannot be resolved.

_author=tony
pkgname=tmuxp
pkgver=1.2.3
...
depends=(
...
'python-libtmux>=0.6.1'·

etu commented on 2016-11-12 08:01

I think this or python-libtmux would need to add tmux as an dependency

pepper_chico commented on 2016-09-17 06:33

@kageurufu thanks, it's installing fine now.

kageurufu commented on 2016-09-17 06:06

Sorry about that, pushed python-libtmux 0.6.0 and bumped the pkgrel to match

Working on my machine now

pepper_chico commented on 2016-09-17 06:02

@kageurufu meaning, this last update requires that the python-libtmux AUR dependency to be updated as well.

pepper_chico commented on 2016-09-17 06:00

@kageurufu this version of tmuxp is requiring a newer libtmux than the one that's available from AUR currently:

~ ❯❯❯ tmuxp load mail
Traceback (most recent call last):
File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 660, in _build_master
ws.require(__requires__)
File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 968, in require
needed = self.resolve(parse_requirements(requirements))
File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 859, in resolve
raise VersionConflict(dist, req).with_context(dependent_req)
pkg_resources.ContextualVersionConflict: (libtmux 0.5.0 (/usr/lib/python3.5/site-packages), Requirement.parse('libtmux==0.6.0'), {'tmuxp'})

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File "/usr/bin/tmuxp", line 6, in <module>
from pkg_resources import load_entry_point
File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 2985, in <module>
@_call_aside
File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 2971, in _call_aside
f(*args, **kwargs)
File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 2998, in _initialize_master_working_set
working_set = WorkingSet._build_master()
File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 662, in _build_master
return cls._build_from_requirements(__requires__)
File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 675, in _build_from_requirements
dists = ws.resolve(reqs, Environment())
File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 854, in resolve
raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'libtmux==0.6.0' distribution was not found and is required by tmuxp

All comments