Package Details: toggldesktop-bin 7.4.528-5

Git Clone URL: https://aur.archlinux.org/toggldesktop-bin.git (read-only, click to copy)
Package Base: toggldesktop-bin
Description: Time Tracking Software.
Upstream URL: https://toggl.com/
Keywords: freelance toggl
Conflicts: toggldesktop
Provides: toggldesktop
Submitter: swalladge
Maintainer: whezzel
Last Packager: whezzel
Votes: 23
Popularity: 0.045585
First Submitted: 2017-01-23 23:15
Last Updated: 2019-11-26 19:03

Pinned Comments

yurikoles commented on 2018-10-26 13:24

PRs are welcome: https://github.com/yurikoles-aur/toggldesktop-bin

If you want to install the latest release, then use: toggldesktop-dev-bin.

Please don't report out of date until you check API response, e.g.

$ curl "https://toggl.com/api/v8/installer?app=td&platform=deb64&channel=stable"
<a href="https://github.com/toggl/toggldesktop/releases/download/v7.4.122/toggldesktop_7.4.122_amd64.deb">Found</a>.

Latest Comments

1 2 3 4 5 6 Next › Last »

borisjoffe commented on 2019-11-27 06:20

@whezzel Thanks, the install works now.

whezzel commented on 2019-11-26 19:07

The github url that the source files are downloaded from changed. The PKGBUILD has been updated to reflect this change.

Let me know if you run into anymore issues.

concocki commented on 2019-11-26 17:34

I'm getting the same error:

curl: (22) The requested URL returned error: 404 Not Found
==> ERROR: Failure while downloading https://github.com/toggl/toggldesktop/releases/download/v7.4.528/toggldesktop_7.4.528_amd64.deb
    Aborting...
Error downloading sources: toggldesktop-bin

borisjoffe commented on 2019-11-26 06:44

I'm getting the following error when installing it:

curl: (22) The requested URL returned error: 404 Not Found
==> ERROR: Failure while downloading https://github.com/toggl/toggldesktop/releases/download/v7.4.528/toggldesktop_7.4.528_amd64.deb
    Aborting...
Error downloading sources: toggldesktop-bin

I think it could be the _amd64 part of the deb file

PotHix commented on 2019-10-15 13:01

It's not working, probably because the package is outdated. Already flagged a out of date.

yurikoles commented on 2019-03-28 12:01

@kuon please send a PR to https://github.com/yurikoles-aur/toggldesktop-bin

kuon commented on 2019-03-16 14:55

I also had a problem with the GUI not showing, but in my case the responsible env var was QT_STYLE_OVERRIDE. I had it set to kvantum.

Adding QT_STYLE_OVERRIDE='' to the /opt/toggldesktop/TogglDesktop.sh script fixed it.

daweiy commented on 2019-02-17 03:26

Manjaro user with MATE desktop here. Not showing GUI either. I used the method by @nabuhodonozo but edited the /usr/share/applications/toggldesktop.desktop instead, with env QT_QPA_PLATFORMTHEME=gtk3 and it also works.

nomacsec commented on 2019-01-23 19:52

@mattalexx

"...every time I open the app, it asks me if I want to install the new version. Any way to turn that off?"

  1. In the Toggl Desktop UI menu bar, click Toggl Desktop > About
  2. After the About window opens, click the drop-down menu next to Release channel and select stable
  3. It will check for updates. Then, display Toggl Desktop is up to date

nabuhodonozo commented on 2018-11-05 16:46

Manjaro user with gnome desktop. App doesnt work UI doesnt show up.

Fix! /opt/toggldesktop/TogglDesktop.sh add QT_QPA_PLATFORMTHEME=gtk3 before else

And if you are using Manjaro with gnome. You ll need to add "$XDG" = "GNOME" to if. In case you are using different environment, you can check by running "echo $XDG_CURRENT_DESKTOP"