Package Details: toggldesktop 7.4.347-1

Git Clone URL: https://aur.archlinux.org/toggldesktop.git (read-only)
Package Base: toggldesktop
Description: Toggl time tracking software
Upstream URL: https://github.com/toggl/toggldesktop
Licenses: BSD
Conflicts: toggl-bin, toggldesktop-bin
Submitter: karel_louwagie
Maintainer: flops
Last Packager: flops
Votes: 18
Popularity: 0.886972
First Submitted: 2016-02-27 16:04
Last Updated: 2019-02-27 12:42

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

swalladge commented on 2017-12-19 02:47

I suspect this has something to do with the fact that it bundles a version of openssl with it (and probably is getting built against it). If that version is very different from that shipped with arch, then we have a problem. Debugging help appreciated! :)

swalladge commented on 2017-12-19 02:31

@phil-mah I can't reproduce the build errors you are getting. It builds fine for me in a clean chroot.

Yes I also noticed the SSL errors in the log (I haven't used Toggl for a while so not sure when it began). That may be an upstream issue - I'll open an issue on their github repo. [EDIT: on second thoughts that sounds more like an issue on openssl's side or the configuration...]

phi-mah commented on 2017-12-18 15:27

I observed two things concerning the toogldesktop app:

1) Even with the most-recent PKGBUILD I get build errors. However the build process can be manually completed via executing

make; (will still produce an error, complaining about missing poco libs) make poco; make;

within the src directory.

2) Since recently, togglDesktop refuses to connect to the server and displays: Status offline, no network

The log file is full of lines similar to this one: 2017-12-18 15:12:52.151 [27737 6]:websocket_client:E:SSL Exception: Cannot create SSL_CTX object: error:140A90A1:SSL routines:SSL_CTX_new:library has no ciphers

This makes the app unusable for me, any ideas would be much appreciated...

braderhart commented on 2017-08-28 23:32

toggldesktop 7.4.58-1:

https://gist.github.com/anonymous/4ca46a04396c404f5b80dc235a453255

prrraveen commented on 2017-06-16 17:34

@swalladge Thanks, I was able to install by following your suggestion. Please update this in pkgbuild. Thanks again

swalladge commented on 2017-06-15 07:43

@prrraveen can you edit the pkgbuild and change lines 53 and 54 to read:

make -j1 deps
make -j1

Please let me know if this works for you. If so, I'll update the pkgbuild on the aur.

prrraveen commented on 2017-06-15 07:18

I am getting build error. i.e "ERROR: A failure occurred in build()."
I tried installing it multiple times. I didn't understand how to use "-j1" args as mentioned in comments. Did anyone have success installing this package?

swalladge commented on 2017-02-20 23:12

@FrederickZh sounds like a good idea. Can I add the flag when calling `make`, or would I need to patch the makefile? (not that familiar with c build processes... I'm assuming it would require patching the makefile to add to the cflags and/or cxx variables there)

FrederickZh commented on 2017-02-20 11:38

It often fails with parallel compilation enabled. Perhaps it's better to explicitly specify "-j1".

barbuk commented on 2017-01-25 13:28

The package is correctly build after a second try. ¯\_(ツ)_/¯