Package Details: tok-git r193.0ade57f-1

Git Clone URL: https://aur.archlinux.org/tok-git.git (read-only, click to copy)
Package Base: tok-git
Description: Telegram client built using Kirigami
Upstream URL: https://invent.kde.org/network/tok
Keywords: kirigami telegram
Licenses: GPL3
Conflicts: tok
Provides: tok
Submitter: gustawho
Maintainer: gustawho
Last Packager: gustawho
Votes: 6
Popularity: 1.26
First Submitted: 2021-05-03 03:26
Last Updated: 2021-06-28 22:45

Latest Comments

im_tem commented on 2021-09-13 10:47

extra-cmake-modules is required

johnny_boy commented on 2021-07-19 12:17

I get the following error towards the end of the build:

ERROR: /usr/bin/g++ -g -O0 -Wall -Wextra -m64 -pipe -fexceptions -fvisibility=default -fPIC -DQT_STATICPLUGIN -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/include/qt -I/usr/include/qt/QtGui -I/usr/include/qt/QtCore -I/usr/lib/qt/mkspecs/linux-g++ -I/home/michael/.cache/yay/tok-git/src/tok/default/rlottieplugin.e051c923/qt.headers -std=c++11 -o /home/michael/.cache/yay/tok-git/src/tok/default/rlottieplugin.e051c923/73489b871e127538/moc_rlottieplugin.cpp.o -c /home/michael/.cache/yay/tok-git/src/tok/default/rlottieplugin.e051c923/qt.headers/moc_rlottieplugin.cpp

ERROR: In file included from /usr/include/qt/QtCore/qsharedpointer.h:48, from /usr/include/qt/QtCore/qpointer.h:43, from /usr/include/qt/QtCore/qplugin.h:45, from /usr/include/qt/QtGui/qimageiohandler.h:45, from /usr/include/qt/QtGui/QImageIOPlugin:1, from /home/michael/.cache/yay/tok-git/src/tok/default/rlottieplugin.e051c923/qt.headers/../../../src/the rlottie plugin/rlottieplugin.h:7, from /home/michael/.cache/yay/tok-git/src/tok/default/rlottieplugin.e051c923/qt.headers/moc_rlottieplugin.cpp:10: /usr/include/qt/QtCore/qsharedpointer_impl.h: In function ‘std::shared_ptr<_Tp> qobject_pointer_cast(std::shared_ptr<_Tp>&&)’: /usr/include/qt/QtCore/qsharedpointer_impl.h:1019:40: error: ‘exchange’ is not a member of ‘std’ 1019 | return std::shared_ptr<X>(std::exchange(src, nullptr), castResult); | ^~~~~~~~ ERROR: Process failed with exit code 1. The following products could not be built for configuration default: org.kde.Tok, rlottieplugin, tokInternal ==> ERROR: A failure occurred in build().

database64128 commented on 2021-06-26 08:27

Can you please change the install prefix to /usr instead of /usr/local?

database64128 commented on 2021-06-25 10:04

Please add kconfigwidgets and kitemmodels as dependencies. Building on GNOME requires these packages.

LiveLM commented on 2021-06-06 22:03

Build failed without jq installed. Please add it as a make dependency.

malcolm commented on 2021-06-06 21:49

rlottie is not only a build dependency

gcala commented on 2021-06-06 08:36

Please, add rlottie-git to makedepends

malcolm commented on 2021-05-22 14:24

The CMake build was dropped https://invent.kde.org/network/tok/-/commit/4337f9e99662b28db99ac20cf111cbd439f9f1ed

appadeia commented on 2021-05-17 23:32

don't use CMake for the build; use Qbs.