Package Details: tootstream 0.3.6-1

Git Clone URL: https://aur.archlinux.org/tootstream.git (read-only)
Package Base: tootstream
Description: Text interface for the Mastodon social network
Upstream URL: https://github.com/magicalraccoon/tootstream
Licenses: MIT
Submitter: SirCmpwn
Maintainer: djmoch
Last Packager: djmoch
Votes: 4
Popularity: 0.000239
First Submitted: 2017-11-18 20:14
Last Updated: 2018-11-10 19:50

Required by (0)

Sources (1)

Pinned Comments

djmoch commented on 2019-05-04 11:21

If you see errors regarding a missing python-magic dependency, make sure that you install python-magic-ahupp from the AUR. This resolves to the Python package python-magic, which is not the python-magic package in the Community repo, although the two packages do conflict on account of using the same module name.

It's a dumb problem that the Python package maintainers could easily resolve, but appear to have dug in their heels. I'll be reaching out to upstream on the ahupp side to see if that's really the case or if they might be open to reason.

Latest Comments

djmoch commented on 2019-05-04 11:21

If you see errors regarding a missing python-magic dependency, make sure that you install python-magic-ahupp from the AUR. This resolves to the Python package python-magic, which is not the python-magic package in the Community repo, although the two packages do conflict on account of using the same module name.

It's a dumb problem that the Python package maintainers could easily resolve, but appear to have dug in their heels. I'll be reaching out to upstream on the ahupp side to see if that's really the case or if they might be open to reason.

kflak commented on 2019-05-04 09:35

Getting this after the latest update when launching tootstream:

Traceback (most recent call last): File "/usr/bin/tootstream", line 6, in <module> from pkg_resources import load_entry_point File "/usr/lib/python3.7/site-packages/pkg_resources/init.py", line 3241, in <module> @_call_aside File "/usr/lib/python3.7/site-packages/pkg_resources/init.py", line 3225, in _call_aside f(args, *kwargs) File "/usr/lib/python3.7/site-packages/pkg_resources/init.py", line 3254, in _initialize_master_working_set working_set = WorkingSet._build_master() File "/usr/lib/python3.7/site-packages/pkg_resources/init.py", line 583, in _build_master ws.require(requires) File "/usr/lib/python3.7/site-packages/pkg_resources/init.py", line 900, in require needed = self.resolve(parse_requirements(requirements)) File "/usr/lib/python3.7/site-packages/pkg_resources/init.py", line 786, in resolve raise DistributionNotFound(req, requirers) pkg_resources.DistributionNotFound: The 'python-magic' distribution was not found and is required by Mastodon.py

I have python-magic 5.36-2 installed on my system.

SirCmpwn commented on 2018-11-10 17:48

Thanks!

djmoch commented on 2018-11-10 17:48

tootstream-git maintainer here. I’ll be happy to pick this up and get an update out today.

SirCmpwn commented on 2018-11-10 17:44

I don't actually use this software anymore. Going to orphan the package.

SamWhited commented on 2018-11-10 17:43

Hi, please consider servicing the out-of-date request for this package. Thanks!

SirCmpwn commented on 2018-03-11 15:09

Updated to 0.3.3.

djmoch commented on 2018-03-11 12:06

It appears python-emoji has been updated.

SirCmpwn commented on 2018-02-01 16:56

Update blocked pending update of out of date dependency: https://aur.archlinux.org/packages/python-emoji/

djmoch commented on 2017-12-15 12:51

python-mastodon currently provides Mastodon.py 1.1.2, while tootstream requirements.txt requires exactly version 1.1.1. I was able to fix this by adding the following to the PKGBUILD:

sed -ie 's/Mastodon.py==1\.1\.1/Mastodon.py>=1.1.1/g' requirements.txt