Package Details: topcat 4.9.1-2

Git Clone URL: https://aur.archlinux.org/topcat.git (read-only, click to copy)
Package Base: topcat
Description: Tool for OPerations on Catalogues And Tables
Upstream URL: http://www.star.bris.ac.uk/~mbt/topcat/
Keywords: astronomy astrophysics
Licenses: GPL
Submitter: saimn
Maintainer: saimn
Last Packager: saimn
Votes: 9
Popularity: 0.000322
First Submitted: 2012-09-18 10:00 (UTC)
Last Updated: 2024-04-07 20:04 (UTC)

Dependencies (2)

Required by (0)

Sources (4)

Latest Comments

1 2 Next › Last »

Firestar commented on 2024-04-06 05:56 (UTC) (edited on 2024-04-06 05:59 (UTC) by Firestar)

Can you edit topcat.desktop so that in [Categories] the Science (NOT Sciences!!!)is at the first place? Now it is at Lost and Found category.

vandalt commented on 2023-04-12 14:51 (UTC)

I had an issue with the URL to download topcat. Using this instead seems to fix the issue: https://www.star.bristol.ac.uk/mbt/releases/topcat/v${_pkgver}/topcat-full.jar

saimn commented on 2021-10-29 21:47 (UTC)

@Universebenzene - Yes, I was thinking at this solution too. I updated the package with this, thanks !

Universebenzene commented on 2021-10-25 08:54 (UTC) (edited on 2021-10-25 08:57 (UTC) by Universebenzene)

Is it OK to rename the source in PKGBUILD? Like this:

source=(${pkgname}-full-${pkgver}.jar::"http://andromeda.star.bristol.ac.uk/releases/topcat/v${_pkgver}/topcat-full.jar"

This can solve the md5 problem caused by some AUR helpers. And you can rename it back to topcat-full.jar in the package() phase.

saimn commented on 2021-10-24 17:58 (UTC)

If you are using yay, the cache is in ~/.cache/yay/topcat

lucian commented on 2021-10-24 17:49 (UTC)

could not find it in the cache. (pacmann)

downloaded and verified md5 manually - it is correct. still install doesn't run through. :(

saimn commented on 2021-10-24 17:31 (UTC)

@vandalt - Now using the icon you mentioned, thanks!

saimn commented on 2021-10-24 17:28 (UTC)

Hmm, are you using yay ? I'm seeing the same error locally with yay, because it keeps a cache of downloaded files, and for topcat the file is always the same (topcat-full.jar) so yay does not download the new version. After removing its cache I can install the package, which confirms that the md5sum is correct. Not sure what to do about this.

lucian commented on 2021-10-24 17:07 (UTC)

Validating source files with md5sums... topcat-full.jar ... FAILED

doesnt install since the md5 seems to be wrong (or download). could not find actually the official md5's so I could not update the build script.