Package Details: topmenu-gtk3-git 2015.12.10-1

Git Clone URL: https://aur.archlinux.org/topmenu-gtk3-git.git (read-only, click to copy)
Package Base: topmenu-gtk3-git
Description: Gtk3 module for topmenu.
Upstream URL: https://git.javispedro.com/cgit/topmenu-gtk.git/about/
Licenses: LGPL3
Submitter: gborzi
Maintainer: None
Last Packager: gborzi
Votes: 25
Popularity: 0.000000
First Submitted: 2014-12-16 21:54 (UTC)
Last Updated: 2015-12-17 12:04 (UTC)

Latest Comments

1 2 Next › Last »

michaelrk02 commented on 2018-12-09 23:19 (UTC) (edited on 2018-12-09 23:21 (UTC) by michaelrk02)

You need to download the GTK3 source according to your gtk3 version. Extract it and modify the PKGBUILD.

Add:

--with-gtk-srcdir="/path/to/the/source/"

as the ./configure parameter in the build section.

zone commented on 2018-11-17 05:07 (UTC)

same error as @husek

husek commented on 2018-02-21 16:49 (UTC) (edited on 2018-02-21 16:50 (UTC) by husek)

checking pkg-config is at least version 0.9.0... yes

checking for gtk+-x11-3.0... yes

checking for x11... yes

configure: error: in `/home/Downloads/topmenu-gtk3-git/src/topmenu-gtk':

configure: error: --with-gtk-srcdir was not specified.

See `config.log' for more details

==> ERROR: A failure occurred in build().

Aborting...

Any suggestions?

nerka commented on 2017-02-06 00:45 (UTC)

@gborzi Thanks, my bad! Should have looked there before come here!

gborzi commented on 2017-02-05 23:02 (UTC)

@nerka It is a known bug. From the latest commit: "Please note that there is a known crash with Gtk+>=3.20, which I don't know how to fix. I don't have time to follow all of Gtk+ 3 changes"

nerka commented on 2017-02-05 12:48 (UTC)

My GTK3 applications closes every time I try to use the menu... Anyone else facing this problem?

commented on 2016-11-08 08:47 (UTC)

Shouldn't topmenu-gtk3 build with wnck 3 as well ?

birnenwerfer commented on 2016-02-26 01:01 (UTC)

I added the suggested lines into ~/.xprofile and created a file .gtkrc-2.0 in my home folder with the following line into it: gtk-modules = "canberra-gtk-module:topmenu-gtk-module" But unfortunately it doesn't work with all windows. For example virtualbox, firefox (I also installed topmenu-mozilla-git and it only works with thunderbird), KeePassX and etc .... Any suggestions?

ValHue commented on 2015-06-04 09:59 (UTC)

@gborzi Thanks! Now if he shows me the menus of gtk3 applications

gborzi commented on 2015-06-04 08:54 (UTC)

@ValHue You have to set the GTK_MODULES environment variable in your profile. For example, with lightdm I use: if [[ -z $GTK_MODULES ]]; then GTK_MODULES="topmenu-gtk-module" else GTK_MODULES="$GTK_MODULES:topmenu-gtk-module" fi export GTK_MODULES in ~/.xprofile.