Package Details: tor-browser 10.0.17-2

Git Clone URL: https://aur.archlinux.org/tor-browser.git (read-only, click to copy)
Package Base: tor-browser
Description: Tor Browser Bundle: anonymous browsing using Firefox and Tor (international PKGBUILD)
Upstream URL: https://www.torproject.org/projects/torbrowser.html
Keywords: Anonymity Browser Internet Network Tor
Licenses: GPL
Submitter: grufo
Maintainer: grufo (jugs)
Last Packager: grufo
Votes: 1149
Popularity: 10.46
First Submitted: 2017-03-23 12:24
Last Updated: 2021-06-09 11:44

Required by (0)

Sources (8)

Pinned Comments

grufo commented on 2019-08-15 02:22

Before running makepkg, you must do this (as normal user):

$ gpg --auto-key-locate nodefault,wkd --locate-keys torbrowser@torproject.org

If you want to update tor-browser from AUR without AUR helpers you can run in a terminal:

$ tor-browser -u

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 ... Next › Last »

whynothugo commented on 2021-04-16 10:46

I doesn't seem to be necessary any more. I removed mozilla-common from the PKGBUILD depends, and it builds and runs fine.

class101 commented on 2021-04-16 10:42

To fix extra/mozilla-common deleted from the extra repository

pacman -U https://archive.archlinux.org/packages/m/mozilla-common/mozilla-common-1.4-6-any.pkg.tar.zst

Unfortunately, pushing mozilla-common 1.4-6 at aur/mozilla-common is currently rejected :

remote: error: package already provided by [extra]: mozilla-common        
remote: error: hook declined to update refs/heads/master

Maybe the package is no more necessary ? I haven't checked, a workaround would be to create it under a different name like aur/mozilla-common-aur but this would be ugly, because every dependent app will still break until patched.

Anyway, a backup of the sources of the deleted extra/mozilla-common is available here

https://github.com/archlinux/svntogit-packages/tree/packages/mozilla-common/trunk

morganmay commented on 2021-04-15 23:15

Build of 10.0.15-1 fails due to missing dependency mozilla-common. It's not in official repositories or AUR.

mackilanu commented on 2021-03-31 11:47

@randomguy343 That is an issue with your AUR helper and not this package.

randomguy343 commented on 2021-03-31 10:47

I can't update tor-browser using a AUR helper, I get the following error.

error fetching tor-browser: fatal: No Git-Repository (or any parent directory to the mount point /) Stopping at filesystem boundaries (GIT_DISCOVERY_ACROSS_FILESYSTEM not specified).

But I can simply clone the git repository and build and install the package from there.

zoltanszabo commented on 2021-03-04 20:54

@jugs: Thank you for the quick action; with Tor 10.0.13 ProtonMail starts again nicely.

jugs commented on 2021-03-04 11:48

tor-browser 10.0.13 should fix the glibc issue

AntiComposite commented on 2021-02-24 03:37

That's caused by the same glibc problem. You can downgrade glibc, use an alpha version of tor-browser, or wait for the fix.

adoa commented on 2021-02-24 03:02

tor-browser refuses to play h264 videos for me. I checked html5test.com and they say that my tor-browser does not support the h264 codec. Optional dependency gst-plugins-good is still installed, tho.

It used to work fine, but stopped working a week or two ago. Did some other software update break, or does tor-browser not locate the gstreamer plugins? how do I troubleshoot this?

jugs commented on 2021-02-23 21:21

Thanks for the updates folks, we are tracking the issue on the tor-browser gitlab.

The easiest workaround at the moment is to downgrade to the last 2.32(-5) glibc.

Once a real solution is posted we'll ensure it lands here as well.