Package Details: torch7-cunn-git r819.1ae6aa0-5

Git Clone URL: (read-only, click to copy)
Package Base: torch7-cunn-git
Description: CUDA backend for Torch7 Neural Network Package
Upstream URL:
Licenses: custom
Conflicts: torch7-cunn
Provides: torch7-cunn
Submitter: frantic1048
Maintainer: eclairevoyant
Last Packager: eclairevoyant
Votes: 5
Popularity: 0.000000
First Submitted: 2016-10-02 17:43 (UTC)
Last Updated: 2023-01-07 20:44 (UTC)

Dependencies (6)

Sources (1)

Latest Comments

1 2 Next › Last »

yodaembedding commented on 2023-05-11 00:31 (UTC)

torch7-git torch7-nn-git cmake git should all be makedepends.

Nephilim commented on 2022-01-03 18:54 (UTC)

I found a fix for the current failures caused by cuda 10+

somebody commented on 2021-02-24 01:19 (UTC)

fails with identifier "cusparseScsrmm" is undefined

chrhasse commented on 2019-04-11 04:59 (UTC) (edited on 2019-04-11 05:06 (UTC) by chrhasse)

Looks like the latest version of cuda supports gcc-8 and gcc-7 has been removed from community into the AUR so you don't need -DCMAKE_C_COMPILER=gcc-7 anymore.

frantic1048 commented on 2018-09-17 09:21 (UTC)

I'm sorry that I was testing on a machine not very up to date arch with gcc at version 7 and did not find the compiling error.


Yes, limiting compiler to gcc7 is needed. I'm testing now. BTW, I had set you as maintainer as this package. I'm not very fast on the response because of daily work, if you found a proper fix for the package, you could update this repo( ssh:// ), too :)

petronny commented on 2018-09-17 07:48 (UTC) (edited on 2018-09-17 07:48 (UTC) by petronny)

Same as @flare561 . Setting compiler to gcc-7 works.


flare561 commented on 2018-09-17 04:11 (UTC)

Mine fails to build now because gcc versions later than 7 are not supported. I have gcc 8.2.1

frantic1048 commented on 2018-09-16 15:25 (UTC)

It looks gcc-5 is not need anymore during building, removed gcc54 makedep and gcc-5 flag.

frantic1048 commented on 2018-09-16 15:19 (UTC)

fuan_k: Makes me wonder why it depends on a specific old version of gcc.

Because it needs gcc-5 to build before, I'm checking if it's working with current gcc version.

fuan_k commented on 2018-09-16 14:59 (UTC)

Can't install, because gcc54 is not available anymore?

==> Error: Could not find all required packages: gcc54 (Wanted by: torch7-cunn-git)

Makes me wonder why it depends on a specific old version of gcc.