Package Details: torch7-cunn-git r819.1ae6aa0-5

Git Clone URL: https://aur.archlinux.org/torch7-cunn-git.git (read-only)
Package Base: torch7-cunn-git
Description: CUDA backend for Torch7 Neural Network Package
Upstream URL: https://github.com/torch/cunn
Licenses: BSD
Conflicts: torch7-cunn
Provides: torch7-cunn
Submitter: frantic1048
Maintainer: petronny
Last Packager: petronny
Votes: 4
Popularity: 0.000001
First Submitted: 2016-10-02 17:43
Last Updated: 2019-07-05 08:47

Dependencies (6)

Required by (2)

Sources (1)

Latest Comments

1 2 Next › Last »

chrhasse commented on 2019-04-11 04:59

Looks like the latest version of cuda supports gcc-8 and gcc-7 has been removed from community into the AUR so you don't need -DCMAKE_C_COMPILER=gcc-7 anymore.

frantic1048 commented on 2018-09-17 09:21

I'm sorry that I was testing on a machine not very up to date arch with gcc at version 7 and did not find the compiling error.

@petronny:

Yes, limiting compiler to gcc7 is needed. I'm testing now. BTW, I had set you as maintainer as this package. I'm not very fast on the response because of daily work, if you found a proper fix for the package, you could update this repo( ssh://aur@aur.archlinux.org/torch7-cunn-git.git ), too :)

petronny commented on 2018-09-17 07:48

Same as @flare561 . Setting compiler to gcc-7 works.

cmake . -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_C_COMPILER=gcc-7 -DCMAKE_BUILD_TYPE=Release

flare561 commented on 2018-09-17 04:11

Mine fails to build now because gcc versions later than 7 are not supported. I have gcc 8.2.1

frantic1048 commented on 2018-09-16 15:25

It looks gcc-5 is not need anymore during building, removed gcc54 makedep and gcc-5 flag.

frantic1048 commented on 2018-09-16 15:19

fuan_k: Makes me wonder why it depends on a specific old version of gcc.

Because it needs gcc-5 to build before, I'm checking if it's working with current gcc version.

fuan_k commented on 2018-09-16 14:59

Can't install, because gcc54 is not available anymore?

==> Error: Could not find all required packages: gcc54 (Wanted by: torch7-cunn-git)

Makes me wonder why it depends on a specific old version of gcc.

frantic1048 commented on 2018-05-13 16:37

依赖更新成 gcc54 了,现在没冲突了

frantic1048 commented on 2018-05-13 14:15

我看看能不能都用 gcc54

petronny commented on 2018-05-13 06:52

gcc5 和 cuda依赖的gcc54冲突了。。。